Apple ID login in macOS guest OS

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by JonC8, Oct 12, 2021.

  1. JonC8

    JonC8 Bit poster

    Messages:
    5
    I've been unable to login with an Apple ID in the Big Sur guest that is offered at Parallels install time. The error is the same for my normal Apple ID and one newly created from within the guest OS.

    Logging into iCloud from System Preferences generates a 'Verification error'. All generic stuff and seems to happen a lot with Apple devices.

    When I log into appleid.apple.com I can see that VirtualMac is a connected device, but I'm not logged into the OS.

    It feels like an Appel problem but wondering if the VM is causing something to fail?



    Screenshot 2021-10-10 at 19.45.jpg
     
    GabrielB10 likes this.
  2. Jeff Donovan

    Jeff Donovan Bit poster

    Messages:
    1
    Best Answer
    As an update, I was able to download the InstallAssitant.pkg for the Sonoma Developer Beta just released and, unfortunately, it does not yet fix the issues of being able to sign into your Apple account from the OS. There is a thread regarding this complaint on the developer forums that has been long-running and has been updated in the last day with the following (AppleID Login failing in virtualiz... | Apple Developer Forums):

    I got confirmation that the Apple ID story hasn't changed (r. 102844895). It's definitely a priority -- partly based on the number of bugs that you folks have filed! -- but, as always, I can't make any promises about The Futureā„¢.

    Share and Enjoy​

    Hopefully, with enough upvotes and feedback, this will become a priority and a solution before Sonoma goes Public Beta as this affects a lot of us and our multitude of use cases.
     
  3. JonC8

    JonC8 Bit poster

    Messages:
    5
    Parallels now support a Big Sur guest on an M1. There's also a downloadable image at install time.
     
  4. JonC8

    JonC8 Bit poster

    Messages:
    5
    Wondering whether this is some protection Apple use to identify genuine Macs?

    Code:
    akd: (AppleIDAuthSupport) [com.apple.AppleIDAuthSupport:general] SendRequestAndCreateResponse: submissing a request to: <private>
    akd: (AppleIDAuthSupport) [com.apple.AppleIDAuthSupport:general] -[AIASSession URLSession:task:didReceiveChallenge:completionHandler:]: checking pinning
    akd: (AppleIDAuthSupport) [com.apple.AppleIDAuthSupport:general] -[AIASSession URLSession:task:didReceiveChallenge:completionHandler:]: use credentials
    akd: (AppleIDAuthSupport) [com.apple.AppleIDAuthSupport:general] -[AIASSession URLSession:dataTask:didReceiveData:]: <private> got more data: 657 bytes
    akd: (AppleIDAuthSupport) [com.apple.AppleIDAuthSupport:general] -[AIASSession URLSession:task:didCompleteWithError:]: <private>: <private>: (null)
    akd: (AppleIDAuthSupport) [com.apple.AppleIDAuthSupport:general] SendRequestAndCreateResponse: completed request <private>
    akd: (AppleIDAuthSupport) [com.apple.AppleIDAuthSupport:general] AppleIDAuthSupport: setError: 2:selected protocol key missing
    akd: [com.apple.authkit:core] Authentication with server failed! Error: Error Domain=com.apple.AppleIDAuthSupport Code=2 UserInfo={NSDescription=<private>, Status=<private>}
    akd: [com.apple.authkit:core] Attempting to show login error: Error Domain=AKAuthenticationError Code=-7018 UserInfo={NSLocalizedDescription=<private>, NSUnderlyingError=0x13e821f80 {Error Domain=com.apple.AppleIDAuthSupport Code=2 UserInfo={NSDescription=<private>, Status=<private>}}}
    
     
  5. JonC8

    JonC8 Bit poster

    Messages:
    5
    Yeah my bad - VM is indeed a Monterey beta. After a call with Apple they pointed out that the VM serial number is invalid (well it would be, right) so that *could* be what is driving the log message. My guess is that a genuine Mac will have something that helps the authentication, perhaps as simple as a valid serial number and the VM does not. That does basically mean a macOS guest can't install from the Mac App Store which was the one thing I was trying to do.
     
  6. HaraldSt

    HaraldSt Member

    Messages:
    101
    Interesting, this looks like a bug. Looks like you have to look at the config file to fix.
     
  7. BenF7

    BenF7 Bit poster

    Messages:
    1
    Did you ever figure this out? I'm having the same problem.
     
  8. JonC8

    JonC8 Bit poster

    Messages:
    5
    Nope, I never did. I ended up using a Mac for testing. The Mac on Mac support is very new and very limited. There is now a KB article here - https://kb.parallels.com/125561 which includes no support for logging in with an Apple ID
     
  9. MarianD3

    MarianD3 Bit poster

    Messages:
    3
    I am having the same issue (parallels on M1)
     
  10. StuartW6

    StuartW6 Bit poster

    Messages:
    1
    Same issue here. TBH - not being able to log in with an appleid makes the VM useless for anything I wanted it for....... Hope support is added soon
     
  11. AlanW13

    AlanW13 Bit poster

    Messages:
    3
    Same issue here. This is a severe lack of functionality in Parallels.
     
  12. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    503
    Hello!
    Thanks a lot for the heads up! We've already reported the issue to our developers. They're researching the ways how we can address it and what's the root cause after all. We'll keep you posted!
     
  13. DarrenC4

    DarrenC4 Bit poster

    Messages:
    1
    Having the same issue. Makes Parallels unusable for me.
     
  14. Silvan1

    Silvan1 Member

    Messages:
    25
  15. AlessandroE3

    AlessandroE3 Bit poster

    Messages:
    1
    I have the same issue. It's important to have it solved!
     
  16. sylvain2

    sylvain2 Bit poster

    Messages:
    1
    Same here, I need to have a functionnal Mac OS vm.
     
  17. CaptainIndignant

    CaptainIndignant Bit poster

    Messages:
    1
    This appears to be a problem with Apple's new virtualization framework because there's the exact same problem with UTM and even with the text Xcode project Apple released. I am pessimistic it will be fixed before the MacOS 13 betas this summer but hope that Parallels has sufficiently escalated it with Apple that it gets fixed then!
     
  18. cryptoisfuture

    cryptoisfuture Bit poster

    Messages:
    1
    yes also me have this problem; please help
     
  19. Andreas Seeger

    Andreas Seeger Bit poster

    Messages:
    2
    I just wanted to confirm that this behaviour is still a thing with Parallels Version 17.1.4 (51567) running the first macOS 13 beta.
    Neither logging in to iCloud nor in to Feedback Assistant works.
    Sure feels like Apple is somehow detecting that the request is coming from a VM and preventing log in somehow.
     
  20. Andreas Seeger

    Andreas Seeger Bit poster

    Messages:
    2
    Also, I just tried using an App Specific Password-not that it would have been too logical for that to work-but I can report that this is not a solution neither...
     
  21. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    503
    Hello Andreas!
    We know about the issue and keep researching the ways to fix it together with the Apple engineers.
     
    Andreas Seeger likes this.

Share This Page