Applications/games not working on Windows on ARM

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by Mikhail Ushakov, Feb 10, 2022.

  1. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    173
    This thread has been created to let you share your experience and findings of working with third-party apps and games in Windows on ARM.
     
  2. SWANDY

    SWANDY Kilo Poster

    Messages:
    308
    Don't have a lot of game/apps installed (and the one's I do have work fine). Still issues trying to get Diablo II - Resurrected to install/run according to other people. Also there are still issues with the Xbox app installing games (though I think this is a Microsoft issue from what I have read). And obviously the issue with Bluetooth controllers like the Xbox controllers not connecting properly to the Windows 11 ARM VM which seems like Parallels even though I have Bluetooth Sharing turned on can't take control from the macOS side (I have Monterey 12.2) and switch it to the Windows 11 ARM VM side.
     
    Dmitry@Parallels likes this.
  3. soakingwetcat

    soakingwetcat Bit Poster

    Messages:
    2
    Flatout 2 shows blackened cars and the tracks load in black making it unplayable. Flatout 1 has some bad shadowing problems and is sort of playable. Both games want to run full speed - showing some promise. Just graphics problems.

    Love to see a Flatout 2 - my all time favorite racer working on Parallels.
     
  4. henrymonk

    henrymonk Bit Poster

    Messages:
    36
    Lost ark can't run on arm 64 issue
     

    Attached Files:

  5. HaraldSt

    HaraldSt Bit Poster

    Messages:
    85
    Interesting it does not run under Windows 11 x86 emulation.
     
  6. Parakek

    Parakek Bit Poster

    Messages:
    4
    Cyberpunk 2077 crashes on load.

    Anno 1800 works almost fine with "special" settings, but disc access seems extremely slow. Gameload takes minutes, savegame loads very slowly. Once started the game is playable but again: items on the map sometimes appear "late". This seems like an issue maybe easy to fix.
     
  7. LeeB10

    LeeB10 Bit Poster

    Messages:
    2
    Cisco vpn client can't install on M1, for x64 windows before install cisco i need to install dneupdate64 (citrix) , M1 cant install dneupdate64
     

    Attached Files:

  8. HidehikoT1

    HidehikoT1 Bit Poster

    Messages:
    1
    I'm trying out Parallels on M1 Mac mini and found "A-Tourism" doesn't work.
    It seems the textures on the ground corrupted. How to avoid this? I would like to buy Parallels if you can fix it.
    screenshot.png
     
  9. 沈明明

    沈明明 Bit Poster

    Messages:
    16
    Maplestoey does not boot properly after updating from x86 to x64 has tried all compatibility settings
     
  10. Deci

    Deci Bit Poster

    Messages:
    1
    Grow: Song of the Evertree is unplayable because large numbers of textures are missing, many surfaces are invisible, and a lot of light sources appear to be missing.
     

    Attached Files:

  11. JoeM31

    JoeM31 Bit Poster

    Messages:
    6
    Is the windows store included in the iso parallels makes you download? It isn't the last time I tried parallel on my Mac.
     
  12. SWANDY

    SWANDY Kilo Poster

    Messages:
    308
    That is strange because every VM that I made using Parallels over the years has had the Windows Store. I was under the impression that the Windows Store (assuming we are talking about the same app) was part of the Windows operating system - sort of like the App Store that Apple installs as part of macOS, iOS and iPadOS and tvOS.
    Don't remember if I ever used the download that is actually part of Parallels (as opposed to getting the installation files from Microsoft, purchasing a key or the UUPDUMP site) but I still always assumed it was part of the Windows installation files that Microsoft produces.
     
  13. JoeM31

    JoeM31 Bit Poster

    Messages:
    6
    It's missing from win11 arm preview.
     
  14. SWANDY

    SWANDY Kilo Poster

    Messages:
    308
    Do a search in the apps for "Microsoft Store". At least that's what it's called on my Windows 11 ARM installation.
     
  15. JoeM31

    JoeM31 Bit Poster

    Messages:
    6
    It wasn't there. Parallel has an article on this. But it's an old article.
    Don't matter anyway since I can't use this. What I want to do don't work. Guess it'll be years if ever till these issues are fixed.
     
  16. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    173
    Hello!
    If you download and install Windows using the 'Get Windows from Microsoft' option in the Installation Assistant wizard, the new VM will have the Microsoft Store working.
     
    icetear likes this.
  17. MarkD21

    MarkD21 Bit Poster

    Messages:
    1
    I use Parallels to be able to run Quicken for Windows. It has been working fine on my new M1 MacBook Pro for a week or two.
    Two or three days ago, Windows update installed Build 22563.ni_release.220219-1637
    Now, when I try to start Quicken, the Quicken splash dialog shows up, and that is it. Eventually Windows says it isn't responding and kills it, and sends Microsoft a report.
    Today, I tried uninstalling/reinstalling quicken hoping that would fix the problem, but it did not work.

    Any suggestions?
     
  18. icetear

    icetear Bit Poster

    Messages:
    12
    "Foundation" is not working due to missing OpenGL 4.3 Support.
     
  19. CliftonY1

    CliftonY1 Bit Poster

    Messages:
    1
    Windows 11 arm64 on Apple M1 MAX Chip (MacBook Pro)
    Parallels version 17.1
    Windows 11 installed thru Installation Assistant
    Confirmed (Windows -> System -> About) that Processor is 'Apple Silicon 3.2GHz (4 Processors)
    Install SQLServer Management Studio (SSMS) failed.
    Install SQLServer 2019 Express failed.
     
  20. SWANDY

    SWANDY Kilo Poster

    Messages:
    308
    Microsoft Links 2003. Game will install fine, but after playing around with the various resolution settings within the game the game will just quit. When I try to restart it I will get an error message saying "Cannot fine Language.dll in Program Files (x86)\Microsoft Links\Assets\Binaries" but when I check the folder the requested file is there.
    If I run the Troubleshooter it changes the file properties to emulate either Windows Vista, Windows 7 or Windows 8 but the same result occurs.
     

Share This Page