Applications/games not working on Windows on ARM

Discussion in 'Parallels Desktop for M Series Mac' started by Mikhail Ushakov, Feb 10, 2022.

  1. Sidneyp

    Sidneyp Bit Poster

    I use Parallels to be able to play on Steam. It works fine on many games on my M1 MacBook Pro.
    But in some games I have an FPS rate of around 10 and others are shifted like in the picture.
    I changed some settings in Steam or Parallels. Nothing helped. Do you maybe have a tip?
    I use Windows 11 ARM.
    Bildschirmfoto 2022-06-22 um 12.38.16.png

    Attached Files:

  2. FMonk

    FMonk Bit Poster

    The only thing that's worked for me is setting the CPUs to 8 and the memory to 32 GB (this is the most you can give Parallels on ARM right now). It worked for Starship Troopers (the new one) but didn't work for Call to Arms.
  3. JohnS116

    JohnS116 Bit Poster

    Window 11 Pro on Apple M1Max chip Macbook Pro Parallels 17.1.4
    Autocad Architecture crashes constantly and this is reply from AutoCad tech support after days of troubleshooting:

    thank you, John!

    Unfortunately, this type of virtual installation does not meet the system requirements for using AutoCAD Architecture 2023 or 2022 (which doesn't mean it can't work). Using AutoCAD or AutoCAD based products via Parallels on an M1 chip can cause instabilities or rough commands, other users have reported this in the forums.

    It may be worthwhile to make sure that Windows is up to date as well as any drivers that can be handled by Parallels. You can also try disabling folder sharing in Parallels settings.

    Otherwise, it might be best to contact Parallels, because indeed, Autodesk provides technical support to ensure that your software is working properly, but this does not include your virtual environment.

    Thank you very much.
    Best regards,
    Autodesk Expert
  4. 沈明明

    沈明明 Bit Poster

    How does Parallels modify virtual machine configurations to bypass virtual machine detection for some games? I think Parallels officials need to provide a way for paying users
  5. RonanA

    RonanA Bit Poster

    Fall Guys does not launch on Windows 11
  6. TracyN


    I keep reading that GTA 5 works, but I'm having no luck running it. I'm using the Steam version with Rockstar Launcher. Game starts and you see the lights and sirens intro and then it crashes after about 5 seconds consistently. I've tried everything that Google has suggested with no luck.
    Running 2020 MacBook Air with M1 chip.
    Parallels Pro Edition Version 17.1.4 with Windows 11 ARM.
    Crash Log: [crashdetection] Exit code 0xc0000005 indicates a fatal game exit (reason: STATUS_ACCESS_VIOLATION)
    I feel it's a graphics setting, but I see very little you can adjust on these M1 machines.
    Also, currently running everything with Admin privileges.
    Thanks for any help you can offer.
  7. RTsui


    I am contemplating a new Mac to replace my 2012 MacBook Pro. There is a crucial software - Turbotax standard (Canada) version that is available in Windows only. Have someone by chance try this software and can provide feedback? I don't want to get a second windows laptop just to run this. Thanks.
  8. JoachimV

    JoachimV Bit Poster

    Stray does not work on parallels 17.1.4.

    Can we expect a fix?
  9. JimC15

    JimC15 Bit Poster

    I have seen a previous post that someone was able to run TurboTax. Tryin searching the feeds.
  10. SeanP9


    I just tried Assassin's Creed Odyssey - crashed on launch. :(
  11. yejoons

    yejoons Bit Poster

    i want to do overwatch and fallguys things. but the overwatch cant play like normally and i cant road fallguys in steam
  12. EvgenyT

    EvgenyT Bit Poster

    Is it possible to Launch Disciples 2 or Diablo 2 remastered ?
  13. SWANDY

    SWANDY Kilo Poster

    Not on my M1 iMac running P18 and Windows 11
  14. JimChiu

    JimChiu Bit Poster

    While installing SQL 2022 preview > Choose Basic installation option, it will fail to install SQL 2022. =(
    Does anyone successfully install SQL 2022 + Visual Studio 2022 with PD 18 on Apple Silicon machines? Thanks.
  15. charliem4


    I attempted to install F1 Manager 2022 via stream on parallels 18 today on my M1 Max Macbook Pro. It installed fine, but there was an unreal engine crash before the game even finished loading.
  16. RichM6

    RichM6 Bit Poster

    PowerWash Simulator was working fine under Parallels 17.x, but upgrading to 18 seems to have broken the game's ability to register progress. I touch any surface with the water and the entire surface loses its dirt texture, but none of the progress bars register any cleaning progress. Steam says all the game's files' integrity are fine, but the game's unplayable. I suppose I could try a reinstall, but it was the installation of Parallels 18 that seems to have caused the breakage.

    2020 8 GB M1 Mac Mini, Monterey.
  17. PierreC12


    Dear Sami,
    I am facing the same issue.
    Did you receive any answer from Palisade?
    All the best,
  18. MobinZ

    MobinZ Bit Poster

    Windows 11 ARM64 on M1 air
    Metatrader 5 keeps crashing
    I used to use metatrader 5 in PDinstalled on windows 11 on m1 mac. Everything was working properly until I was forced to change my version of PD from the app store version to the downloaded version from the website. after that metatrader installed successfully but keeps crashing when trying to resize the window or use strategy tester.
    After that nothing could stop crashing this software. I changed back PD to the app store version and even factory reset my mac and installed PD again. but the problem is still there.
  19. JonathanA10

    JonathanA10 Bit Poster

    Total War Warhammer 3 worked fine until the 2.1 patch, now it won't launch. The app will start, but is killed after 10-15 seconds.
  20. SamiA4

    SamiA4 Bit Poster

    Pierre: Palisade said it is not their problem! It is somehow between Microsoft and Apple ... I wish Parallels would come up with a workaround. Not sure if version 18 will solve the problem.

Share This Page