Applications/games not working on Windows on ARM

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by Mikhail Ushakov, Feb 10, 2022.

  1. JonathanA10

    JonathanA10 Bit Poster

    Messages:
    11
    Gaming issues could very well all have to do with DirectX compatibility. Since parallels dropped support for Windows 10, and Windows 11 using DirectX 12, it breaks a lot of things that used to work. The Crossover folks have a good article about what's holding up DirectX12 support. Metal3 will hopefully bridge this gap close enough so that DirectX support can be added:
    https://www.codeweavers.com/blog/cj...etting-there-crossover-support-for-directx-12
     
  2. ollie3

    ollie3 Bit Poster

    Messages:
    2
    Having the same issue. Very frustrating
     
  3. SWANDY

    SWANDY Kilo Poster

    Messages:
    292
    Anyone lately had any success getting the old MS Links 2003 game to run under Parallels 18/Windows 11 ARM? I have not tried for a few months and curious if it is worth trying again. (I also tried under Crossover and couldn't get it to work properly there either.) Thanks.
     
  4. DouglasK5

    DouglasK5 Bit Poster

    Messages:
    2
    I created a ticket with Parallels and contacted Palisade support. IMO it is a Palisade problem. Clearly Windows and Parallels work great on M1 and M2 Macs. Palisade needs to fix their software to work in the environment. Why did it work on Intel VMs? Anyone have solutions to move away from Palisade? What a waste of a license payment. I'd like something native to Mac.
    .
     
  5. PaulD27

    PaulD27 Bit Poster

    Messages:
    2
    Hello.

    I have a Mac with an M1 Pro processor. initially, I had Parallels Desktop 17.1.2 and Windows 11 Pro ARM installed.
    In the Windows virtual machine, I installed the Realtime Landscaping Architect 2020 program and the "Realtime Walkthrough" function I needed worked in it.

    I recently upgraded to Parallels Desktop 18.0.2 and the "Realtime Walkthrough" feature stopped working. I launch Realtime Landscaping Architect 2020, click View -> "Realtime Walkthrough" -> Ok at the top and a window appears on my screen with information that an error has occurred in the program.

    I have updated all Visual C++ x64 x86 libraries to the latest versions, and also reinstalled the Realtime Landscaping Architect 2020program, but this did not solve the problem.
    When I removed Parallels 18.0.2 and installed version 17.1.2, the "Realtime Walkthrough" function became functional again.


    I hope you will be able to fix this problem. I used the latest version of the Realtime Landscaping Architect program. Here is the official website
    https://ideaspectrum.com/professional-landscape-software/
     
  6. ChrisStitches

    ChrisStitches Bit Poster

    Messages:
    2
    I'm running Wilcom Embroidery software (Windows) and it requires a dongle by Aladdin. The company basically says tough nuggets we don't support Mac BUT they know that it's a Mac M1 issue. Parallels sees it, my M1 Mac sort of sees it, as it it recognizes that it is attached and beyond that nothing when it tries to authenticate. While not strictly a Parallels issue I thought I'd toss it out there JUST IN CASE. TIA
     

Share This Page