Audio popping and stuttering with new Windows 11 ARM insider preview update

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by JeffreyW1, Nov 18, 2021.

  1. JeffreyW1

    JeffreyW1 Bit Poster

    Messages:
    6
    Windows 11 ARM insider preview updated in the past day to Build 22504.rs_prelease.211112-1650 - I'm using latest Parallels with MBP M1 Max.
    Working in Windows through Parallels with audio playback today has been difficult with tons of popping and clicking no matter the output or settings in windows (or in Parallels config). I'm using wave files. I changed the sound settings in Windows 11 to match my 16 bit, 44.1K files to test. Nothing seems to improve it. The audio stutters at times too. It was fine before the Windows 11 update. The audio files play fine on the Mac and in another licensed copy of Parallels on Mojave in Windows 10 (retail). Very strange. Anyone else?
     
  2. SamS4

    SamS4 Bit Poster

    Messages:
    61
    Thanks for posting this. I have the same problem and its existed since the last update.
     
  3. JeffreyW1

    JeffreyW1 Bit Poster

    Messages:
    6
    Thanks for confirming. I tried all last time to fix it. I thought I was losing my mind.
     
  4. JeffreyW1

    JeffreyW1 Bit Poster

    Messages:
    6
    I installed Parallels 17.1.1 moments ago. Very random audio stuttering still exists in Windows 11 ARM (wave files in an app called Karaoke Builder...which I use nearly daily). I'm pretty sure it's the Windows 11 ARM Build 22504.rs. No problems at all in Windows 10 on Intel mac
     
    SamS4 likes this.
  5. JeffreyW1

    JeffreyW1 Bit Poster

    Messages:
    6
    I just received Build 22509.rs and the stuttering is still there too! Even worse now in this version. Freeze/stutters every couple of seconds as wave audio plays! UGH It's completely useless as it freezes the timing of the song as it plays too! Anyone else? Same thing playing wave audio in Windows Media Player.
     
  6. WesleyP1

    WesleyP1 Bit Poster

    Messages:
    5
    I've been having issues with crackling audio when playing back audio in foobar2000 in windows 11 in parallels on a m1 mac as well, anyone found a solution?
     
  7. PeterH11

    PeterH11 Bit Poster

    Messages:
    9
    I do exactly the same in on my Mac - Windows is installed mostly so that I can use foobar2000!
    I was able to minimise the audio issues by changing the Sound Output in the settings for the VM to directly address the specific soundcard rather than Default (even though the Mac is also set to use that soundcard). I have not yet tested this with "MacBook Pro Speakers" though, as I'm using a USB soundcard (see screenshot).
    It's gone from quite ugly crackling when Parrallels is in the background to being very stable (although occasionally I get a small pause or gap).
     

    Attached Files:

  8. WesleyP1

    WesleyP1 Bit Poster

    Messages:
    5
    It makes me happy to know I'm not the only parallels foobar guy! Thanks for the advice but I think I'm still having the same issues even with the output selected as you suggested. Also would want to clarify that the audio issue is also present when playing back audio from other sources (such as simply playing youtube videos in firefox). Would really love to get this fixed.
     
  9. WesleyP1

    WesleyP1 Bit Poster

    Messages:
    5
    Ok so I've done some more trial and error and installed a windows 10 vm and the problem remains. For the record I'm on the latest version of parallels (17.1.1) with a pro subscription.
     
  10. PeterH11

    PeterH11 Bit Poster

    Messages:
    9
    Yes, from what I've seen in another thread, it was introduced or exacerbated in the latest Parallels version, so maybe we can hope that another update will fix it.
    I feel like something like a virtual audio device which you could set your Parallels output to would help, but it seems like slim pickings - Loopback is quite expensive for just testing this!
     
  11. PeterH11

    PeterH11 Bit Poster

    Messages:
    9
    OK well I realised Loopback has a trial period, so I tried it, and it doesn't help. Oh well.
     
  12. WesleyP1

    WesleyP1 Bit Poster

    Messages:
    5
    I have found a fix that seems to work for foobar2000 only, but I'm pretty sure the problem remains in other apps. In foobar2000, add the wasapi output component and change the output to WASAPI Speakers in the fb2k settings. It's possible that this could hint at a systemwide solution for the issue, though I haven't done any further testing.
     
  13. PeterH11

    PeterH11 Bit Poster

    Messages:
    9
    Wow that's stunning, Wesley. Perfect sound from foobar2000.
    I tend to do browsing and play videos in the host OS anyway. Only otherwise Steam, which I would only use while Parallels is in focus, but I'll have to confirm whether it's stable.
    Anyway, a thousand thanks for this very clever workaround and foobar-user high-fives!
     
  14. WesleyP1

    WesleyP1 Bit Poster

    Messages:
    5
    Hey no problem! Glad it worked for you too.
    I tend to pretty much exclusively use my vm's for foobar as well, though it'd be great to have this fixed in the future.
     
  15. RalfM7

    RalfM7 Bit Poster

    Messages:
    3
    Maybe I've found a solution for the sound problems.

    Windows 11 automatically sets the sound output settings to 32Bit 48000Hz. Changing that to 24Bit or lower eliminates almost all audio crackling on my M1Max (playing audio form Spotify web player).

    You can change it in settings under "Sound -> Speaker"
     
  16. PeterH11

    PeterH11 Bit Poster

    Messages:
    9
    Unfortunately I still get the glitches/crackling playing a YouTube video (1440p) even with sound set to 16bit & 44.1K.
     
  17. sounds

    sounds Bit Poster

    Messages:
    4
    see my post here - I think it may be a deeper issue than just audio driver ?
     
  18. JeffreyW1

    JeffreyW1 Bit Poster

    Messages:
    6
    I FIXED IT! After receiving countless Windows 11 ARM insider preview updates since audio stuttering started before Thanksgiving (the original download was perfect when I first installed it...only after updates did this issue start), I got another update last night and the stuttering was still there. I search the post directly above here (posted Jan 2, 2022) that led me to look at the Parallels Hardware/CPU & Memory setting. I unselected Automatic (recommended) and chose Manual. I have a 16" M1 MacBookPro with 64 GB and 10 cores (which include 2 efficiency cores) with plenty of room to 'play'. So I changed the CPU setting manually to 4 processors and 16 GB plus also clicked on Advanced and unchecked the Hypervisor for the heck of it. Now, I really didn't know what I was doing, but I figured as a test, the computer would remain within the main 8 cores and possibly the stop it from going into the 2 efficiency cores...but no clue if it would When I rebooted Windows 11 the audio was perfect...and has been perfect for the last 24 in every program I use plus in the Windows Media Player. NO STUTTERING AT ALL. As I said, I got it to sound perfect by just 'taking' a shot' with those settings, so I would advise others to change and adapt as needed in they try this method. Maybe it wasn't a Windows 11 issue for me. I've been a very happy camper in the last day!
     

Share This Page