Beta 4 - Macbook Pro bridged networking with en1 (wireless) problem

Discussion in 'Parallels Desktop for Mac' started by VTMac, Apr 18, 2006.

  1. VTMac

    VTMac

    Messages:
    340
    On beta 4 if I try to use bridged networking and I'm switching back and forth between my OSX (Camino) browser and my WinXP (IE) browser, the network drops. What is very odd is this is only happening with HTTP and HTTPS. Other protocol don't seem to have a problem sharing. If I wait 30-60 secs after switching one or the other returns.
     
  2. GlennF

    GlennF Bit Poster

    Messages:
    2
    Beta 4 disable wireless en1?

    I'm not able to connect the network at all with a bridged setting that worked in beta3. My Network Adapter in Parallels Workstation beta 4 is set to Bridged Ethernet with en1, which I have confirmed is an active Wi-Fi network. Within Windows, the Ethernet connection is shown as active, but is has no IP information in the status view, and it cannot be repaired. The error: "Failed to query TCP/IP settings of the connection. Cannot proceed."

    For some reason, 802.1X authentication was checked and I unchecked that. The network didn't work before nor after that was checked.

    Everything worked fine in beta 3, however.
     
  3. VTMac

    VTMac

    Messages:
    340
    Yep. I'm now in the no network category. It seems beta 4 has taken a step backwards with respect to WiFi networking. Can't try wired networking yet .. but I'm using a Macbook and I'm mobile, so that isn't really a viable option anyway.
     
  4. STim

    STim Super Moderator

    Messages:
    942
    Sounds like a serious problem.

    Please keep networking problems posted here. And please, as much details as possible. We'll do our best to investigate.
     
  5. VTMac

    VTMac

    Messages:
    340
    I'm thinking it might have to do with amount of traffic. I just noticed Windows Update is busily downloading a bazillion updates. I'm hoping when it finishing (which will be about 10 hours at the current rate of losing and regaining connection) it will stabilize.
     
  6. VTMac

    VTMac

    Messages:
    340
    Are there any log files that I can look though to figure out what's going on?
    When the connection drops, ipconfig still returns valid info. I can still ping other machines on my lan. But HTTP just won't work. This is happening like every 3 minutes. Then it won't work for 3 minutes. Then it works. Then it doesn't.
     
  7. smpdigital

    smpdigital

    Messages:
    9
    So I use networking (en1 WiFi) a lot on my VM and I don't care about full screen, I just prefer a windowed VM, should I stay away from beta4?
     
  8. controller

    controller

    Messages:
    20
    wifi networking has not worked on my MacBook Pro on any beta for me, even beta4.
     
  9. dhjdhj

    dhjdhj

    Messages:
    220
    I have had no problems with wifi networking since the original beta. I'm on a MacBook Pro as well.
    D


     
  10. ivel

    ivel

    Messages:
    33
    i'm on a macbook pro as well (1.83/1/80) and i have had no problems; even with beta 1.
    Are you using some sort of encryption on your WIFI? I am and i have no problems at all. I also have used en0 and had no problems from the begining too! Please add details to your post so those of us who are not experiencing problems can compare and contrast against your system.

    -Levi
     
  11. divsorbit

    divsorbit

    Messages:
    6
    VPN issues


    I am trying to connect to work from home using VPN. We have a sonicwall vpn router at work. I have all the settings correct but no connection. However, I can browse the internet in my VM wirelessly.
    Any ideas?
     
  12. VTMac

    VTMac

    Messages:
    340
    I'm using a MBP 2.0 / 2G
    I'm using a home and work Wifi. Both use WEP.

    Now that Windows Update has finished, I'm not seeing the problem. So, I now think it could be any of the following:

    1) Windows Update was loading the network driver in a way that made it unhappy. (I actually had to plug into eithernet and reset my network connection from en1 to en0 to get windows update complete.
    2) Resetting form en1 to en0, saving, resetting back to en1, saving, somehow fixed whatever was wrong.
    3) The Windows Update files in some way made the Parallels drver more stable.
    4) I disabled sound. (I have not clue how this would affect things, but I did it so I listed it.)

    In any case, I haven't been having the dropout for a few hours now. I'm not sure what exactly fixed it, but I'm happy. Hopefully the Parallels test team can isolate whatever the cause was from above. Even if it is 3 it would be nice to know in advance you must install XP using en0 and get all the various Windows updates before using en1.
     
  13. horald

    horald

    Messages:
    7
    It may be caused by VPN.

    I had the same problem. Even win xp had an IP address, router and gateway address, I couldn't ping between the host and guest systems. But when I quited the VPN(CISCO), the connection was back.
     
  14. serv

    serv Parallels Developers

    Messages:
    809
    VTMac,

    Could you please elaborate on your en1 problem a little more
    to help us understand it better:
    - What was the exact version of Windows you were updating? How much data
    Windows Update reported it needed to download?
    - Are you aware of any traffic shaping/limiting your router may be configured
    to enforce?
    - Have you tried accessing other web sites (either with IE from inside VM,
    or with Safari) when Windows Update was in progress and you experienced
    network dropout?
    - Have you noticed signal strength level of your AirPort connection at times
    of network loss?
     
  15. VTMac

    VTMac

    Messages:
    340
    I was installing WinXP Pro with SP2.
    So I was getting every SP and patch since SP2 via Windows update. I didn't notice how much data it was in total. I think it was over 40 updates. Also, while this was downloading, I had installed Office 2003 + MS Project 2003 + Vision 2003. I *think* that MS Update was pulling updates for these apps as well.

    We ahve no traffic shaping / limiting on our router.

    When the issue occurs, I can use Safari (or Camino or Firefox) from within OSX to access other sites. Sometimes there is a small delay (5 sec) but it works. Using IE in the VM, it plain didn't work at all. But if IE didn't work, I'd check windows update and it would be stalled as well. Then I'd ping my second machine and I'd get responses. I'd try IE again - nothing. Look at windows update - still stalled. Wait 1-5 minutes and the network would return.

    I do track my signal strength. It happens I'm sitting less than 8 feet from the AP with direct line of site. So that isn't the issue.


    BTW, I had said previously it appeared that once Windows Update was finished the connection stabilized. It appears I spoke prematurely, or at least jinxed myself. I was having the same problem again yesterday afternoon. I'm now experimenting with the MTU trick mentioned on another thread to see if that helps.
     
  16. serv

    serv Parallels Developers

    Messages:
    809
    VTMac,

    Actually I'd not recommend adjusting MTU because there's no good technical
    reason why this would solve the problem. MTU may (or may not) only slightly
    remote the problem by implicitly lowerig TCP bandwidth.

    If you're willing to experiment we may try to figure out what really happens.
    At the time of network loss in an XP VM issue the following commands:
    ping <the site you were accessing>
    ping <your router>
    netstat -s
    arp -a
    nslookup <the site you were accessing>
    Also ping your router the site you were accessing from Mac OS X. And lets see
    if there's something interesting in Mac OS X log:
    tail /var/log/system.log

    Thanks
     
  17. nasp

    nasp

    Messages:
    2
    No problems with en1 on MacBookPRo

    I have no problems using dhcp under WinXP but dhcp do not work under SuSE Linux 10.0.

    Under SuSE Linux 10.0 works fine with static IP settings.
     
  18. serv

    serv Parallels Developers

    Messages:
    809
    VTMac,

    one more little thing... Is it possible that there's an IP address conflict? I.e.
    some other machine is using the same IP as the VM. To make sure do the
    following:
    - verify VM IP address by issuing "ipconfig" in XP
    - Disable VM networking. Click Devices menu, then Network -> Disconnect
    - in Mac OS X Terminal issue
    sudo arp -d <VM IP address>
    You'll be prompted for password here. Then
    ping <VM IP address>
    You'll see responses in case of a conflict.
    - Enable VM network. Devices -> Network -> Connect
     
  19. Drewmangroup

    Drewmangroup

    Messages:
    30
    I have a Macbook Pro 1.83/1.5 and have no problem with Wifi (to be honest i haven't really given it much of a workout). I use WEP. I don't do much browsing because I can do that in OSX. It downloaded 7 updates yesterday and had no problems. On a new install i would reccomend autopatcher so windows update isn't trying to download for days. I am using XP Pro Sp2.
     
  20. mglerner

    mglerner

    Messages:
    8
    Trouble with WPA encryption on 2GHz/1GB MBP OS10.6 WinXP SP2+updates

    (Trouble with WPA encryption on 2GHz/1GB MBP OS10.6 WinXP SP2+updates)

    With Beta 4, wireless works fine on my machine when connecting to an unencrypted network. It doesn't work at all for me when connecting to a WPA-encrypted network. The connection status says

    "You might not be able to access the Internet or some network resources. This problem occurred because the network did not assign a network address to the computer."

    This network works fine for OS X and for Win XP under Boot Camp.

    I'll be happy to provide any additional details, run diagnostics, etc.

    Thanks,

    -michael
     

Share This Page