Beta 4 - Macbook Pro bridged networking with en1 (wireless) problem

Discussion in 'Parallels Desktop for Mac' started by VTMac, Apr 18, 2006.

  1. VTMac


    I will try to above tests tomorrow. For what it's worth, changing MTU had no impact. I was out of the office today at another site on a open (no security) 802.11g wifi and had the same problems I'm having at work. Oddly, I don't seem to have this issues at home. But then at home I really don't use XP much at all. I'll report the results tomorrow. This is very, very easy for me to reproduce.
  2. earthling



    I am essentially having the same problem. When the networking is failing I can ping any machine on the network on the near side of the router (no ip conflict, routing is working). I have a windows box sitting right next to my mbp running parallels and I can directly compare the network information.
    netstat -s and arp -a do not return anything except what you would expect. When the network is not working a lot of datagrams go out, none come back unless I am pinging the local network. arp -a shows the same thing on both the mbp and the windows box sitting next to it.

    After a few minutes the networking will just suddenly start working. The next step would be to stick a packet sniffer on the back of the wifi access point but I don' t have time for that before I leave for on vacation.

    Ping (fails)
    ping internet network systems (works)
    ping VM from other systems (works)
    ping router (fails)
    ping router from other systems (works)
    ping router from OSX (works)
    nslookup (fails to resolve server)
    nslookup from osx (works)
  3. serv

    serv Parallels Developers

    VTMac and earthling,

    Thanks for your persistence and help. Just one more simple check before we
    go into network sniffing... Do you configure your guest XP with static IP or DHCP?
    If you've assigned static IP address to your VM, do you have DHCP enabled on the
    router? If your static IP falls into the range of router managed addresses that may
    pose the problem.
  4. ppayne


    I am also having problems

    Before (in ver 1 & 2), I could get networking properly when it dropped out (after restarting) by opening the local area connection, disabling it, opening it again (which enables it), then hitting Repair. That was with XP. Now I'm using ver 4 of the Parallels program and Win 2000. After I ran two sets of Windows Update, which worked normally, my Internet is gone bye-bye (no connection from the PC). I can't repair it since that option doesn't exist in Win2000, and disabling and enabling it does nothing.

    Can you help?
  5. VTMac



    I have identical results to earthling.
    I am configured as DHCP.
    BTW .. this seems oddly cyclical. Since I've been testing this for about 45 minutes, it drops ever 3-5 minutes and comes back after 2-3 minutes. Strangest thing I've ever encountered.
  6. eudyptes


    Depends on the router?

    I cannot seem to get my MBP to connect to my network at work through en1 (airport) but it seems to work fine when I'm at home.

    I can connect to my network at work using en0, and since both wifi and wired use the same DHCP server I'm pretty sure it's not a DHCP server issue.

    One difference is that at work the wireless network uses a netgear WGR614 router while my home network uses a Linksys WRT54G.

    I don't know why that would make a difference but I figured I'd throw it out as a data point in case anyone else sees anything similar.
  7. MicroDev


    I'm running fine with WiFi using WPA encryption. I have multiple Netgear access points and a Windows 2003 server backbone. The access points are scattered over the network in various areas (nothing is connected directly to a server or machine). I simply picked the wireless adapter to use for the bridge (en1: Airport/Wireless Adapter). When I'm onsite at a client, I switch that to the (en0: Ethernet Adapter) before starting the VM. It seems to work just fine (did in B3 too). I even run Cisco VPN software (in the VM and separately in OS X) for hours at a time and with very heavy traffic on both sides. My wireless net is setup fo 10g only also.

    Check the authentication mechanisms in Windows. It should read as a Parallels network adapter (assuming you installed the included tools). If you are running the stock out-of-the-box adapter, then yes, it was a little unstable for me too. BTW, my Windows connection is firewalled and all options are at the default settings.

    One other thing to check is that you are not using the same host name for the OSX and guest OS. That would confuse the DHCP and DNS servers (depending on your setup). Here, we use Windows DHCP and DNS from a Win2003 server. If you did use the same names, release the IP from both sides, if possible clear the reservations from DHCP, and try again. Also, check your signal strength from OSX and make sure you are not picking up more than one access point (try using the AirTraffic Control widget to check).

    MacBook 2.16
    OS 10.4.6
    Parallels b4
    XP SP2
  8. Daktari


    Wireless: what worked for me....

    Using a Macbookpro upgraded from the first public beta to the current, with WinXP as the guest OS. I have never had wireless working. Deleting the network adapter in the porperty page, saving and starting up windows, shutting down then reinstalling it and my wireless is working perfetly! I havent tested it yet at school where i have to login to the network.

    Finally, Woohoo! Now i can do all the stupid stuff i could never doo, such as watching music videos o n yahoo and mtv.

    I love parallels wont even bother with bootcamp!
  9. earthling


    In my case both the VM and the host and every other machine on the network for that matter is set to DHCP. Like I said, if I am patient enough it starts working all of a sudden. Also, I did find some time to run TCP dump on OSX so I will post that in a separate message.
  10. earthling


    6 is my main router (zyxel) is a windows box on my network is the Windows XP VM is the OS X host system

    As you can see from the tcpdump output below the OS X host can ping anything on the network including the router (networking is just fine). The windows VM can ping any other machine on the network but not the router.

    Windows VM attempting to ping the router

    15:57:49.427178 IP > ICMP echo request, id 512, seq 13568, length 40
    15:57:54.963549 IP > ICMP echo request, id 512, seq 13824, length 40
    15:57:59.957849 IP > ICMP echo request, id 512, seq 14080, length 40
    15:58:17.335145 IP > ICMP echo request, id 9473, seq 0, length 64

    OS X Host pinging the same router

    15:58:17.378741 IP > ICMP echo reply, id 9473, seq 0, length 64
    15:58:18.335342 IP > ICMP echo request, id 9473, seq 1, length 64
    15:58:18.516340 IP > ICMP echo reply, id 9473, seq 1, length 64
    15:58:19.335519 IP > ICMP echo request, id 9473, seq 2, length 64
    15:58:19.337561 IP > ICMP echo reply, id 9473, seq 2, length 64
    15:58:20.335692 IP > ICMP echo request, id 9473, seq 3, length 64
    15:58:20.461964 IP > ICMP echo reply, id 9473, seq 3, length 64
    15:58:21.335936 IP > ICMP echo request, id 9473, seq 4, length 64
    15:58:21.337962 IP > ICMP echo reply, id 9473, seq 4, length 64
    15:58:22.336131 IP > ICMP echo request, id 9473, seq 5, length 64
    15:58:22.508426 IP > ICMP echo reply, id 9473, seq 5, length 64

    16:03:14.131620 arp who-has tell
    16:03:14.133494 arp reply is-at 00:11:11:40:f4:9e (oui Unknown)

    Windows VM successfully pinging another windows box on the network (wireless to wired lan) followed immediately by an attempted ping to the router

    16:03:14.134136 IP > ICMP echo request, id 512, seq 14336, length 40
    16:03:14.135636 IP > ICMP echo reply, id 512, seq 14336, length 40
    16:03:15.213359 IP > ICMP echo request, id 512, seq 14592, length 40
    16:03:15.214934 IP > ICMP echo reply, id 512, seq 14592, length 40
    16:03:16.098459 IP > ICMP echo request, id 512, seq 14848, length 40
    16:03:16.202709 IP > ICMP echo reply, id 512, seq 14848, length 40
    16:03:17.010453 IP > ICMP echo request, id 512, seq 15104, length 40
    16:03:17.012016 IP > ICMP echo reply, id 512, seq 15104, length 40
    16:03:27.927103 IP > ICMP echo request, id 512, seq 15360, length 40
    16:03:33.074081 IP > ICMP echo request, id 512, seq 15616, length 40
    16:03:38.946370 IP > ICMP echo request, id 512, seq 15872, length 40
    16:03:43.955712 IP > ICMP echo request, id 512, seq 16128, length 40
  11. earthling


    had to be 2 minutes after posting this that all of a sudden the networking started working on the windows side. too bad I had shut off tcpdump (DOH!)
  12. backtothemac


    Well, I cannot connect with it at all. Worked in Beta 1, 2, and 3, and now nothing. Weird. I can't get any connection no matter what I do. It is strange really.
  13. VTMac


    Same with me. Everytime I'm ready to capture something, it's not working. This is a really nasty little bug.

    One thing I noticed, which I'm not sure if it matters, is that in Windows Device Manager, it reports the Network Card as Parallels. In the Parallels Manager is says the Parallels Network is enabled. But if I hover my mouse on the network icon on the vm window on the bottom right, it reports RealTek.

    Maybe something isn't fully setup right??? Or maybe this is just a bug in the bubble text.
  14. VTMac


    Just wait 5 mintues .. seriously. Unfortuately it will only work for 3 minutes before you have to wait another 5 minutes.
  15. chartb


    My network is solid when it's working, but can't connect to all wireless authentication types.

    At home: WEP128 and WPA Personal work fine... I can get a DHCP address and do everything on the XP install.

    At work: WEP128 works as expected, but WPA Enterprise does not... the OSX side can get a DHCP address after authentication, but the XP guest never gets a DHCP address.

    Also, when attempting to connect at a hotel which is using (presumably) a radius server (where you have to go to a browser, hit 'ok' to accept thier terms, and then are allowed onto the 'real' network), the XP guest never even gets an initial DHCP address. Restarting the XP guest after going through the web-based connection in OS X did not help the problem.

    Anyone got this working on a hotel or coffee shop type access point?

    en0 connections always work fine. Yay.

    I'm assuming that the authentication mechansims are tied to MAC address or such, and having a different MAC address in the XP guest than the OS X means that packets are not being accepted at the router... I'm really not a network person, though, so I may be talking out my butt...

    Macbook 2.16, 2GB, 2.6.4 updated. Using Beta 4. Guest is XPSP2 updated, with tools installed and using Parallels net adapter.
  16. adamsfbay


    WiFi problem with MacBook Pro & iMac

    On both my MBP and iMac I get assigned the appropriate IP address (I use fixed IP bound to each MAC address), and the DNS gets passed as well, but no internet activity. I run WPA/WPA2 security, but the problem remains even if I go without any security at all. For wireless I use an Airport b/g connected into a firewall router connected into my cable modem. Devices on the WiFi network go in the 10.0.65.x range.

    Both computers work fine wiht the en0 ethernet option. They get assigned static IPs, bound to their MAC, and perform flawlessly in this setting.

    As an aside, I've found on my network that my PCs can use WPA (TKIP) but not WPA2 (AES).

    I sure hope this gets resolved in the next version. This solution is great, but on my iMac particularly I must run wireless.

  17. backtothemac


    Team is there any news you can give us on this. Or can you provide us a link to go back to beta 3? I want to keep testing the software, but I cannot use beta 4 as I have to have an internet connection.

    Thanks for all the great work.
  18. adamsfbay


    MBP/iMac wireless networking fixed


    I had written previously about not being able to use en1 wifi networking in parallels.

    I had some ARP entries sent in my router/firewall that, once removed, allowed both my iMac and MBP to connect wirelessly without problems.

    I have static IPs assigned to both the physical machines (and MAC for each machine) and the virtual machines (and MAC for each virtual machine).

    So, the problem was on my end. Thanks Parallels team!

  19. VTMac


    Could you please provide some more details or teh ARP entries adn what you did to resolve the issue?
  20. adamsfbay


    ARP entries

    Originally I had assigned and ARP entry to each IP address and bound the MAC addy to it. To resolve the issue, I deleted all my static ARP bindings and flushed the ARP cache. Presto, with my assigned static IPs, everything worked. So, no more bound ARP entries.


Share This Page