Beware of Parallels 17 with macOS VMs

Discussion in 'Mac OS X Guest OS Discussion' started by JohnJohnD, Aug 29, 2021.

  1. JohnJohnD

    JohnJohnD Bit Poster

    Messages:
    5
    I tried to update to Parallels 17 this weekend and it made quite a mess. I run a bunch of macOS VMs (Catalina and Big Sur 11.5.2) on a macOS host (Mac Pro 2019 running Big Sur 11.5.2). All ran perfectly under v16, but after updating to v17, the Big Sur VMs crash during startup, about halfway through the progress bar. The Catalina VMs can't handle much network traffic: when they are running apps that stress the network, they start dropping pings.

    The strange thing is that even after I reverted back to v16, the same stuff is happening. And it's happening even with restored VMs from before the v17 upgrade, ones that it never touched. So it seems like v17 did something to my host machine that destabilized it, especially with network connections.

    The "uninstall" for Parallels is just dragging the app to the trash, but I think there's something lingering somewhere from v17. My environment is pretty unique, so not sure if too many other people will see this, but wanted to put it out there in case others are thinking about updating: give it a few more versions until they discover and fix some of this weird stuff.

    I have a Support ticket in, but this is so weird that I don't have much confidence that they'll be able to offer much, unfortunately.
     
  2. SeanBB

    SeanBB Bit Poster

    Messages:
    28
    Uninstall parallel tools and just go to Fusion.
     
  3. SeanBB

    SeanBB Bit Poster

    Messages:
    28
    Uninstall parallel tools and install update.
     
  4. Philip6

    Philip6 Bit Poster

    Messages:
    3
    johnhohnD...wondering if you resolved your issues?...I'm experiencing same/similar problems since upgrading to version 17; Key/mouse commands in the VM were either extremely slow and sometimes non-existent; I've spent over 30 minutes (several times!) waiting for Parallels to start and Windows 10 to boot, only to have it completely stall; I also experienced tasks in other Mac apps responding very slowly while Parallels was running; My last attempt ended with a Force Quit command of Parallels and as soon is it quit, Mac speed instantly returned to normal ...and now I don't have access to ANY of my Windows data files! Any resolution discoveries would be helpful
     
  5. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hello, did you try any steps for the issue resolution? (Like Parallels Tools reinstallation for example)
     
  6. Philip6

    Philip6 Bit Poster

    Messages:
    3
    I could not find the uninstall command but I did indeed check for tools update and it said current version in use; However, the link you provided in your message was very helpful so I followed that procedure and all seems fine for now.
    After sending this message, I'm going to do a complete shutdown (Windows, Parallels, Mac computer) and restart after returning to my office later...I am hopeful the issue does not return, so that will be my final 'test'.

    And FYI: I see the banner under your username that you are part of Parallels...Had I known to expect Parallels technical support thru this forum, I would not have wasted the last 2 weeks waiting for/attempting (3 different times!) to request help thru your Support Ticket portal...so thank you for your help.
     
  7. Philip6

    Philip6 Bit Poster

    Messages:
    3
    I'm still experiencing a serious startup issue. After completing the tools reinstallation and restarting, I put a timer on the launch/startup processes and these are the results:
    Parallels Desktop 17 Standard Edition 17.0.1 (51482) launch: under 10 seconds
    Windows 10 startup: 10min 2sec (until I saw Windows 10 home screen)
    Time for progress wheel to stop spinning and mouse pointer to become responsive: 4min 17sec
    Time to launch the 1 and only application I use: 16min 43sec
    Time before the 1 and only application I use became responsive: 14min 21sec
    That's a total of over 31 minutes waiting!! And completely unacceptable!
     
  8. BrandenS

    BrandenS Bit Poster

    Messages:
    2
    glad stay on 16 didn't upgrade to 17 as i need parallels to run 10.11
     
  9. warnergt

    warnergt Bit Poster

    Messages:
    51
    I just installed Parallels 17 and updated to Monterey on my Mac Pro 2019.
    I have VM's for MacOS 10.6 (Snow Leopard), Ubuntu Linux 20 and Windows 10.
    All are working.
    I had to move my VM's to the /User/Shared/Parallels directory as they were no longer accessible in the Documents/Parallels directory.
    While the VM's work, they no longer have access to some of the directories that they directly accessed before (e.g. host Desktop and host Documents).
    It appears that Monterey has continued the Apple trend toward much tighter privileges.
    iMovie HD 6 is working in Snow Leopard (I had a problem with sound when Big Sur/Parallels 16 first came out).
    I am able to connect an external DVD drive to the Snow Leopard VM through a USB port.
    In all, it is working pretty well.
     

Share This Page