Beyond Frustrated with PD4. Now Freezes MAC - can this be resolved?

Discussion in 'Installation and Configuration' started by likegadgets, Dec 1, 2008.

  1. likegadgets


    I had under PD3 my full Windows machine that was ported. I finally had that working, except for two issues, parallel tools would stop working and the iSight camera would not work (and yes, I tried every suggestion in the forum).

    I upgraded to PD4 - that introduced two new problems, the Unable to connect CD/DVD-ROM 1 and finding the machine frozen if I leave the VM running. (isight still did not work) I had a fairly large Windows XP machine that I ported with many programs, and perhaps it was too complex for PD.

    While I am new to the Mac I am avery experienced Windows and PC user.

    In frustration with my multiple Parallels 3 and 4 problems. I started from scratch and created a new virtual machine. I have XP SP3 and Quicken 2008 plus a couple of minor Windows apps. For now, nothing else.

    I was able to get iSight working, and the CD/DVD-ROM issue is apparently gone. However the freezing is happening constantly if the VM is working. The Mouse and Keyboard stop responding and requires the on/off switch to restart on the MAC.

    I have isolated the problem to PD4 - as I have turned almost everything else off. No VM - no freezing. Yes VM - freezes. (I had suspected a new Fujitsu ScanSnap - but I removed it and it's software from the MAC to trubleshoot).

    I read in another thread (with no follow up) that John asked: "Do you have Screen Sharing or VMC server enabled?"

    I happen to have Screen Sharing enabled and I am running Vine Server on the MAC side. Does this matter? I need this to access the machine remotely.

    You can imagine the times it has taken to address the above. I cannot think of any software issue I have exprienced that is so frustrating.

    Is there a solution or workaround to the freezing?

  2. crazy_awper


    Sorry, I can't give you some advice, but still to support you,and I also want to know the answer to this question.
  3. Anna Pichueva

    Anna Pichueva Parallels Team


    could you please check if it is caused by lack of memory on your Mac? Do not you run two virtual machines concurrently?
    If the reason is not in it, please create a ticket here and our engineers will be gkad to help you
  4. likegadgets


    I do not think it is a memory problem. I have 4GB RAM and nothing else running. It is a conflict somewhere. Maybe having to do with screen sharing. I did not have the issue with PD3.

    I tried creating a ticket for the past hour, but the email to confirm registration just does not arrive. So I cannot even crete the ticket. (I have clicked on resend to no avail). It is not in the spam folder or anywhere else and the email is correct. So in addition to resolving the freezing, I need help in activating my account to set up a ticket.
  5. edeslaur


    I'm experiencing a remarkably similar problem. I just updated my Parallels to 4.x from 3.x earlier today, and now the VM is horking the Mac side (yes, horking is a technical term).

    prl_vm_app is going to high % (but not more than 120-130) but the Mac side is nearly unresponsive, and the PC side is frozen. Interestingly, the Parallels process is reading 0% busy.

    I'm trying this right now:

    So far, that slowed load times by at least a factor of 4+, however it seems to be running better at the moment. I'll know more tomorrow when I go back to using it heavily, but right now I'm categorizing this as a hack and not a resolution.

    FWIW, I checked the CPU settings per this: without any success, provided feedback on the KB page.

    Additional issue - when I killed (Force Quit through Activity Monitor) the various Parallels process, I was NOT prompted to send a report in. Now that can't be good...

    Initial observations - V4 is muuuch faster to load in "default" config (Automatic memory config), but more unstable than v3. I upgraded because V3 crashed regularly on me (appx 1x per day). I'm a very heavy user on both the Mac and PC side, only run 1 VM, and had it limited to 2GB on V3. I use USB frequently (printing).

    I'm also a power user on the PC side, and many have difficulty following me as I swap from app to app to get whatever done. More than a few times, Parallels Tools has given up trying to keep up in V3.

    I think V4 seems to be snappier, but it's locked up on me 3x since 4:30pm today (it's now 7pm), so the "snappier" isn't getting me any value yet.

    Looking forward to a resolution...
  6. likegadgets


    Well, I submitted the ticket and sent the requested files. Nothing as of yet, except that PD4 is unusable with this problem.

    edeslaur - Any progress at your end?
  7. edeslaur


    I'm going through my IT group for it, so not really.

    I went back to default config for giggles.

    Then, yesterday I walked in and P4 crashed my Mac. Not just crashed itself. Surprisingly, this one wanted to send an error report (the first out of 4 crashes). So I let it.

    The behaviour it exhibited is that P4 had crashed. When I went to restart it, it complained that my user profile wasn't acceptable, probably because the HDD was full. Uh, nope.

    HOWEVER, when I tried to start Entourage (I was in a hurry and needed to look at my calendar and several emails for the meeting I was prepping for - I normally use Outlook in P4), Entourage also complained of user profile issues (no note on full HDD).

    After I rebooted the Mac (latest OS X, Macbook Pro w/ 4GB), Entourage and P4 were able to start up just fine, with the caveat that Windows took more than 5x as long to start up as it had before. I doublechecked and the settings I had undone (from prev post) were still where I wanted them (default).

    Overall, however, it seemed better behaved yesterday. Why? I dunno, I'm not aware that anyone changed any settings.

    I'm eager to see what it's done today.

    So far, my IT team is leaning towards reinstalling P3 for me (we backed up the original image because, well...).

    While I'm at it, I'd like to complain about the new icons. Real belly-whining. Those allergic can stop reading here (sorry Parallels team, you should keep reading! LOL)
    Red slashes in all the icons? I'm trained to see red things as BAD, and all those red things showing up in my dock are jarring to me visually. It's a good way to visually tie things together as Windows or not Windows, I'll give you that. Just the wrong color methinks.

    Also, the P4 icon is harder to find on the dock (other than just looking for those red slashes) that the previous logo.

    I'm going to try to figure out how to change dock icons for the main Parallels app (I'm a relative noob to Mac, not Unix), and then try to figure out how to stop P4 from putting my Windows apps in the dock when they start. I wasn't able to find it after a cursory look through Preferences, etc. yesterday.

    I prefer single window over coherence and see no reason to have icons in both my Start bar and in my dock (with those annoying red slashes).

  8. brianwmay

    brianwmay Bit Poster

    I'm back on a lightning fast PD3 and I too hated PD4's icon because I agree, red slashes are BAD! Good luck.
  9. likegadgets


    In response to my ticket Parallels Support send the solution below. Regretfully that appears t be the solution to a different problem when the Mac freezes upon booting.

    But I do not have a Mac Freezes during the startup process problem nor do I have Parallels 3 installed, I have PD4 for Mac.

    My Keyboard and Mouse Freeze after using PD4 for a while - sometimes a couple of hours sometimes longer - but only if parallels 4 is running.

    Any solution for that problem?

    --- Their solution ---
    Parallels Desktop for Mac 3.0 and Mac OS X Leopard Beta version 9a499 are freezing during the startup

    Mac freezes during the startup process
    This malfunction is caused by the issue in the updated Apple Installer application.
    To solve the problem please do the following:

    1. Restart your Mac.
    2. Hold down Command + S to boot in the Single mode.
    3. Type the command below and press Enter:
    mount -uw /
    4. Type the command below and press Enter:
    chmod 1775 /Volumes/<Your Leopard volume>
    5. Press Ctrl+D or type exit.

    After that Mac will load properly. You can continue the process of Parallels Desktop for Mac build 3.0 installation. The issue will be fixed in the future versions of Parallels Desktop for Mac.
  10. edeslaur


    Walked in this morning, it had nearly locked up again (P4 would react to a click about a 30 seconds to a minute later). The Mac side was very unhappy again. CPU and disk and network utilization were not excessive, but it was acting like it was running 95%+

    Safari wouldn't start. MS Messenger had a problem and threw up a dialog with buttons with no text on them. Nice!
    Activity monitor was behaving relatively normally.

    I killed P4, again no error report sent.
    One more hard-boot with the Mac since it wouldn't shut itself down again. Only after P4 goes to lunch it seems.

    P4 started even slower than yesterday (XP SP2).

    Later in the day I went to print from P4, and it would not. I had to uninstall the PC printer drivers and reinstall them (R-click My Computer, Manage, System, Search for new hardware) to get it to work. I'm hoping it's a throwback to the upgrade.

    I left it running this weekend in my office, we'll see how it does on Monday.

    If I used this at home to mess around, it would be different, but when it doesn't work, I end up working late. Today I spent an extra hour at work catching up because of these issues.

    And the $29.99 phone support charge is about 1/2 of what it takes to move to another product lots of people at work are happy with... I'm not sure I'm going back to P3, but I'll give the IT guys a few more days to try to sort it out before I decide.

    In the meantime, I tried to submit an email ticket to Parallels today, but for some reason, my login for these forums didn't seem to work on the support request - sound right? I was pretty busy anyways, so just canned the idea for now.

  11. MakcyD



    the ticket has been created for you, please check your mailbox and let us proceed with the investigation there.
  12. edeslaur


    Thank you, I'll follow up this AM, I'm playing catch-up already...

    Came in to a Parallels process that was still up (yaaay!). However, not connected to the network (Bridged for the LAN NIC).
    - Disconnect/Reconnect in P4, no joy
    - disable/enable in XP, no joy
    - ipconfig in XP netted the error -> "not enough quota is available to process this command" (hmm...)
    - shutdown -r -t 0 locked up the VM
    - Force Quit on the prl_Vm process (which was alternating from one core to the other using slightly more than 100%) from Activity Monitor did not quit P4 AND has locked up Activity Monitor.

    In the process of rebooting now.
  13. edeslaur


    So I clicked the RT link I got in the support email and got an "Invalid invitation"

    Thanks for setting that up for me, but it's actually more frustrating that this isn't working...
    PLUS I got a note this morning apparently telling me the ticket was closed, did I agree?

    I appreciate the support team has metrics to meet, but I sure hate being a metric over the weekend. A little overzealous I think...
  14. voobrajulia



    I found only one ticket created with your e-mail. This is ticket #634290: Parallels Desktop 4.0 slow performance. It was on hold for a couple of days, but then was opened by your reply. So it is in opened status now. Please, let us know if you mentioned any other ticket.
  15. etdale


    Same issue with Keyboard/Mouse

    I used Parallels 3.0 on my MacBook Pro without significant problems. My keyboard and mouse have become frozen 4 times over the course of my first full day using Parallels 4.0. I use this software for work and the only way to fix it is a hard reset which is highly disruptive and time consuming. Please let me know if there is a solution to this. I reported a problem under ID 19950. Is there anything else we should do other than that? Clearly this is an issue for other users...
  16. edeslaur


    Mine did that today, locked the whole machine up.
    My IT folks have it, I've asked them to put P3 back on it.
    Others have had better luck, but did not upgrade their P3 image of the host OS (mine is XP SP2).
  17. John@Parallels


    When VM is in locked state please Select Report a problem in Parallels Desktop - Help, and post ID here
  18. edeslaur


    The whole machine locked up, so that wasn't an option for me. Perhaps the other fellow.
  19. John@Parallels


    Ok, do it after that, as soon as you restart Mac
  20. likegadgets


    I am still working through this issue. My ticket while temporarily closed while I was traveling. Level 2 support has requested some files (some of which I had previously sent) and I will try to send these to them ASAP.

    My problem is that I cannot reproduce the lockup at will - it happens when it happens and I am hoping to be around to immediately reboot (only way to regain access) and generate the files requested at that moment in time. I was away for a week and Purposely made sure that PD4 was not running, as I needed my iMac to be remotely accessible. The iMac did not freeze the whole week (while PD4 was not running). I just started my VM and I hope that tomorrow morning the iMac will be frozen as it has been almost every time I leave the VM running overnight, so that I can generate the support requested files.

    At least I am not the only one with the frozen mouse and keyboard issue. FWIW -I have Four other running programs, just in case anyone has a similar scenario: 1) ScanSnap manager (Fujitsu), 2) PageSender Fax Center, 3) PCAnywhere ThinHost, and 4) VineServer. I troubleshooted over days to see if any of the 4 were the culprits, but only when PD4 is running do I get the freeze.

Share This Page