Big Sur and Parallels: "Network initialization failed"

Discussion in 'General Questions' started by LukeI, Nov 14, 2020.

  1. MatthiasS9

    MatthiasS9 Member

    The fix from Khorém works (thanks!), but it has a very annoying side-effect for me: the VM does not use the MAC address it is supposed to use, but an arbitrary one. Since our environment only grants network access to registererd MAC addresses this is pretty bad. I now have to find out which MAC address is used and register it.
  2. DavidB106

    DavidB106 Bit poster

    Just landed here from Google with the same problem. I used the text version of Parallels for M1 and now have updated to the latest version. I had fully working Ubuntu and Windows 10 running. After the update of Parallels to the latest version Ubuntu has no network. Above fixes of changes to a 1 or 0 did not fix it. Windows VM works fine.
  3. ParallelsU407

    ParallelsU407 Bit poster

    I tried everything above to no avail. Got it working by additional steps. Listing all I did, maybe step 1 is not necessary.
    Big Sur 11.3.1, Parallels 16.1.2 on a custom hackintosh build.

    1. open mac System preferences - network. Select Parallels shared and press minus button to remove it. After it asks whether to reinstate network when it appears again, press yes. Then click APPLY. You must not forget to click apply.

    2. open Terminal, sudo su [enter], type password, [enter]. You are now root.

    3. list all running parallels services
    bash-5.1# ps -ef|grep [P]arall
    501 129 1 0 3:12PM ?? 0:00.95 /Applications/Parallels --start-services
    0 568 129 0 3:14PM ?? 0:00.01 /Applications/Parallels Service start
    0 570 568 0 3:14PM ?? 0:00.01 /bin/bash -s -- start /Applications/Parallels
    0 578 570 0 3:14PM ?? 0:09.04 /Applications/Parallels --pidfile /var/run/ --launchd-mode
    0 595 570 0 3:14PM ?? 0:00.54 /bin/bash /Applications/Parallels start 60 20 /Applications/Parallels start
    0 618 595 0 3:14PM ?? 0:00.43 /Applications/Parallels start

    As you see, there are still many running despite parallels is closed.

    4. Kill parallels services. Use PIDs from the second column, and use them in reversed order (last to first).
    kill -9 618 595 578 570 568 129
    Now parallels is dead dead, murdered, nuked. We can edit the file.

    5. Edit the /Library/Preferences/Parallels/network.desktop.xml
    Add <UseKextless>0</UseKextless> anywhere between lines <ParallelsNetworkConfig schemaVersion="1.0" dyn_lists="VirtualNetworks 1"> and <VirtualNetworks id="0" dyn_lists="VirtualNetwork 6">

    6. Start parallels services
    /Applications/Parallels\ --start-services &
    (press 2x enter after this command)

    7. Start parallels app and the VM.
    JeffM30, AlvaroM6 and MichaelS141 like this.
  4. MauricioP1

    MauricioP1 Bit poster

    Hello there,

    I've just set <UseKextless>1</UseKextless>
    Started Parallels, started Windows, changed network adapter to shared network and it is working
    Notice that I didn't I set UseKextless to 1, not to 0 or -1.
  5. MauricioP1

    MauricioP1 Bit poster

    Sorry, I meant that I set UserKextless to 1, nor 0 nor -1.
    Captura de Tela 2021-06-24 às 12.07.58.jpg Captura de Tela 2021-06-24 às 12.08.10.jpg
  6. MichaelS141

    MichaelS141 Bit poster


    Thank you so much for this fix. It worked for my Win 10 Pro VM on Big Sur. Cheers!!
  7. EricP17

    EricP17 Bit poster

    For anyone finding themselves here, @ParallelsU407's suggestion did the trick!

    In my case, the value of "-1" was already there, and I also tried using "1" but only "0" worked. I didn't have to add a new line, as ParallelsU407 said, I modified an existing line. Then everything worked great! Didn't require step 1 or step 6, and quitting Parallels from Menu Bar was sufficient to close all processes (also didn't require steps 2-4).

    Simplified steps:
    1. Fully quit Parallels (including from Menu Bar)
    2. In terminal: sudo nano /Library/Preferences/Parallels/network.desktop.xml
      1. Modify line containing <UseKextless>#</UseKextless> to be 0, add it if it didn't exist.
      2. In Nano, save using Ctrl + O and Enter (Use Ctrl + X to Exit)
    3. Launch Parallels normally.
  8. NishaalJ

    NishaalJ Bit poster

    Hi Guys,

    Close Paralells desktop
    Open terminal and type in : sudo nano /Library/Preferences/Parallels/network.desktop.xml
    in the file look for <UseKextless>X<UseKextless> (X being either -1 or 1)
    change X to 0. (<UseKextless>0<UseKextless>)

    press ctrl + o , hit enter (to save).
    press ctrl + e, hit enter. (to exit).

    Run Parallels desktop again and it should work.

    if you cannot find <UseKextless>0<UseKextless>.
    you can add it on any line.
  9. aldiscon

    aldiscon Bit poster

    I have tried all of these options on a MacBook Air M1 to no avail. Internet works fine for Firefox / Thunderbird etc but not for LivePatch or Software. I can used Bridged or Shared networks.
  10. JeffM30

    JeffM30 Bit poster

    thank you so much!!! You're a genius!


Share This Page