Big Sur Public Beta and Parallels 16 - Only showing a 3Mb graphics card

Discussion in 'Mac OS X Guest OS Discussion' started by Nentecular, Aug 11, 2020.

  1. FelixP2

    FelixP2 Bit Poster

    Messages:
    4
    I just tested Window & Catalina & Big Sur Beta:
    I can change Graphic Memory to any value (was 64kb), yet also with 1 GB the performance of macOS ist inferior and jumby. Big Sur public beta does not manage a higher resolution than 1024 x 768. Installation of Parallels tools worked for Catalina, but with Big Sur no effect is visible.
     
  2. FelixP2

    FelixP2 Bit Poster

    Messages:
    4
    Supplementary Info: One can increase Graphics 1GB but effectively it is just 3MB
    I would welcome to see PARALLELS-Support becoming active in this Blog!
    Bildschirmfoto 2020-09-25 um 15.32.59.png Screenshot 2020-09-25 at 15.35.59.png
     
  3. nanoANT

    nanoANT Bit Poster

    Messages:
    28
    Well not sure how do you define "great", but my experience is far from great on Fusion. There macOS Big Sur is very sluggish and has lot of graphical artifacts, e.g. broken menu bar transparency, certain title bars have weird background like Preferences bellow. The only advantage is that it shows 128 MB video card, not 3 MB as PD16, so it works with Retina. Nevertheless it is certainly doable to have more than 3MB display, so please do it Parallels.
    upload_2020-9-26_18-8-43.png
     
  4. SamF2

    SamF2 Bit Poster

    Messages:
    3
    Wow, happy to have seen this thread before upgrading... so this issue has not yet been solved since early Aug?
     
  5. Miles_Teg

    Miles_Teg Bit Poster

    Messages:
    21
    Can someone confirm this is fixed with version 16.10?
     
  6. SimoneT3

    SimoneT3 Bit Poster

    Messages:
    5
    it appears to be fixed. Graphics is still quite slow, though
     
  7. stuartf

    stuartf Bit Poster

    Messages:
    25
    There is a minor improvement in that a display resolution of 1280x1024 is now possible
     
  8. HonzaIl

    HonzaIl Bit Poster

    Messages:
    49
    This has been fixed in 16.10. I can select 2GB RAM for graphic and run high resolution display. I need to upgrade to PD16.10, upgrade to latest BigSur release and reinstall Parallels tools. I also had to enable loading ot PD extension, which Security & Privacy was blocking from loading. After ~1.5 hours of updating rebooting, etc I have relatively usable BigSur installation on which I can - finally - test software I really want to test. It is not speed daemon by any means, but it seems to boot and work relatively OK.
    BigSUr "About" still shows 256MB graphic only, but that seems to be only visual bug.
     
    stuartf likes this.
  9. stuartf

    stuartf Bit Poster

    Messages:
    25
    And I now see 64Mb of video memory assigned

    After a second reboot I am also seeing other higher resolutions becoming available.

    Stuart
     
  10. Frederic Puhan

    Frederic Puhan Bit Poster

    Messages:
    30
    Thank you, Parallels! The latest update (Version 16.1.0 (48950)) has resolved the display issue, and now Big Sur beta is able to go full screen and show in multiple resolutions. This also means some of the "trickier" issues with the beta are better seen and used. It was worth the wait!
     
  11. ATXag

    ATXag Bit Poster

    Messages:
    4
    I just installed Parallels 16.1.0 and the Big Sur Public Beta and I can select any one of the graphics memory options but all I get inside the VM is the 3MB of graphics memory and the option of 1024x768. I have installed Parallels Tools and rebooted several times. Is there something I am missing?
     
  12. stuartf

    stuartf Bit Poster

    Messages:
    25
    Did you grant access to Parallels in the Security section of System Preferences? This could be a cause. The installer does prompt but it is easy to miss
     
  13. nanoANT

    nanoANT Bit Poster

    Messages:
    28
    FYI I had older Beta 6 and I could not make the /Library/Extensions/prl_video.kext work, but with Beta 10 everything worked fine after I granted Parallels extension permission in Security & Privacy. So make sure you're installing latest beta too. Also once kext permission is granted you should see see this in Terminal:
    Code:
    % spctl kext-consent list
    Allowed Team Identifiers:
    4C6364ACXT
     
  14. ATXag

    ATXag Bit Poster

    Messages:
    4
    I did grant the permission it ask for during the install.
     
  15. ATXag

    ATXag Bit Poster

    Messages:
    4
    I don't see where to grant extension permission. Parallels already has full disk access.
     
  16. aspen63

    aspen63 Bit Poster

    Messages:
    26
    Where do I have to grant access? I did it within both guest and host machines but still I see 3 Mb of video RAM.
     
  17. HonzaIl

    HonzaIl Bit Poster

    Messages:
    49
    In guest system (Big Sur VM) go to System preferences, Security & Privacy, and in Tab General, look in area of "Allow apps downloaded from:". there should be the extension listed and with privileges (unlock this), you can enable it.
     
    Blacksmith likes this.
  18. MarkL41

    MarkL41 Bit Poster

    Messages:
    1
    Honzall, thanks for the info on the security settings! I am testing Big Sur on a Catalina host. Full screen and graphics resolution works now!
    Really appreciate it.
    Mark
     
  19. ATXag

    ATXag Bit Poster

    Messages:
    4
    I installed the Beta in a VM and never was prompted to accept the security settings after the Parallels Tools install. I even looked in the security area and nothing was there. I opened a support case and they were telling me that Parallels Tools wasn't installing properly. Several reinstall attempts did not resolve the issue. After Big Sur was officially released I installed that version and was able to see the extension show up in the security area and after allowing it now I have the correct resolution options. Not sure if it was something with the Beta version or just a fluke with my install.
     
  20. Aries@PF

    Aries@PF Kilo Poster

    Messages:
    217
    Just chiming in...
    I too started with the 3Mb vRAM inside the VM, but now it shows 256Mb even with the VM settings set to 2Gb vRAM (A default I've chosen on VMs). There is no real noticeable difference from before the patch inside the VM and it is still really sluggish vs the Windows VMs I have. In fact, all of the MacOS VMs are curiously more sluggish than the Windows VMs.
     

Share This Page