Black screen in multimonitor Full Screen after the upgrade to Parallels Desktop 12

Discussion in 'General Questions' started by MattL2, Aug 24, 2016.

  1. MattL2

    MattL2 Bit Poster

    Messages:
    5
    Before v12 when I would go full screen it would consume both monitors (iMac and external). Now when I go full screen it goes full screen on one monitor and creates a new "Parallels Desktop" for the other screen while leaving the external monitor black.
     
    MasayukiN likes this.
  2. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi MattL2, the issue is under investigation by the Parallels Desktop Engineering team. Please subscribe to this article to receive an update on the progress.
     
    MasayukiN likes this.
  3. BillM4

    BillM4 Bit Poster

    Messages:
    30
    Please just un-remove the ability to turn OFF OS X Full Screen in PD12... Is that where PD12 gets it's speed improvements? By removing the full screen emulation feature? uggh.
     
    MasayukiN likes this.
  4. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hello, please be informed that Parallels Desktop 12 for Mac Hotfix 1 (12.0.1-41296) was released and the issue has been addressed. Please update Parallels Desktop to the latest build http://kb.parallels.com/123948 Latest version always available here: www.parallels.com/directdownload/pd12 Please note that Parallels Tools also needs to be updated (Actions > Update Parallels Tools) and let us know how it works. Thanks!
     
  5. BillM4

    BillM4 Bit Poster

    Messages:
    30
    41296 does not reinstate the PD full screen emulation option, so this is still not fixed.
    I used to be able to do this in PD11:
    [​IMG]
     
    Last edited: Aug 27, 2016
    MasayukiN likes this.
  6. BillM4

    BillM4 Bit Poster

    Messages:
    30
    Meanwhile... back in PD11...:
    [​IMG]
     
  7. YouK

    YouK Bit Poster

    Messages:
    3
    Also, I have same problem after Parallels 12 and hot fix 12.0.1-41296.
    I can't use my external monitor at the same time on full screen mode.
     
    MasayukiN likes this.
  8. YouK

    YouK Bit Poster

    Messages:
    3
    When I checked "displays have separate spaces" at Mission Control of OSX (ver. 10.11.6), No problem was generated.
    But, after uncheck "displays have separate spaces" option, external monitors were changed as black.
     
  9. JamesH12

    JamesH12 Bit Poster

    Messages:
    3
    I have the same problem.
     

    Attached Files:

  10. JamesH12

    JamesH12 Bit Poster

    Messages:
    3
    I should probably give some more details. I have 2 external monitors connected to a MacBook pro. I'm only using the 2 external monitors.
    Running PD12 in full screen, use all displays in full screen, and "Displays have separate Spaces" is unchecked.
    I'm running OS X 10.11.6, and PD12 says there are no updates available.
     
  11. TomW6

    TomW6 Bit Poster

    Messages:
    16
    Every Parallels release, something with full screen breaks. This is probably worst. I have three monitors. If I tell parallels to use all my monitors, it puts each virtual monitor on a different desktop/space. If I tell it it not to use all monitors, then putting it into fullscreen causes parallels to create it's own whole desktop, with two blank screens.

    In OS X, I have the option "Displays have seperate Spaces" turned off (see screenshot). It seems Parallels have shafted anyone who prefers to have this optional off, as both fullscreen modes are broken when this option is off (reading further, it seems turning this option on introduces other issues, so a case of damned if you do, damned if you don't). This is all seems to revolve around the fact that Parallels are now exclusively using native fullscreen mode, which to say the least, sucks big time for anyone who doesn't have "Displays have seperate Spaces" turned on.
     

    Attached Files:

    Last edited: Aug 30, 2016
    StuartE likes this.
  12. MattL2

    MattL2 Bit Poster

    Messages:
    5
    You nailed it, this suck big time. I hope they address it soon.
     
    MasayukiN likes this.
  13. MattL2

    MattL2 Bit Poster

    Messages:
    5
    As others have stated the issue still has not been fixed. TomW6 gave an excellent overview of the issue.
     
    MasayukiN likes this.
  14. StuartE

    StuartE Bit Poster

    Messages:
    5
    Still not fixed.

    So to describe the problem exactly.

    Retina MacBook Pro, w El Capitan
    Windows 10 v1607

    One external Apple 20" Cinema Display via Mini Displayport -> DVI, running with NVidia discrete graphics.

    Windows VM is set to use all displays in full screen.

    When I go fullscreen, normally I can multi-finger swipe right to get to dashboard, then left to get to mac, then left again to get to windows.

    The Windows should display two windows 'screens' at the same time on my two displays (I am not mirroring, and windows is set to extend the desktop... you know... because I'm actually WORKING in Windows doing WINDOWS development)

    When I'm in Windows I'm 100% in Windows, I'm not trying to have an half and half mac/windows fullscreen 'experience'.

    NOW, instead of this working, I have ( [main display | external display] "->" is swipe right

    [dashboard][dashboard] -> [mac|mac] -> [windows|blank] -> [blank|windows]

    instead of

    [dashboard][dashboard] -> [mac|mac] -> [windows|windows]

    which is useless. I can not see BOTH of my windows screens at the same time, so I might as well not have two windows screens.

    Or I could just go back to PD11, where it works.

    EDIT: I have "displays have separate spaces" turned off.
     
    Last edited: Sep 11, 2016
  15. Guna@Parallels

    Guna@Parallels Parallels Support

    Messages:
    433
    The issue is under investigation by our devs . We are planning to fix it in our future builds. Stay tuned for updates.
     
    StuartE likes this.
  16. MarkW9

    MarkW9 Bit Poster

    Messages:
    1
    A related issue - with the black screen, I can't seem to shut down Windows. It just sleeps or whatever the term is. How can I effect a complete shutdown without seeing anything but black? (and Actions - Shut Down doesn't seem to do anything, but I'm really not sure with the black screen - is it waiting for some keyboard input?)
     
  17. SimonAntony

    SimonAntony Bit Poster

    Messages:
    4
    I've got the same problem - upgraded and now get a black screen - cant do jack with it now - reinstalled, tried the modularity tick box on/off and no difference.
    Doesnt look like I can turn the VM off either, just suspends
    Frustrated yet again!
     
  18. appzattak

    appzattak Bit Poster

    Messages:
    7
    Same problem here, this is very inconvenient. Can we downgrade back to 11 as it works just fine?
     
  19. SimonAntony

    SimonAntony Bit Poster

    Messages:
    4
    Tried but that failed too - however support came back to me, told me to use the Stop menu item to kill the machine then restart it - after that it worked fine.
     
  20. appzattak

    appzattak Bit Poster

    Messages:
    7
    latest update does not fix this!!
     

Share This Page