Black Screen when try to use Parallels Access using Safari

Discussion in 'Accessing your Mac' started by RafaelaC1, May 30, 2021.

  1. RafaelaC1

    RafaelaC1 Bit Poster

    Messages:
    2
    Parallels Access is an excellent tool, but when I try to use it through Safari I am always getting a black screen instead of connecting to my computer.
    Please help!
    Access is working fine with chrome.
     
    MatthewW16 likes this.
  2. JesusP5

    JesusP5 Bit Poster

    Messages:
    5
    I get blank screen after updating to big sur 11.4 using any device, os, or browser, even mobile. Unable to connect, windows or earlier mac os versions still working fine. Been trying for a week to get a hold of support but no one answers
     
    MatthewW16 likes this.
  3. DarylH1

    DarylH1 Bit Poster

    Messages:
    3
    Any update on this? I have tried various combinations of MacBooks running Catalina or Big Sur and Safari or Chrome and always get a blank screen back from the remote computer. I've verified the remote computers each have up to date versions of the Parallels Access app (currently 7.0.0). Each of the remote computers can be accessed OK from an iPhone or iPad running the mobile app and I can see the remote screen. It's only trying to see the remote display on a MacBook browser where I have the problem.
     
  4. DarylH1

    DarylH1 Bit Poster

    Messages:
    3
    Also, just for fun, I tried a moment ago to access a remote computer using a Windows VM running in Parallels Desktop and connected to a remote MacBook using the Edge browser. Same result, blank screen.
     
  5. Warren3

    Warren3 Bit Poster

    Messages:
    3
    Same thing, I am connected to my Mac, but only see a black screen with timer. I have had a remote engineer online, and now it's back with engineering as not fixed
     
  6. Asish@Parallels

    Asish@Parallels Staff Member

    Messages:
    132
    Hello, Kindly follow the below steps to re-install Parallels Access and check.
    1. Uninstall Parallels Access from your remote computer completely.
    2. Download a fresh copy of Parallels Access from this website; https://www.parallels.com/products/access/get-started/
    3. Install a fresh copy of Parallels Access on your remote computer.
     
  7. DarylH1

    DarylH1 Bit Poster

    Messages:
    3
    Thanks Asish,
    I have uninstalled Parallels Access on two of my MacBooks, an older 2012 MacBook running Catalina 10.15.7 and a newer one running Monterey. I reinstalled the fresh copy and verified that all the access permissions were approved on each computer. I then tried connecting remotely to the other MacBook. While I can make the connection and see the mouse move on the remote computer, all I see on the local computer is a grey screen. I tried connecting with Safari, Chrome, and Firefox and each gives the same result, grey screen on the local computer.
    I also tried connecting from the other direction using the newer MacBook on Monterey to connect to the older MacBook running Catalina. Same result. I have a connection and can see the mouse move on the remote computer and can manipulate the remote computer, i.e., open an email, click on a browser tab, etc., but on the local computer all I see is a blank grey screen.
     
  8. Nazeemabanu@Parallels

    Nazeemabanu@Parallels Staff Member

    Messages:
    69

Share This Page