Blackberry and USB

Discussion in 'Parallels Desktop for Mac' started by ken, Oct 30, 2006.

  1. ken

    ken

    Messages:
    7
    I have been searching the posts about Parallels for Mac and Blackberry USB support and I dont seem to see anyone with my issue. I dont have the 5-10 sec error everyone else reported.

    When I plug my Blackberry in, the USB on XP does chime and I do see the Blackberry as recognized in Device Manager. Problem is that the Blackberry Desktop Manager cannot see the Blackberry on the USB port. The Verizon VZ Access Manager cannot detect the Blackberry either.

    I am on Build 1940 for OSX.

    Thanks for the help.
     
  2. ggoodwin

    ggoodwin

    Messages:
    2
    This is identical to the behaviour with my BB 7250. I'm on build 1970.
     
  3. Ainvar

    Ainvar

    Messages:
    32
    I am having this issue also with the Blackberry I have from Verizon an 8703e. It gets reconizged and bam nothing else. I dont think the newer Blackberry devices are USB 1.x backward compatible and are on USB 2.0 compatible. I am not 100% sure on this but it is my educated guess.
     
  4. zfirst

    zfirst

    Messages:
    9
    possible solution for BlackBerry 8100 USB connection

    I, like many others, was unable to connect to my BB 8100 using Parallels (build 1970). I've now solved the problem, and wanted to share my experience (YMMV):

    1. Uninstalled PocketMac 4.0 from my Mac, including uninstalling the sync manager.

    2. Followed the instructions here to identify and unload any kernel extensions contributing to the dreaded "5-10 seconds" error message. In my case, I unloaded com.apple.driver.iTunesPhoneDriver first, then unloaded com.apple.iokit.IOUSBMassStorageClass.

    3. With the BB still connected to the Mac, I selected it from Parallels' USB device menu (accessible by clicking on the USB icon in the lower-right corner of the Mac window that encloses the VM desktop). This time it connected, and Windows loaded a driver and wanted a restart.

    4. Restarted Windows, selected the BB again from the USB device menu, and this time it loaded a different driver (something about the SD card, as I recall).

    5. Restarted Windows again, selected the BB from the USB device menu again.

    6. Loaded BB Desktop and voila - it could see my BB for the first time.

    7. Downloaded and tried to install an OS update, which is about the most robust test I could think of to see whether or not this connection was for real. It chugged along just fine until it tried to reboot the device after the OS install had finished; the thing crashed and burned, and I had to reinstall the OS from a Windows PC. So these steps may work for lesser activities than an OS upgrade, but they didn't work at all for my OS upgrade attempt.

    BB 8100
    MBP CoreDuo
    Mac OS X 10.4.8
    Parallels build 1970

    - Zach
     
  5. akatimr

    akatimr

    Messages:
    15
    this worked for me

    Hi Zach, your instructions were helpful, and worked (but not every time for me). Anyway, thanks a million! I really appreciate when people post solutions that they find.

    So, here is one I found: a slightly different solution to the same problem Zach describes and may be more simple?

    1) With BB plugged in to Mac, started Parallels.

    2) Went to Device Manager (right click on My Computer, select manage, then device manager).

    3) Went to USB devices and uninstalled Blackberry device

    4) Restarted Parallels (it reloaded the driver and listed "RIM Composite Device" instead of "RIM Mass Storage Device")

    5) Selected "RIM Composite Device" from the USB Devices listed in Parallels, and BB Desktop recognized it just fine and synced.

    If it freezes for any reason, you have to go through this process again.

    Another problem people have mentioned that happened to me: the sync stops in the middle and says "unable to write or update application data." This is because not all my records had something written in the first name and last name fields. I went through my outlook and added "none" to the last name field in 15 or so records and 10 or so first name fields that were blank. Also, BB support says that it will freeze if first and last name fields have special characters such as *, ?, and a few others.

    BB synced 3,000 contacts without interruption after that.
     

Share This Page