Blank java applications.

Discussion in 'Windows Guest OS Discussion' started by Siker, Jun 22, 2007.

  1. Siker

    Siker

    Messages:
    13
    At this time all my Java applications render blank in parallels. They open their windows and so on but the windows are always grey on the inside. Presumably, they're trying to use some Direct X acceleration method that doesn't work.

    If anyone else has this problem, here's a temporary solution: start the java application, then go to Window's display settings. Reduce the amount of hardware acceleration and hit Apply. You can then change back to the previous level of acceleration - the action of changing the level is what matters, not what level you have.
     
  2. dkp

    dkp

    Messages:
    1,367
    How are you starting them?
     
  3. jtkohl

    jtkohl

    Messages:
    7
    same problem here

    starting a java AWT app, using JRE 1.6 (Java 6)
    Setting acceleration down to "all but basic" gets the screens drawn.
    The icon shortcut is invoking 'C:\WINDOWS\system32\javaw.exe -classpath ..\conf\;galleon.jar;log4j-1.2.14.jar;forms.jar;commons.jar;concurrent.jar;hibernate.jar;jdbc2_0-stdext.jar;hme-1.4.jar;hme-host-sample-1.4.jar;pja-2.5.jar;dom4j-1.6.1.jar;browserlauncher.jar org.lnicholls.galleon.gui.Gui'

    'java -version' says:

    java version "1.6.0_01"
    Java(TM) SE Runtime Environment (build 1.6.0_01-b06)
    Java HotSpot(TM) Client VM (build 1.6.0_01-b06, mixed mode, sharing)
     
  4. Siker

    Siker

    Messages:
    13
    The Java application I start is launched by the exe4j Java launcher. The same symptoms can be observed by just double clicking the 'Java' icon in the Windows Control Panel. This Sun provided application also renders blank with direct x acceleration turned on.

    Here's a slight update: I upgraded to version 4128 of Parallels, which did not resolve the problem.
     
    Last edited: Jul 2, 2007
  5. ckuske

    ckuske

    Messages:
    8
    Runtime flag

    You can try adding this argument to disable D3D acceleration in Java2D.

    -Dsun.java2d.d3d=false
     
  6. bobbyb

    bobbyb

    Messages:
    8
    Is there a way to set that as a global option?
     

Share This Page