BlazBlue Central Fiction PC Video driver issue

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by DARRENS1, Sep 6, 2021.

  1. DARRENS1

    DARRENS1 Bit Poster

    Messages:
    4
    Im on a Mac Mini M1, 8core, 16GB Ram, 2TB SSD with Windows 10 arm with Parallels 17.0.0 (Trial) and Ive descovered
    that BlazBlue Centra Fiction PC displays the game in wrong colors. Blacks are green or blue, but playable at 59fps at 720p.
    Upon trying to fix this issue, removing or disabling the Parallels 17.0 WDDM video driver allows the game to display properly but now tins at 20-35fps. Which makes it unplayable.

    Ive run Guilty Gear Accent Core Plus PC and that displays properly and is fully playable. Ive tested the other versions of BlazBlue Continuim Shift, Continuum Shift Extend has the same display issue with Parallels 12 WDDisplay driver. Can we get a fix?
     
  2. DARRENS1

    DARRENS1 Bit Poster

    Messages:
    4
    Update on the issue, Codeweavers app very 21.0 installs the game, but doesn't fully start, but, it displays in the correct color space.
    Parallels 17.01 update along with Parallels Tools update with your updated WDDM Driver 17.0.1.51482 (9/1/2021), does not resolve the graphical issue with BlazBlue Central Fiction PC game(32-bit). I have 6 days left on the trial, and I will not be giving you any money until this can be fixed.
     
  3. Anand48

    Anand48 Bit Poster

    Messages:
    64
    Hi, please follow the steps given below and check on the issue:
    1. Reinstall Parallels Tools, please refer to ( https://kb.parallels.com/115835 ).
    2. Change hypervisor to Parallels (ignore if it is already selected as "Parallels"), please refer to the article ( https://kb.parallels.com/125186 ).
    3. Change virtual machine profile to "Gaming" in Parallels Desktop, please refer to the article ( https://kb.parallels.com/124264 ).
    4. Set Optimization to no limit. To open these settings, choose Actions > Configure > Under Options > Optimization set Resource usage to No limit. Thanks.
     
  4. DARRENS1

    DARRENS1 Bit Poster

    Messages:
    4
    Ive had it set to no limit, gaming profile from the start but Ive followed all the above troubleshooting steps and even did the Terminal command to set to Apple, and I still
    have the same issue with BlazBlue.
    The Parallels 17.01 GUI doesnt even show "Apple" in the advanced settings for CPU & Memory, it only has extended or Hypervisor.
    I dont expect you to have this game, but if you do, you might be able to better troubleshoot this issue.
     
  5. DARRENS1

    DARRENS1 Bit Poster

    Messages:
    4
    Update, while using the MacOS terminal command lines prlctl, I saw some other options.

    prlctl set c0eaae14-a242-4106-a9a4-b05764335cd0 --video-adapter-type virtio

    that goes to generic Display video driver. Still same problem.

    prlctl set c0eaae14-a242-4106-a9a4-b05764335cd0 --hypervisor-type parallels
    that wants my Mac mini M1 to restart in order to take affect, but it does not, just the request popup comes backup after the restart of my Mac mini M1 and when I try to start Parallels 17.01.

    This one, is the only one that I can use:
    prlctl set c0eaae14-a242-4106-a9a4-b05764335cd0 --hypervisor-type apple

    prlctl set c0eaae14-a242-4106-a9a4-b05764335cd video-adapter-type parallels

    Back to the same issue, its the Parallels WDDM video driver that's not compatible with the BlazBlue games. Sad.
     

Share This Page