Blue Screen of Death using Boot Camp

Discussion in 'Parallels Desktop for Mac' started by esquilo22, Jan 17, 2007.

  1. esquilo22


    After installing my boot camp partition, apple drivers and applying all MS security updates I receive the attached blue screen of death when I first try to boot my partition using Parallels.

    Any ideas?

    Attached Files:

  2. STim

    STim Super Moderator

    Thank you for reporting.

    Please send us your %SystemRoot%\Minidump file (usually, it's the C:\Windows\system32\Minidump file) to mailbox. This file contans a necessary information about this blue screen conditions and is just 64 kilobytes size.

    We will appreciate memoty minidump files from anyone else having similar problem. Please don't forget to mention whether this BSOD occures when Boot Camp is booted via Parallels or natively.

    Best regards,
    Last edited: Jan 17, 2007
  3. Narflar


    I have had the same error happen to me. I sent in an email with an explanation of what happend plus a screenshot of of the BSOD. I have no "minidump" file on my computer to send. At least in my case the crash is happeing at bootup, before windows loads. There have been numerous posts about this and this is the first time we are seeing any kind of responce from the Parallels team? I appriciate that this bug is finally being addressed.
  4. esquilo22


    The problem happens just after I boot parallels before it can install parallels tools. I don't have this minidump file. Here are my discoveries so far:

    • If I install WXP SP2 Corp from a stantard CD without installing anything else on my boot camp partition (Apple Boot Camp drivers for example) Parallels can boot it and install the necessary drivers and software
    • If I install WXP SP2 Corp from a CD slipstreamed with all MS Security patches (67 so far) using nlite I got this error
    • The same if I try to slipstream the CD only with Apple Drivers
    • The same if I use a different configuration for Windows system directory names (System instead of Windows, Applications instead of Program Files, Users instead of Documents and Settings)

    nLite is a great tool for creating custom Windows installation CDs and I use it for a long time on my PCs. And by using it I can have a better Windows experience with less memory footprint, less BSOD and so on. I use it for at least a year and could assure that it is very reliable.

    So my guesses are:

    • Parallels is relying on some DLL, EXE for booting, installing Parallels tools that has been updated by MS Security Patches
    • Parallels is relying on fixed directory names instead of getting those names from registry
    • Parallels is relying on fixed size SP2.CAB or DRIVER.CAB files to get the necessary drivers to install Parallels tools

    This problem is getting me nuts. I reinstalled my Windows at least 10 times to test different scenarios.

    Those are my two cents. Hope this problem gets fixed soon because this software really rocks!
  5. photo


    Thanks Tim, for finally responding a post about this problem.

    I have the same error.

    There is no Minidump file.

    The error occurs during or immediately after the loading of MUP.SYS.

    Clean Windows install, fully patched, with bootcamp drivers.
  6. Ainvar


    I get the BSOD when trying to boot into XP. My version is a corp build also with SP2 already aplied by MS. There is no minidump file in XP when it bluescreen, I dont think it can get that far to create a dump file. I also tried this before any updates are applied via Microsoft Updates / Windows Updates and I get the BSOD then also. I have tried this before I install the Apple drivers and I get the BSOD.

    I dont think Parallels like the corp version of XP?

    The only time I was able to boot into Bootcamp from parallels was the version of parallels that required you to install a small file first in your Bootcamp install of XP.
  7. lostgame


    I get one of these, too.

    SP2 Professional.

    Also, no "minidump".
  8. esquilo22


    My problem also occurs just after MUP.SYS is loaded. This is the last loaded driver before the GUI starts.

    Guys, please besides posting to this forum send your BSOD to with this info.
  9. lanny


    Iy gets WORSE

    Not only do I get blue screen but parallels also screwd up my bootcamp startup so tht it nowsay invalled ha.dll ...

    Parllells id geting worse and worse - this ysed to work

    :cool: :cool:
  10. lanny


    I can't send it, the blue screen stays on for a fraction of a second. This is the WORST release of Parallels ever. It screwed my Boot Camp, it now will not start due to invalid hal.dll
    Last edited: Mar 29, 2007
  11. lanny


    How am I supposed to send it if Parallels screwed my Boot camp boot whioch now aborts on invalid hal?.dll. It worked great before, no I am fubar because of this release of Parallels.
  12. lanny


    It used to work. Now it sucks. It destroyed my boot camp booting (missing or invalid hal.dll) and I had to repair-install win xp again.
  13. Eru Ithildur

    Eru Ithildur

    Have you tried repairing permissions on your disk and/or doing a repair install of Windows?
  14. mpdan


    I'm having the same problem.

    Repairing natively will fix Bootcamp, but break Parallels...
    Repair in parallels, and it breaks the native boot.

    Bootcamp runs just fine. latest drivers and updates.

    Help please.
  15. mpdan


    No minidump logfile here either. Let me know if there is any other relevant data you'd like to see.
  16. fso


    Blue screen too after booting into BootCamp natively

    I have blue screens and it happens some time after booting into bookcamp natively.

    I was able to get around it for a little while before by turning off windows auto-updates service, but it is happening again now (with Windows Updates off).
  17. mpdan


    Is there a way to make XP totally forget about the parallels hardware config?

    I figure my best chances of this working again is for me to get my Bootcamp config squared away, then tell parallels to boot that for my VM....just like I did the very first time when it worked without a hitch.
  18. mpdan


    I'm so frustrated. Maybe if I just keep posting here, my error will go away.

    Here is a screenshot of my bluescreen. Note the identical memory address as esquilo22.

    Attached Files:

  19. rlbauer2


    Same Problem W/ A Black Screen

    I too updated Win XP last Sunday. I start Win XP in PARALLELS. It begins to load then stops & the screen turns black. I have paid to work w/ Parallels. They say it's a apple or windows problem. I went to the apple store & same thing. This has happened to me 3 times. each time I am working away just fine then out of the blue a black screen appears & shuts down. this time I am unable to retrieve my data or to install it into a new VM. When I check on the MAC side the data appears to be there as far as volume! I am getting very frustrated. I could not find anything on Microsoft site & no one @ parallels has ever recommended this site. I found it on my own. Now I don't feel like I'm the only one having this problem. My data has been down for a week & I need it for my business. Any help would GREATLY APPRECIATED
  20. CorpSuit


    I hate to say it but I am having a similiar problem that cropped up today. I normally work fine with Parallels and my Boot Camp Partition, but today I can't get into my Virtual Machine and when I boot into Boot Camp it says there is a problem with hal.dll.

    Here is the error message I got from the Mac OS X side:

    Date/Time: 2007-04-07 14:05:46.000 -0700
    OS Version: 10.4.9 (Build 8P2137)
    Report Version: 4

    Command: Parallels
    Path: /Applications/Parallels/Parallels
    Parent: WindowServer [52]

    Version: 2.5 (2.5 Build 3188.0)

    PID: 246
    Thread: 0

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000024

    I didn't want to post all of the thread crashes, because there were just so many of them.

    Anyone have any suggestions, besides reinstall from scratch?

Share This Page