Bootcamp doen't boot anymore, Missing file root\system32\hal.dll

Discussion in 'Parallels Desktop for Mac' started by aknyc, Mar 17, 2007.

  1. aknyc


    I am not longher able to boot into Xp bootcanp, missing file "hal.dll"

    I will start from parallels, how can I fix it?

  2. fiberoptic


    I am having the same problem.

    Bootcamp and VM both worked well for 2-3 days after installing the new 3188 build. Bootcamp worked fine on the previous betas. I haven't done much except install some windows updates and a game.

    Build 3188 March 7 ,2007
    Intel Macbook Pro
  3. fiberoptic


    I thgoutht there might be a slight chance my paralellels install was corupted, so I reinstalled the paralells tools into windows, while running in VM mode. That didn't help. I am pretty much at a loss, short of re-installing everything and starting over. Any suggestions?
  4. masonjames


    I had this same problem. I couldn't get into windows through parallels, so I tried starting up with the bootcamp install (not virtualizing) and it eventually loaded up and ran the chkdisk thing. After that I was able to get into windows fine through bootcamp and through parallels. I dunno what changed.
  5. Mathew Burrack

    Mathew Burrack

    I've seen this problem before if Parallels crashes or I otherwise don't shut down Windows the "proper" way inside Parallels. It looks like Parallels might move some files around and/or change the boot config for XP when booting a Boot Camp partition, so you need to shut down XP the official way to get the files back to the original state so that Boot Camp will work normally.

    Every time I've seen this error, booting in Parallels, then shutting down via the Start Menu always fixes the Boot Camp boot.

  6. luomat

    luomat Kilo Poster

    FWIW my experience has been the same as Mathew Burrack's.... if this happens it usually means that something hinky happened with Parallels, so I boot that and shut it down cleanly.

    If that doesn't help... I don't know what to suggest.
  7. nicholaspwojtowicz


    this has happened to this to fix...

    hal.dll is the hardware abstraction layer.

    1. Insert and boot from your Windows XP CD.
    2. At the first R=Repair option, press the R key
    3. Press the number that corresponds to the correct location for the installation of Windows you want to repair.
    4. Typically this will be #1
    5. Type bootcfg /list to show the current entries in the BOOT.INI file
    6. Type bootcfg /rebuild to repair it
    7. Take out the CD ROM and type exit


    I had the same problem when trying to start Parallels from a boot-camp partition. HAL was destroyed on the bootcamp partition. I had no choice but to reinstall bootcamp and XP. YUCK! What a bummer.


    Nick, I tried that. But it didn't work as no valid partition was found. How did you manage this? It sounds like you are on a "real" PC????
  10. Eru Ithildur

    Eru Ithildur

    This frequently happens if you have a 'non-graceful' shutdown of Parallels. Try to boot Parallels, then Shut Down properly without a crash then give BootCamp a try.
  11. fiberoptic


    I have tried starting and shutting down gracefully. I can successfully do this in virtual mode, but not booting straight to boot camp. I will try some of these hal replacement tips above as I have time.
  12. Eru Ithildur

    Eru Ithildur

    Strange... Try doing the repair install like they were suggesting.
  13. fiberoptic


    hal.dll missing problem fixed

    I used the Mac file browser to check out the Hal.dll file in windows\system32. I found that this file was 0 (zero) KB. Using a USB thumb drive I was able to copy the file off of another windows xp desktop PC, overwriting the 0kb file. This appears to have fixed the problem and I can now boot in parallels mode as well as boot camp mode off of the boot camp partition. Thank you all for your suggestions.
  14. rebaser


    I fixed the problem this way ....

    After trawlling through some of the forums and microsofts technet I found the following.

    Looking at my boot.ini (which i can see in parallels) file you can see a specific kernel and hal file is being used see below

    multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /kernel=ntkopvs_.exe /hal=halopvs_.dll

    in this case the hal.dll file is halopvs_.dll Unfortunatly on the install disk there are several Hal files that you could used (depening on if you have a single processor or mutiple processor machine). To find out the on e that is being used open the setup.log file which lists the one that was installed when you installed bootcamp. (eg notepad c:\windows\repair\setup.log)

    \WINDOWS\system32\hal.dll = "halmacpi.dll","293a1"

    From this in my example you can see that I had installed the halmacpi.dll

    So to get the orginal back I do the following
    * Insert Windows XP SP 2 disk
    * Bring up a cmd window
    * run the following comands
    cd %TEMP%
    expand d:\i386\ -f:hal*
    copy halmacpi.dll c:\windows\system32\halopvs_.dll

    Hopefully that will fix your problem, it did for me except windows does not shut down now in boot camp all the time.

    I am started to now get very miffed with Parallels as this has happened twice to me now. Also I have started to get Kernel Panics as well, looking at the panic.log was casued by the Parallels Kernel Extension! Plus it has just taken 5-10 minutes to start windows (This is ona 3Ghz Mac Pro with 4GB of memory!). Just even starting a cmd window takes a long time :mad:
  15. Stadsport


    I've had the same problem. I ended up just reinstalling Windows XP. bootcfg /rebuild does nothing.
  16. LCPGUY


    As I've said in other threads, please just try cleaning out "ALL" your caches, including the kernel caches. This can work wonders, and usually does!

    ONYX - Free

    CockTail - shareware

    Tiger CacheCleaner - shareware

    They all work, and work well.

    Depending upon which one you use, if you are presented the "option" of deep-cleaning, just go for it and ignore the warning to try lesser methods first.

    Please give it a try, and if the problems still exist, then SCREAM at Parallels, or Apple.

    For the record, except for the destruction of my BootCamp partition, and my previously reported Kensington Mouse install problem, Parallel's is just AWESOME.
  17. Eru Ithildur

    Eru Ithildur

    Try the Cache cleaner. I love Onyx.

    Also, try a memtest... It might just be bad memory as I recently found out.
  18. count me as another missing hal.dll

    when I try to boot into bootcamp, I get a blank screen with a mouse cursor. when I to boot in parallels, it thinks I have multiple Windows installations (not true)

    Macbook Pro 15" C2Duo 2.33gHz, 2GB RAM

    VM Config: Using Bootcamp

    This problem surfaced after a spontaneous reboot occured last night (I believe due to parallels).

    This is using Build 3188 (Mar 07 07).

    Worst bit is this is my work machine. Thankfully, the OSX partition is still happy.
  19. Eru Ithildur

    Eru Ithildur

    If you have a bunch of Kernel Panics and the like, try the following, they have helped me in moving from BETAs to Stable... To include the Stable Stability.

    Back-up your Hard Drive, be it a .hdd or Partition. Un-install Parallels tools. Now, completely un-install Parallels Restart your Mac. Re-seat your RAM modules. Run all the Onyx tests and maintnence that you are willing too. Re-index your directory tree with something like DiskWarrior. Check your memory from a boot disc. Now install Parallels again and point it at the appropriate drives. Re-install Parallels tools.

    Hopefully stuff will work now.
  20. zenweb


    Me 2000!I already posted about this. Can't boot into BC. PDM fine. 3188

Share This Page