Build 1940 of Parallels Desktop for Mac

Discussion in 'Parallels Desktop for Mac' started by STim, Oct 10, 2006.

  1. STim

    STim Bit poster

    Hello everyone!

    Build 1940 is ready to download from here.

    Main fix of this build is better memory management for MacPro and iMac Core 2 Duo with more than 4GB RAM. Other minor fixes for customers reported problems introduced like Shared Folders and unicode characters.

    Plus one more thing some advanced users might find useful - an initial possibility of Parallels Desktop operation scripting. Check the command-line tool for details.

    As usual, your feedback on this build is very much appreciated.

    Best regards,
  2. dmainzman

    dmainzman Bit poster

    Yeah, when will we see 3D support in a beta build? EVER?
    You guys promised us potential 3D support a long time ago.
  3. mcg

    mcg Hunter

    Oh, please. They did no such thing, at least not on YOUR timeline. From my reading it has been clear that 3D support is not an immediate priority but a longer-term goal.
  4. controller

    controller Member

    This build works great on my Mac Pro with 4GB of RAM (all enabled), as did the last few versions. I noticed some clean ups too:

    a newer icon in the dock,

    no more "Release Candidate" text,

    I didn't have to sleep the machine to get VT-x working (sometimes that happens though so that could have been a fluke),

    A prompt to register (although I already bought the product and it shows as activated/licensed),

    A prompt to reinstall Parallels Tools to the latest version.

    Looks and acts polished!
  5. Scott Willsey

    Scott Willsey Hunter

    Mine too. They made it very clear that is something in the future (and not in the immediate future).

    Interesting new dock items that indicate what type of OS is running! :)
    Last edited: Oct 10, 2006
  6. jhapeman

    jhapeman Bit poster

    Fixed the RAM issue, too

    Build 1922 would cause a kernel panic on my Mac Pro (2.66 w/ 5GB RAM) if I increased the RAM allowed for the VM to the max 1.5GB; that problem is fixed now. Sweet.

    Still doesn't seem to have all the nice tools for Vista that you have XP, like the seamless mouseover. Coming soon? I expect my EA release of Vista in about 45 days.

  7. Snowing

    Snowing Bit poster

    VT-x issue remains

    Unfortunately Build 1940 hasn't helped with my VT-x issue. I still have to sleep. :(
  8. Andrew @ Parallels

    Andrew @ Parallels Parallels Team


    VT-x issue is not Parallels fault. It is bug in Mac Pro firmware. We are pushing Apple to fix and hopefully it will be fixed in th upcoming firmware updates.
  9. bamsaleg

    bamsaleg Member


    Everyone has it's own agenda.
    In my case, having to transition many VPC users in the next 12-18 month, I would trade 3D for direct conversion of Virtual PC images to Parallels...

    and yes, this is in the FAQ as something that may be part of a future version...

    Parallels team must know best than us, what is possible on what time frame and with what business casse to found the developement and testing effort.
  10. plasticaugus

    plasticaugus Bit poster

    Works fine on my Macbook with Ubuntu & XP Pro.

    Now we just need some Parallels tools for Linux (pretty please)
  11. Snowing

    Snowing Bit poster

    Right… now I know. So given Parallels is able to recognise this, is it possible then to stop the VM from actually starting or to at least give the option. Instead of being told it and having the VM carry on its merry way in the meantime it would be nice to be able say I don't want to start to the VM.
  12. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    But you can start it without VT-x support in software mode. It is less speedy but also works pretty good.
  13. swilcox

    swilcox Bit poster

    Garmin USB support?

    I know there are lots of things on the development team's plate, but this is the one that concerns me :)

    I don't suppose this version allows us Garmin Edge owners to use our devices, does it?
  14. webdeck

    webdeck Member

    I can't use the sleep workaround for VT-x because my Mac doesn't go into a deep enough sleep due to the ATTO ul5d SCSI PCIe card that's installed.

    To get VT-x working, is it simply a matter of setting %cr4 to 0x26e0 instead of 0x06e0 so that VME is enabled?

    I tried writing a small efi application for rEFIt to set the VME bit in %cr4 and it worked, but of course booting into Mac OS X undid it. Is there no way to set that bit in %cr4 once the OS is running?

  15. phobus

    phobus Bit poster

    Sleep mode worked for me in the last build, but after upgrading today, sleep mode no longer works for getting VT-x to work. :confused:
  16. esz

    esz Junior Member

    Build 1940 strange behavior...

    This build has new behavior I haven't seen with any of the older builds:

    When I switch to full screen mode in Windows XP, my desktop background (Windows XP - Stretch) gets switched to a blank blue screen. Of course I can set it again, but when I switch back to the small screen it's blank and blue again.:confused: When I go into the Display Properties to set it again, it still has "Windows XP" selected as the Background pattern, but it's just not displaying it...

    MacBook 2GB RAM, 160GB HD, Win XP Pro
  17. conalho

    conalho Member

    I think a lot of us have been dying for better USB implementation.

    This latest build, 1940, still cannot work with my Garmin Forerunner 205. Is the USB problem such a difficult problem to solve? I hope not.


  18. Miko

    Miko Junior Member


    This build did not fix the memory problem in my MAC PRO with 5GB i still ONLY have 1500mb available to use in VM :( more info:
    Really sux i got 5gb just so that i could use at least 2 in parallels......
    Maybe tomorrow with next build ;)
  19. MartyMcr

    MartyMcr Hunter


    Have you "undone" the memory restrictions that the previous version used? You may have to reset some parameters to get rid of the 1500MB limit.
  20. Miko

    Miko Junior Member

    are you talking about the "reserved memory limit" ?
    in that case yes i have chage it to over 4gb if not i'm not sure .....

Share This Page