Build 3188, the new release, spoilt up my MBR. please help!

Discussion in 'Parallels Desktop for Mac' started by karan_karia@hotmail.com, Mar 16, 2007.

  1. Hi,

    I had installed Windows through boot camp prior to installing this new release of parallels. After i installed parallels, i started to set up the parallels on my mac. But before it started windows (after the initial set up, before the screen flips over and starts up your virtual machine) it froze up. Apple+option+esc revealed that its not responding, so I forced quitted it.

    I tried restarting the app, but it just kept freezing up. Tried doing the set up again and it still doesn't work. After many tries and many frustrated visits to forums on the net to try and fix the problem, I gave up and just uninstalled the parallels software with the uninstaller that comes in the dmg file.

    Now however when i start up windows normally by pressing option after i switch on my macBook pro, it seems that parallels hasn't removed itself completely because it shows up on the O/S options list and asks me which to start up, parallels, or windows xp.

    Even worse is that Parallels is selected by default and the damn timer is set to 1 second or something. So within that one second I have to press the down key, or else it tries to start up in parallels and claims some file is missing and gets stuck.

    I feel this is a really shabby programming by the parallels team to not have a proper uninstaller. They should have waited a while before releasing this build and tested it more thoroughly.

    Anyone knows how to fix this booting up problem.
     
  2. strells

    strells Product Expert

    Messages:
    572
    The uninstaller can only uninstall stuff on the Mac side of things. It can't do anything in the VM. Either uninstall the Parallel tools in Boot Camp or simply reinstall Parallels to fix the problem.

    Steve
     
  3. tomservo291

    tomservo291

    Messages:
    90
    There is a program called rEFIt: http://refit.sourceforge.net/

    This program esentially replaces the apple boot loader (option/alt at startup.) Don't be scared by this, it doesnt replace it, it just takes place after the apple boot loader would (if you wanted to use the apple boot loader, you would still hold down alt/option and it would come up.)

    What boot camp does is create a hybrid GPT/MBR boot sector (GPT is the scheme used for EFI.) rEFIt is a Debian project that has come to light for the need of a boot loader that is configurable and customizable that is able to recognize this new hybrid GPT/MBR. It contains a tool that will "resync" the GPT/MBR boot sector if it has erroneous entries.

    If there is something actually wrong with your MBR, this might detect it. I won't garauntee that of course, but it's something you could try. Even if it doesnt work, you will have gained a really cool boot loader that you wont know how you lived without (I love it..)
     
  4. Hi,

    Thanks for your help. I tried re installing parallels.

    Its still not working though. How do i remove parallels completely?

    I never even set up parallels tools in boot camp. I had just installed it on the mac, it never loaded windows (even for the first time.) and so i uninstalled it.

    Actually there is no problem in loading up Macintosh. Theres a problem in loading up windows.

    I have taken a few images to show the problem exactly. Ok the first image is this
    Image 1
    This happens after I press option during start up and choose windows. Then windows starts to boot up and this is the default screen. As you can see, parallels is on top and by default it is selected. And the stupid timer is set to one second. So unless I don't keep pressing down or up continuously, it doesn't stop the timer and chooses Parallels Configuration for me instead.

    Once that happens I get this screen...
    Image 2

    However if i press down or up continuously, while the comp is reaching this screen, it cancels the timer and I am able to start up Windows normally by choosing Microsoft Windows XP Professional.

    That works fine, although whenever I start up windows it gives an error saying it cant find parallels tools.


    Its not such a big deal cause I can keep pressing down while loading up windows and then choose windows xp and cancel the error which pops up when windows is loaded up but... How do i restore it so that it is just like it was before I installed parallels? I know I can just format the boot camp partition and install windows again, but that is such a pain cause i have a lot of information and settings set up as I want them in windows.

    Damn parallels for doing this. Never buying their software. Stupid trial software messed up everything.

    (Plus i think after I installed parallels and uninstalled, i keep getting a lot of those "grey screen of death" the mac equivavlent of windows' blue screen of death. The one where everything becomes transclucent and an error is displayed in different langauges.
     
  5. Nevermind. I fixed part of the problem.

    The main issue anyway.

    Theres a setting I found in the Windows control panel > system > advanced > system recovery.

    This allows me to reconfigure the O/S options screen to show Windows First. It still doesn't remove the Parallels Configuration Option or stop the stupid Parallels Tools error from popping up every time I start windows. But it at least helps me by keeping Windows chosen by default so that it doesn't make my life difficult while booting up Windows.

    Thanks for your help.
     

Share This Page