Build 3212, Open BSD 4.1, USB problem

Discussion in 'Parallels Desktop for Mac' started by dylanharris, Jun 10, 2007.

  1. dylanharris

    dylanharris

    Messages:
    34
    I've updated to build 3212. I've just successfully installed & patched Open BSD 4.1, but I'm having a USB problem.

    Specifically, the OpenBSD umass driver can see when my dedicated CF reader plus CF card is plugged in, but "Get Max Lun" fails.

    I know that Open BSD was supported in earlier versions of Parallels, but I note it's not on the current list of Guest Operating systems.

    Unfortunately, I need this running because I want to update my Soekris boxes.

    Has anyone any suggestions?
     
  2. Liong612

    Liong612

    Messages:
    15
    USB problem here too

    I am using windows 2000 to use Sonicstage with my Sony HD5.

    After upgrading to 3212, windows failed to recognized my Sony HD5 through USB.

    I have no choice but downgrading back to 3188.

    :(
     
  3. dkp

    dkp

    Messages:
    1,367
    Is 3212 a version 2.5 refresh or an earlier build of version 3.0?
     
  4. murphy

    murphy

    Messages:
    64
    It's a 2.5 update.
    It is not 3.0.
     
  5. dylanharris

    dylanharris

    Messages:
    34
    Under Fusion

    I just want to confirm Open BSD USB does work under the current release of Fusion, & I've rescued those CFs. I guess I'm going to be running both products for the time being.
     
  6. dylanharris

    dylanharris

    Messages:
    34
    Worked it out

    Ok, I've understood the problem.

    Fusion supports both USB 1.x and USB 2. When Fusion simulates USB 2, OpenBSD 4.1 outputs the same error as it does in Parallels. However, OpenBSD 4.1 behaves when Fusion simulates USB 1.1 only. It looks like OpenBSD wrongly interprets the USB 2 ports as USB 1.1 ports in both products.

    I know Parallels 3 (I got my key yesterday) supports 2 USB 1.1 ports (docs, p133). What I'm not clear, though, is how to ensure Parallels connected my CF reader through one of its virtual 1.1 ports (Fusion has an option to only use USB 1.1). Do I need a physical USB 1.1 hub? Added: Ok, so I'm stupid. I forgot the keyboard has the USB 1.1 ports. Unfortunately, they don't work with my card reader; it needs more power than the keyboard provides.

    Is there anyway to force Parallels 3 to simulate USB 1.1 connectivity, even on USB 2 sockets?
     
    Last edited: Jun 13, 2007

Share This Page