Build 5160 Sharing Mac Applications Despite Being Disabled!?!

Discussion in 'Windows Guest OS Discussion' started by powell, Sep 11, 2007.

  1. powell

    powell

    Messages:
    12
    I upgraded today to Build 5160, and the first thing I checked was that my XP VM configuration had security set to High with both File and Application sharing turned off.

    I booted into WinXP, Checked the "Applications" menu in Parallels, and all Application sharing is disabled. Parallel Tools updated to match 5160, and I rebooted.

    After rebooting, WinXP notified me that new applications were available. Checking the Start Menu, there are all of my Mac Applications. Shutdown the VM. Check the settings: still disabled. Reboot. Check the Applications menu, all disabled. Check the Start Menu, they are there. Click on one, and it starts up.

    Parallels, I am patient, but I really don't believe you guys understand. Many of us want ZERO integration between the two. We turn it off, yet you do it anyway. I do not want malicious windows code to corrupt files on my Mac. A Windows virus writer could easily write a new virus that injects foul Mac code into Mac applications via Parallels with this B.S.

    I do not want WinXP to have ANY knowledge of my Mac. None. Zero. Do you understand?

    I have disabled all sharing options (and confirmed thrice), yet you persist on presenting my Mac to Windows. Please stop. Now.
     
  2. brkirch

    brkirch Kilo Poster

    Messages:
    415
    I can't reproduce this problem. Have you restarted your computer since the update? If you still have the problem after a restart you may want to try uninstalling and reinstalling Parallels Desktop.
     
  3. SnakeEyes

    SnakeEyes

    Messages:
    33
    Not a problem here either, I am skeptical. Regardless, it is irrational paranoia.
     
  4. spectre

    spectre Parallels Team

    Messages:
    270
    powell,

    Please try manully re-installing Parallels Tools in your VM, maybe they weren't updated automatically.
    1. Boot Windows VM into the Safe Mode (hit F8 (or Fn+F8) during Windows boot logo) inside the VM, then choose Safe Mode.
    2. Uninstall Parallels Tools in Windows using Control Panel - Add/Remove Programs. Manually delete any remaining files in C:\Program Files\Parallels
    3. Boot Windows normally and use "Install Parallels Tools" option in the "Actions" menubar section.
     
  5. D. Alan Stewart

    D. Alan Stewart

    Messages:
    8
    I have the same problem...

    and the suggested fix (uninstall, the reinstall Parallels Tools) did not work.

    This is a BIG problem for me because for some reason the application sharing interferes with using my company's SharePoint site. I'm supposed to be able edit Excel files on the site, but since Parallels application sharing was enabled, Windows complains that I do not have a SharePoint-supporting application to open the file with. I had the same thing happen after installing the previous version of Parallels, but was able to disable application sharing which eliminated the problem.

    When will there be an update to fix this? Since I work in Parallels 100% of my work day I cannot risk running beta software.

    I'm a software developer. If there is a settings file I can manually tweak to get around this, please let me know.
     

Share This Page