Call of Duty WW2 on Parallels 15 not working

Discussion in 'Installation and Configuration of Parallels Desktop' started by AmirM83, Apr 7, 2020.

  1. Maria@Parallels

    Maria@Parallels Problem solver

    Hello, did you check the same issue with Parallels Desktop 16.1.3?
  2. RobertH55

    RobertH55 Bit poster

    Hi I have the same exact issue with 16.1.3. Has anyone been able to resolve it?
    Thank you
  3. sebastienb3

    sebastienb3 Bit poster

    Same issue. Any workaround ?
  4. SachaB

    SachaB Bit poster

    Have you guys tried to use "Enable vested virtualisation" ? I have a similar issue with my MacBook and the game Guild Wars Prophecies which has a consistent fatal error at launch. Unfortunately that option is greyed out for me but it could fix some DirectX related issues for games crashing at launch. The other workout I found was to disable Parallels Display Manager (WDDM) (Device Manager > Display > Parallels Display Apdater) but that is obviously very inadequate since you can run games... but without graphic cards making them basically impossible to play. At least it helped me spot the root of the issue...
  5. TimC17

    TimC17 Bit poster

    I too am experiencing the same issue.
    • I am using Parallels Desktop 16 for Mac, standard edition, 16.5.0 (49183)
    • Load ""
    • I select "Play" on 'Call of Duty: Warzone`
    • The application loads about ~25% before a DirectX Error presents, stating "DirectX encountered an unrecoverable error. Check the readme for possible solutions." Of course doesn't have a readme for running Warzone in Parallels.
    • I did configure the VM so that it runs with the gaming profile, but that doesn't seem to make a difference.
    • I submitted #2958233 in hopes to further escalate this issue.
  6. VinnyG

    VinnyG Bit poster

    Greetings everyone..

    Getting the same error as the rest of the folks in the thread whilst trying to play COD Black Ops: Cold War through

    "No valid DX12 video card found."

    I've tried adding the additional command line arguments: '-d3d11legacy' and '-d3d11' - both do not work.

    Can we please get a Dev to reply on the status of these issues?
  7. PaulC48

    PaulC48 Bit poster

    I have the same issue, any fix been found?
    I would be interested to know from other users which games 'will' work on macos with Paralells. So far, nothing for me including Steam and Origin.
    Thank you.
  8. moderadordecontenidos

    moderadordecontenidos Bit poster

    En Parallels Desktop 17 con Mac Apple M1 no logra correr Call Of Duty WWII.
    Cualquier ayuda sirve.

    Attached Files:

  9. McallenT@P

    McallenT@P Parallels Team

    Hello, Please refer to this KB article: Parallels Desktop supports Direct X 11. COD requires Direct X 12. Thanks.
  10. cem1

    cem1 Bit poster

    I use Paralel Ver. 17.1.4 (51567). ... I have same issue with Call of vanguard . When I try to enter the game I get the following message.
    ''No supported DXGI adapter''
    My Mac graphic card.. AMD Radeon Pro 5600M 8 GB ..
    I tried all step .. but I did see any adjustment about graphic card side ... my windows profile is game only .. So paralel says every think will be come automatically in Ver 17 .. But I see its not like that . . and I saw when I read forum nobody work on this issue in paralel desktop side ... this disappointed me.

    Attached Files:

  11. SerhanY

    SerhanY Bit poster

    Cem merhaba, PD 18.01 versiyonu kullanıyorum, CoD WW2 çalışır mı? Macbook M1 Pro kullanıyorum?
  12. SerhanY

    SerhanY Bit poster

    Hi all,
    I m using PD V18.01, Does it work CoD WW2 on this version? any problem?
    If the game works, I will buy from steam.

Share This Page