Can 3.0 really be this buggy??? VM Edit annoyance

Discussion in 'Installation and Configuration' started by paharris, Jun 18, 2007.

  1. paharris

    paharris

    Messages:
    8
    OK, now I have no ability to edit a VM (non bootcamp) as when I stop or suspend the VM, Parallels Desktop exits.. grrrrrr

    Having deleted my Boot Camp volume due to the issues in previous postings, I am now getting incredibly frustrated...


    Phil
     
  2. wingdo

    wingdo Kilo Poster

    Messages:
    314
    Hold down the command key when double clicking the Parallels Application. Make sure you are NOT double clicking the PVS file.
     
  3. paharris

    paharris

    Messages:
    8
    ok, what exactly does that do?.. Not seeing any difference....
     
  4. dkp

    dkp

    Messages:
    1,367
    It starts Parallels but not the virtual machine. In this state you can edit the virtual machine parameters.
     
  5. wingdo

    wingdo Kilo Poster

    Messages:
    314
    Once you have Parallels running but not automatically starting and stopping your VM, you can select your VM, click edit -> virtual machine, go to options -> gooting and uncheck the "start vm automatically" and "exit application on VM shutdown" check boxes and this issue will disappear. The default for both of these boxes is not checked.
     
  6. paharris

    paharris

    Messages:
    8
    well sure it starts Parallels, but then all I get is the option to select one of the VM's I have.. Hitting Cancel at this point exists from Parallels.. All other menus are greyed out....
     
  7. wingdo

    wingdo Kilo Poster

    Messages:
    314
    If you would select one of the VMs instead of hitting cancel, you could then edit the VM as above and you could disable the auto start and auto end. My understanding was you were trying to figure out how to edit your VM. Did I misunderstand?
     
  8. paharris

    paharris

    Messages:
    8
    No - you are right in what I'm trying, Selecting a VM by highliting it does not enable any menus.....
     
  9. wingdo

    wingdo Kilo Poster

    Messages:
    314
    After highlighting it, did you click the pulsing blue "select" button? That should bring up your VM so you can edit it.
     
  10. paharris

    paharris

    Messages:
    8
    yes and it immediately boots the vm....
     
  11. wingdo

    wingdo Kilo Poster

    Messages:
    314
    And you held down the Command / Apple key whilst double clicking the Parallels app?
     
  12. paharris

    paharris

    Messages:
    8
    actually no button is "pulsing"
     
  13. wingdo

    wingdo Kilo Poster

    Messages:
    314
    OK, well then since you cannot select a VM (never heard of that before) .........

    Navigate to the folder where your VM sits (default is ~/Parallels) ..... make a copy of the VM's pvs file and put it some place safe. Next, open the pvs file with text edit and look for the following two lines:

    Start auto = 1
    AutoShutdown = 1

    Change the 1s to 0s (zero) and save

    you've now set things back to default. I can't answer why you're unable to edit your VM.
     
  14. dkp

    dkp

    Messages:
    1,367
    You need to keep the command key depressed until you have started Parallels and loaded the VM's pvs file. Otherwise it will autoboot as that is what you have told it to do at some point.
     
  15. dkp

    dkp

    Messages:
    1,367
  16. whytwolf

    whytwolf

    Messages:
    4
    I found the Knowledgebase article about using the Apple/Cmd key, and that works. What I don't understand is why the VM auto boots even though I set it to NOT "Start VM automatically when it is opened" - that's UNchecked, and so is "Exit application on VM shutdown. BUT not only does the VM boot automatically when I open it, it exits Parallels when I quit Windows. Clearly the Parallels 3 (4128) is broken regarding this. Is Parallels working on a fix?

    I even looked into the .pvs file as Wingdo described and both settings are correctly set to 0.
     
  17. dkp

    dkp

    Messages:
    1,367
    There's a couple ways to start Parallels. One is to double click on the vm.pvs file which will start Parallels and also start your VM regardless of whether you have autostart selected or not. The other way is to double click the parallels.app file in the Applications folder. That will start Parallels but not start any vm's. And on top of it all, Parallels has at some point added a vm icon to your desktop that is a link to the pvs file and that as you now know will autostart your vm.

    Use your mouse to explore the info associated with the icon you use to start Parallels (ctrl click). It's probably the pvs file, hence your grief with editing the config.
     

Share This Page