Can I hide my virtual machine in Mac's Application Switcher?

Discussion in 'Windows Guest OS Discussion' started by willmow, Oct 12, 2017.

  1. willmow

    willmow Bit Poster

    Messages:
    46
    The Mac's Application Switcher (Cmd-Tab) shows the active apps (including those running under Parallels/Windows), but it also shows the icon for the VM, which is not useful as it is not an app. Is there any way it can be hidden?
     
  2. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,359
    Hi @willmow, please help us with screenshots, we will check and help you.
     
  3. willmow

    willmow Bit Poster

    Messages:
    46
     

    Attached Files:

  4. alexg

    alexg Parallels Developers

    Messages:
    536
    Yes, you can do it in the Parallels Desktop preferences. General tab -> Virtual Machine Dock icon -> None
     
  5. willmow

    willmow Bit Poster

    Messages:
    46
    @alexg
    Tx, but
    a) Where exactly is this (I have Parallels 12): it's not in the Parallels Toolbox, nor in the Toolbox's Preferences, nor in the VM's menu Actions > Configure > General tab. The Applications tab has a couple of Dock-related commands, but...
    b) I'm not talking about the Dock, but the Mac's App Switcher, which is a different thing (see my previous upload).
     
  6. alexg

    alexg Parallels Developers

    Messages:
    536
    @willmow There is no difference between Dock icon and App switcher icon from macOS point of view. If an application is visible in the Dock then it will be visible in App Switcher (Cmd-Tab) and vice versa. I'm talking about Parallels Desktop preferences not VM configuration. Just right-click on Parallels Desktop icon in the Dock and select Preferences... menu item.

    NB. Parallels Toolbox is the different product :)
     
    willmow likes this.
  7. willmow

    willmow Bit Poster

    Messages:
    46
    Wow, magic!!! Thanks for the solution.
    BTW, right-clicking on the Parallels Desktop icon in the Dock does not bring up its Preferences. I had to quit the VM and do it via the Parallels Desktop menu item.
     

Share This Page