Can you transport from PC-->Bootcamp?

Discussion in 'General Questions' started by VydorScope, Mar 31, 2007.

  1. VydorScope

    VydorScope Bit poster


    I have never owned a mac before, so please forgive me if this is a stupid question. I have tried searching the archives here but could no find this answer. I have a new iMac Dual Core 2 17" arriving early next week and I want to use Parallels (already purchased and arrived) to bridge the gap until I can replace most of my software with Mac native versions. As a long time Linux user, I am just tired of MS-Windows. :)

    So I have this laptop that has XP on it, and I like the idea of being able to transport an image of it to the iMac, but I do not see anywhere where it says I can transport and create a Bootcamp partition? I have some processing tasks that can take 10-15 hours to run when on a native 'doz machine, so Bootcamp seems to be the best option for those tasks. Few other programs, like Quicken, Office, and etc I would not see any need to reboot for making a VM the best option.

    So is there a way to us transporter to go directly to a Bootcamp partition, or do I have to reinstall from scratch?
  2. shelbydodgeimp

    shelbydodgeimp Bit poster

    Be careful, once you activate windowsXP in Parallels, you will not be able to do so in bootcamp. It would have been nice if a warning about that was listed in the literature, or in the program.

    Supposedly you can use the bootcamp partician as the hard drive for the Parallels VM... I would check to make sure you can do that with larger drive sizes (windows requires NTFS for anything above 32gb and mac osx can not write to ntfs formated drives out of the box).
  3. VydorScope

    VydorScope Bit poster


    Windows Activation is not an issue for me. But thanks for the warning. I gave up and just installed fresh and working on getting all my app's installed.
  4. flynsqrls

    flynsqrls Junior Member

    read as many posts as you can before installing!

    ...seems like this build 3188 is not in good working order yet!

    ...if you do decide to go forward, i would definitely like to hear how it went and if you managed to avoid all the other problems people have experienced!

    ...good luck to you! ;o)

    blue skies,
  5. VydorScope

    VydorScope Bit poster


    Problems? So far not had any. I just installed via the normal boot camp route, then followed the directions in Parrallels to add it as a VM. Turns out my brandy new iMac is defective and they are coming out tomorrow to fix it so I have not played to much with it yet but so far no problems with Parrellels. After the hardware is fixed I will know better how well ti works or not...
  6. flynsqrls

    flynsqrls Junior Member


    here are just some i found:

    Internet stopped working...
    All of the sudden my internet on Parallels quit was working fine last night then when I tried to get on this morning it no longer works. The internet connection to my Mac is fully working. Any ideas?

    Support Help Needed
    I recently purchased a support per incident because I couldn't solve a problem after several hours. When I got my support incident order number I called and was put on hold for quite a long time, then told to leave a message, someone would call back.

    After two more days and no call back, I tried calling the offices of Parallels, but all I could get was a message that all mailboxes were full and I couldn't even leave a message. I've sent two emails with no answer or call back also. Now after another 24 hours has passed and still no contact, I would like to get the money back that I charged to my credit card if they aren't going to call me. I've since found the answer in some poor guys blog so the problem is solved without the help of Parallels support.

    If anyone on this forum can help by pointing me to how to get hold of someone in billing or administration, I'd really appreciate it. I'm LOVE the product, but the service so far is really 3rd world. Any help from any Parallels employee out there?


    activation key
    I've just bought parallels and am trying to install it but the activation key doesn't work - it says it is invalid but it is the serial number on the envelope. Any suggestions - I can't get through to customer support!

    Phantom Administrator and worse...
    I had a similar experience with the phantom administrator account. It seems to have uncovered a problem with Parallels I don't know how to solve.

    Windows requires that you have at least one account with administrator privleges.
    Thats why when you first install windows and go to login screen you see "administrator".
    If you create another account and give it administrator privleges, then when you log in you don't see "Administrator" anymore, just the one you created and perhaps "guest". The administrator account is still there, its just hidden from you. This isn't a bug, its the way Microsoft designed it to work.

    Unfortunately, parallels seems to automatically log you in as Administrator, even if you have another account that you want to use by default, and thus you have to log out and log in again as youever you are.

    Worse yet, suppose you decide to change the password on the "Administrator" account. In my experience, Parallels still tried to login as Administrator but continued to use the "blank" password. This will hang system startup with an "incorrect password" window hidden under the "Windows is starting" screen. You then have to wait 20 minutes until the screensaver kicks in before you have control of your machine.

    I think parallels should fix this and leave you in the login screen.

    I fixed this on my machine very easily.

    go to Start > Run, type "Control userpasswords2". Then check the box that reads "Users must enter passwords...".

    Now you can add, remove, change users. Then click Apply. Now uncheck the box you checked above. The "Automatic logon" box will appear and you type in your username and password to auto logon to. CLick ok and you're done.

    Simple as that!

    >> Parallels does nothing of the sort. XP does it. This has nothing to do with Parallels and is 100% an XP issue.<<

    I hate to disagree with you, but can safely say this issue is related to Parallels and not Windows XP. Having performed several dozen Windows XP installations, the normal Windows behavior I've witnessed for a non-domain-based install is this:

    1) An Administrator account is created with no password established. A Guest account is also created, but is disabled by default
    2) During the installation, additional user accounts can be specified, but again no password is required. They have administrator access by default
    3) After the installation is done, a restart is initiated
    4) On restart, only the additional user accounts are listed, not the Administrator account
    5) Clicking on one of the user accounts automatically logs in as that user.
    5a) Then, one can go to Control Panel | User Accounts to set passwords, change names, and make more restictive the user account and other additional user accounts, but not the original Administrator account
    5b) In XP Professional, one can go to Control Panel | Administrative Tools | Computer Management to manage users to a finer degree, including the original Administrator account
    5c) In XP Home, one must boot in Safe Mode to access the Administrator account to set the password. After that, booting in safe mode will list the Administrator and additional accounts, but a password will be required to access any password protected accounts, including the Administrator account.

    In all cases, once a password has been set for any account, including the Administrator account, logging into Windows using that acount requires a password.

    Except in a Parallels on Mac installation.

    Parallels bypasses the login screen and automatically logs onto the Administrator account. I don't know how, or why, but it does. Under normal circumstances, the Administrator account is not even visible, unless booting in Safe mode.

    So, this is not a Windows issue. It is a Parallels issue. Maybe it's fixable by running "Control userpasswords2", but that is not normally required by Windows and is at best a workaround to a nonstandard, and undesirable, behavior displayed by Parallels hosting Windows on the Mac.

    Parallels 3188: Win XP very unstable
    Hi there!

    A couple of days ago I bought Parallels (build 3188) to run Windows XP Professional on my 24" iMac with the 2,16Ghz Intel Core 2 Duo processor and 2GB of memory. I run it on Mac OSX 10.4.9 (8P2137). The problem is that I can't get a stable Windows environment!

    I followed the OS Installation Assistant and chose Windows Express (recommended). I proceeded to installing Windows XP Professional from an original CD and every thime the installation freezes, spontaniously reboots or simply gets in a loop. I tried it 6 times and the last time I finally managed to get a working Win XP Professional environment, despite the 2x reboot while setting up...

    Now, my Windows environment has also rebooted 2 times, the USB is not working (inside Windows there are no drivers installed for the USB controller and I can't get any installed either). I tried installing Xp Home Edition, but with the same results. I also tried installing from an ISO file and I tried another Xp Professional disc. After two evenings of installing Windows and pulling my hair out, I gave up...

    Can anybody help me with this?

    sorry to hear about you new computer..., but glad it is being fixed soon! :eek:)
    keep in touch, as i want Parallels Desktop to work for all of us! (really! ;o)
  7. VydorScope

    VydorScope Bit poster

    Well I can say for a fact I have not had any problems with loging on, or passwords. All that works as per normal Windows operation. The only only accounts that are there are the ones that should be. Internet worked fine, and all my USB devices worked fine.

    I hesitate to say much about my experience because I have defective hardware (Apple thinks its the main logic board), but so far I had no problems, just followed the boot camp directions and got that set up. Once that was running I installed/updated parallels and then followed its directions.

    Perhaps because I started with a pure machine and no old versions/patches/etc laying around I had better luck?

    Activation would be a serious problem, but because I use a volume license for xp, I do not have to deal with that. That however is a MS problem not Parallels.
  8. flynsqrls

    flynsqrls Junior Member

    your response...

    ...and the many people using Parallels gives me hope! :eek:)
    (but i will contain my enthusiasm for now...)

    i too have an uncluttered/brand new MacBook...
    have decided to fork out the $$ and buy a full, non OEM version of windows Vista, will install to the most recent Boot camp and wait til i hear more from you (after your Mac has been fixed!)

    blue skies,
  9. VydorScope

    VydorScope Bit poster

    Just FYI, I am right now posting from the Boot Camp partition on the Mac using XP Pro. Shutdown the VM in Mac OS, then booted to it, pluged in my Win-Centric USB TV Tunner watched some TV and hoped on the internet. All works fine.

    This is what I did:

    1) Bought an iMac, with nothing but the base package. The only thing I installed before Parrellels was some basic programs like Firefox and Thunderbird. That plus all the OS Patches.
    2) Downloaded and installed the current build of Boot Camp.
    3) Installed XP from a PRE-SP1 CD to Boot Camp as per Boot Camp's instructions, patched it AFTER all boot camp drivers were in place (had to, need network card to get to MS Update)
    4) Once that was completed, I rebooted to Mac OS X and installed Parrellels from CD. Before using it, I let it update its self.
    5) Then I ran it, and followed its directions for using a BootCamp partition.

    When I first start the VM in Mac OS X, it displays a somewhat hard to read message for several minutes that says something like "Do nothing in here till I am ready for you". I always wait for that before I do anything in it.


    (as for the hardware problem it is an display issue which happens in both Windows and Mac OS X )
  10. chrispf

    chrispf Bit poster

    I have a similar situation as you. I've got a Pre SP1 version of XP. I had it installed on Boot Camp earlier and it was working fine - I was able to install the mac drivers and get the updates as well. This was prior to the last Bootcamp update from 1.1.2 to 1.2

    My problem now is that I did some hardware changes (HD) and have updated everything from bootcamp to OS X. When I go through the same procedure as per instructions in Bootcamp, Windows installs OK, but I an't get the drivers to install - even with an updated Windoz installer. Error message reads "Need to have SP1 or SP2" :cool:

    Just wondering if you were using the Bootcamp v1.2, or v1.1.?
    Any ideas an how to get the drivers installed? I don't know if it'd be too cool to execute them one by one from the CD. :confused:

    I'm installing on a MBP 17" - 2.16MHz CoreDuo; 2GB RAM; 120GB HD; OSX 10.4.9

    Thanks in advance for any suggestions.
  11. VydorScope

    VydorScope Bit poster


    Sorry, but I am a total newb with mac... how do I find out what version of Bootcamp is installed?
  12. chrispf

    chrispf Bit poster


    Thanks for the reply. I'm pretty new to Macs myself, just switched over last spring. It's good to here of our success story. I was also thinking of Transporting from PC to Boot Camp, but after reading other posts, had second thoughts. Fresh install is usually the best bet when it comes to OSes.

    You can check which version pretty much the same way you check programs for windoz - double click on the boot camp icon in the Applications\Utilities folder.

    When the program opens, click Boot Camp Assistant on menu bar (top left, next to the Apple). In the drop down menu select "About Boot Camp Assistant". A window opens with version info.

    Another way is to just "right click" or "ctrl + click" on the program icon and select Get Info.

    BTW - Hope you got your hardware problem fix. If you need help with anything else Mac, a good forum I found is "" real helpful, but not a bit smug - very fun place to get advice for your mac.
  13. VydorScope

    VydorScope Bit poster

    Okay the version line in "Get Info" says "Version 1.2 BETA"

    As for the hardware issue on my iMac, Apple came out twice and replaced across two onsite visits: Motherboard, Powersupply, Optical Drive, and LCD. Now it works fine... makes you wonder why? It would have been A LOT cheaper for Apple to just sent a new machine..... But it works now.
  14. chrispf

    chrispf Bit poster


    Ok, bootcamp 1.2 Now, I'm wondering how you managed to install the Mac drivers for a Pre-XP SP1? In your previous ost you wrote:

    "3) Installed XP from a PRE-SP1 CD to Boot Camp as per Boot Camp's instructions, patched it AFTER all boot camp drivers were in place (had to, need network card to get to MS Update)"

    I also have a pre-sp1 and the first time I installed into bootcamp (v1.1.2) I didn't have any problems. But this time, using BC v1.2, I get error messages first saying I need an updated Windows Installer and after getting that I get another saying I can't install the drivers unless I have at least sp1.

    I can't remember for sure if I updated Windows before I installed the Mac drives when I did the last install.

    You didn't have any problems installing the drivers?

    PS Glad to hear Apple got your Mac fix.
  15. chrispf

    chrispf Bit poster

    I believe I found a way to workround my sp2 hurddle. I've just downloaded a copy of the sp2 updates on my PC and will try to install them to the XP os on the MacBook Pro.

    Will let you know how or if it works out.
  16. chrispf

    chrispf Bit poster

    Well, it didn't work. :(

    I burned the sp2 install package to a cd, then booted into Windows on boot camp. Inserted the cd and copied sp2 to the desktop. I ran the xpsp2.exe from Start>Run. It extracted the files and the install wizard came up just fine, but I got an error saying:

    "There is not enough space on C:\Windows\$NtServicePackUninstall$ to install Service Pack 2. Setup requires a minimum of 4 additional megabytes of free space or if you want to archieve the files for uninstallation, Setup requires 4 additional megabytes of free space. Free additional space on your hard disk the try again." :confused:

    That is hard to believe since Properties on C: says I'm only using 3.44 GB of a 23.4 GB disk. The disk is formatted FAT32.

    I've tried reformatting and reinstalling XP. This time I tried to install SP2 before installing the Windows Installer, it extracts the files and the wizard starts to install, but I get the same error - not enough space. Just 4 stinking MB!!!

    What could be telling Windows that there's not enough room?

    Does anyone have any suggestions on how to get the sp2 installed?
    I wonder if my sp2 package is corrupt?
    Or if Windows OS is?
    The Windows folder alone takes up only 1 GB - I thought it used more than that.
    On my PC it takes up 4.31 GB with all the updates & add-ons.

    I had it once, but I lost it. :eek:

    I just tried something else. During the install of sp2 you have an option to change the location of the $ntuninstall folder. So, I made a new folder on the root directory called backup and got the same results - not enough space. hmmm? :confused:
  17. Tsun-Ming

    Tsun-Ming Bit poster

    Finally, after much searching, I've found someone with the EXACT same problem as me - chrispf's. I've tried using FAT32 and transferring the SP2 package from mac to windows (with 32GB space) and NTFS (with 50GB) - transferring using CD. Both of these had the same results:

    "There is not enough space on C:\Windows\$NtServicePackUninstall$ to install Service Pack 2. Setup requires a minimum of 4 additional megabytes of free space or if you want to archieve the files for uninstallation, Setup requires 4 additional megabytes of free space. Free additional space on your hard disk the try again."

    I downloaded the SP2 package again, in case the one I had might have been corrupt or something, and from different sources, but to no avail.
    I've reinstalled windows almost 5 times now. What is going on? :mad:

    Thanks muchly in advance :)
  18. GaryRmn

    GaryRmn Bit poster

    Boot Camp/Parallels/Vista

    Been reading with interest about the various problems and solutions people have been having with BC, Para and Windows; I have a similar problem which I posted to the forum, but as yet have not had much of a response, perhaps someone on this thread can help..... I HOPE!!

    I have a new MacBook Pro 17", my local Apple representative installed Boot Camp, Parallels and Windows Vista Ultimate, I have since installed Windows Office 2007 on the Windows partition (selected Windows at start up), but when I boot in MAC and open Parallel desktop I can't see any of my Office programs...... HOW DO I MAKE ALL MY WINDOWS PROGRAMS ACCESSIBLE WHEN I'M RUNNING PARALLELS.

    By the way, I have also hit the product registration problem as well..... never get a reply to my email so that I can register product, although strangely enough I did get an instant response to the forum sign-up, perhaps they only want to hear about our problems, not solve them!!!!!:confused:
  19. Tsun-Ming

    Tsun-Ming Bit poster

    Last edited: May 23, 2007

Share This Page