Cannot adjust/change RAM allocatted to VM

Discussion in 'Installation and Configuration' started by JazPhil, Dec 15, 2010.

  1. JazPhil

    JazPhil

    Messages:
    5
    I have put Parallels 6 on a MacBook Pro (Snow Leopard OS X 10.6.5; 2.66 GHz Intel Core 2 Duo; 4 GB MHz DDR3 RAM). Windows 7 Home Premium is the Windows OS.

    I am not able to change the RAM allotted to the VM from the default 1 GB (I would like to increase it). When I open the RAM setting control (via Parallels Desktop > Virtual Machine > Configure > General) the slider for adjustment (see screen shot below) cannot be moved.

    Does anyone know how the slider may be enabled, so I can change the allotted RAM setting? Thanks much in advance for any advice, suggestions, comments, etc.
     

    Attached Files:

    • RAM.jpg
      RAM.jpg
      File size:
      87.1 KB
      Views:
      58
  2. MikeMo

    MikeMo

    Messages:
    42
    You cannot adjust the memory settings when the VM is running. Shut down the Windows VM (Start/Shut Down) and then change the setting. You can also try to "Suspend" the VM.. and then make the changes. Changing the memory settings while the VM is running would be like adding physical RAM to a computer while it is booted up and logged in.
     
  3. Yankee

    Yankee

    Messages:
    1
    Setting

    How do you change the setting in Parallels when it's not running. I can't find the settings or preference tab.


    thanks
     
  4. Statman

    Statman Bit Poster

    Messages:
    32
    In parallels go to Virtual Machine>Configure you will find the ability to change the memory allocated.
     
  5. ThomasB

    ThomasB Bit Poster

    Messages:
    22
    I'm also having this problem of not being able to change the memory. It says VM must be shut down to make the change. But, when VM is shut down I no longer have the configure option to get at the memory settings. Any help is appreciated. I'm using the latest version of 6 (6.0.11994)
     
  6. Smudge2

    Smudge2

    Messages:
    37
    The Virtual Machine>Configure menu will only appear when you have the VM window active. If you have configured the VM to start up automatically when you open the VM window, then you won't be able to make the changes because it will then be running.

    Instead select the Window>Virtual Machines List menu which will bring up the window of all your VMs. Right click on the VM entry and choose Configure. Now you should be able to adjust your settings.

    If you have configured Parallels to automatically launch the VM when the application starts (and perhaps quit the app when the VM is shutdown) then it is a bit more difficult to get into the settings. I think if you hold down Option key while launching the application, it won't start the VMs. If not, you can turn off the option to auto start the VM when the VM is running. Then quit the VM/app and try again and it shouldn't auto start.
     
  7. ThomasB

    ThomasB Bit Poster

    Messages:
    22
    Thank you so much! Worked perfectly by right clicking on the VM list and selecting configure. I have 8Gb of ram and only had 1Gb allocated to VM Windows 7 64bit. I bumped it up to 3Gb
     
  8. grajay

    grajay

    Messages:
    7
    Brilliant - solved my newly installed problem too :)
     
  9. Cadam01

    Cadam01

    Messages:
    1
    I tried these steps but once my VM starts again it reverts back to the 1GB... please help
     
  10. rickyjohn

    rickyjohn

    Messages:
    1
    How to get to window virtual machines list

    "The Virtual Machine>Configure menu will only appear when you have the VM window active. If you have configured the VM to start up automatically when you open the VM window, then you won't be able to make the changes because it will then be running.

    Instead select the Window>Virtual Machines List menu which will bring up the window of all your VMs. Right click on the VM entry and choose Configure. Now you should be able to adjust your settings.------->>>>> but how do i get here from mac os x???

    If you have configured Parallels to automatically launch the VM when the application starts (and perhaps quit the app when the VM is shutdown) then it is a bit more difficult to get into the settings. I think if you hold down Option key while launching the application, it won't start the VMs. If not, you can turn off the option to auto start the VM when the VM is running. Then quit the VM/app and try again and it shouldn't auto start."
     
  11. JamesP11

    JamesP11 Bit Poster

    Messages:
    4
    Hi There,

    I'm having the same problem with Parallels 12/Win8. I'm running a 13" MacBook Pro Retina late 2012. I'd like to increase the RAM settings, but the vm opens automatically when I open Parallels. I've tried holding down the alt/option key as Parallels opens, and then right clicking on the windows vm, and then selecting configure. The windows vm opens and all sliders are deactivated.

    Help!

    James
     
  12. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi JamesP11, please set what happens when you open Parallels Desktop as describe in this article and then you will be able to resize the RAM allocated for Windows virtual machine.
     

Share This Page