Cannot install Parallels Tools

Discussion in 'Installation and Configuration' started by PeterSC, Jul 5, 2011.

  1. BSartist

    BSartist Bit Poster

    Messages:
    55
    Interesting. Could it be possible that the time capsule device has some hooks that allow block level deltas when used with time machine whereas regular drives dont? Sounds like a far fetched theory so now I'm going to have to reinvestigate my original assumption. You've piqued my curiosity.

    One thing I should have mentioned is that I'm still on OSX 10.5. If you are on 10.6 or greater, maybe they added block level incrementals to time machine.

    We're way off topic so I'm glad nobody else is reading this thread ;-)
     
  2. GordonR

    GordonR

    Messages:
    11
    Is it in fact safe to say that Fusion is a bit slower, but more reliable? I see the patch/hotfix issues constantly and the tools install issues as well - and it all says parallels is a little below prime time. Any thoughts from those with the experience to know?
     
  3. RusselJ

    RusselJ Banned

    Messages:
    25
    The solution to mine is the manual uninstall of Parallel Tools outlined in article 8969. =)[​IMG]
     
  4. PeterSC

    PeterSC

    Messages:
    12
    I'm on 10.6.7.

    About Fusion, well I had version 2.0 before Time Machine and became very well versed in loading Vista into a VM. I have no idea what Fusion 3 is like, but 2 was ugly. I went with Fusion originally as we were using VMware at the office.
     
  5. Marc Bernstein

    Marc Bernstein

    Messages:
    5
    I resolved this issue on my machine. After submitting a ticket, I was referred to thread http://forum.parallels.com/showthread.php?t=32137

    I have posted my solution below, as well as to the above thread:

    After this happened to me for the first time after many upgrades over the last two years without issue, I submitted a ticket and was sent to this thread. After reading all the way down, I decided to try MisterAl's solution (the post immediately preceding this one). It worked like a charm. No Microsoft cleanup utility was required for me.

    One thought I have, based on what changed on my computer since the last Parallels upgrade just a couple of months ago, is that it was one of three things which caused the hangup.
    1. Running in bridged vs. shared networking. I used to run in shared. I now run in bridged.
    2. Installing Citrix GoTo meeting which runs in the background
    3. Installing DropBox, which runs in the background.

    Anyway, the following steps fixed the problem.

    1. Turn of Airport (never used to be a problem, but easy to disable)
    2. Remove my USB Keyboard and mouse (they never used to be a problem, but it was easy to just unplug them)
    3. Remove my external monitor
    4. Turned on my Windows XP VM.
    5. Turned of programs running in task tray that were new since last upgrade (GoTo Meeting, DropBox).
    6. Turned off Windows Defender...not because I thought it was a problem, but because it's Monday morning and it was doing it's scan, which just slows the system down.

    Since my Parallels Tools had last been aborted, it won't start automatically, s I went to the Parallels menu option of Virtual Machine, Install Parallels Tools.

    It started up and ran straight through, finishing in about 2 minutes, maybe.

    MBP late 2008
    8GB Ram
    Windows XP VM

    Parallels Build 6.0.12092
    (Revision 670880; June 26, 2011)
     
  6. johndoe

    johndoe

    Messages:
    22
    unfortunately, i have tried this and other items to no avail.

    (and, also unfortunately, i still had Parallels paid support at the time this first happened. i say unfortunately, because i contacted them, and they persuaded me to let their tech support use a remote-desktop-client to poke around in my VM and see what was going on. as i watched these clowns, they started turning stuff off that they shouldn't have been turning off. the most unprofessional behavior i've ever been a part of. i immediately shut down the session!)

    fortunately, i discovered a separate solution, which takes a little brute force:

    1) as the Parallels Tools updater starts, also simultaneously start Process Explorer (it is a substitue for Task Manager).
    2) show processes in hierarchical display
    3) watch for the activity and popping up of dialog boxes as Parallels Tools Updater goes through it's paces.
    4) when you get to the dialog that comes up immediately before the "Rolling back changes" dialog
    4a) go to the Process Explorer window and find the process for the dialog under the Updater process
    4b) kill it.
    5) repeat (4) until the tools are fully installed.

    this allows the Parallels Tools Updater to complete, and allows me to get back to work!
     

Share This Page