Cannot to update macOS VM - Parallels 19.1.0, Intel silicon

Discussion in 'macOS Virtual Machine' started by SteveN39, Oct 29, 2023.

  1. SteveN39

    SteveN39 Bit poster

    Messages:
    7
    Since updating Parallels to v 19.1.0 (54729) I cannot update macOS Ventura 13.5.2 to either 13.6.1 or Sonoma 14.1.

    When attempting update it downloads the installer fine, goes through the Preparing Update phase and commences the reboot displaying the Apple logo and a progress bar - which stalls at about 45% before eventually booting to macOS 13.5.2.

    Host is running macOS Sonoma 14.1 on Intel CPU

    Any suggestions?
     
  2. toonetown

    toonetown Member

    Messages:
    84
    I have been having the same issue. I am unable to update Ventura or Sonoma VMs. I've tried upgrading from within system settings, downloading and running the full installer, installing from recovery, erasing the hard drive and installing from recovery, installing to a secondary hard drive and installing a fresh VM. Nothing works - it fails at "Failed to prepare the software update. Please try again." (except for trying to install a fresh VM...that one fails creating the disk image). I have tried changing my hypervisor (no luck), bumped up the RAM and CPU available to the VM (no luck).

    Needless to say - "Please try again" didn't work either... :)

    Is anyone else seeing this and/or are there other things that can be suggested? I actually have Sonoma 14.1 (trying to update to 14.1.1) and Ventura 13.6 (trying to update to 13.6.1). Those were installed from earlier though - prior to upgrading parallels to 19.1.1 (which I'm currently running). My Monterey VM doesn't have any problems.

    The console shows the following error when trying to install from either system settings or from the full installer - even when installing to a clean empty disk:
    Full replacement is required as opposed to incremental patch​
    The odd thing is I get this error even when downloading and running the full installer.

    I would really appreciate any suggestions as well.
     
  3. DaveInToronto

    DaveInToronto Bit poster

    Messages:
    3
    I'm also seeing this same problem. I'm unable to update any macOS VMs. I have a Monterey (12.6) VM that I've given up on since I can't update it. I created a brand new VM with Sonoma (14.0) and manually moved my data over to it. Now I can't update that one to 14.1.1.

    Parallels is pretty useless if you have to create new VMs every time Apple pushes a point release upgrade for.
     
  4. Macintosh Rescue

    Macintosh Rescue Member

    Messages:
    48
    I managed to get a Ventura guest updated a couple of days ago with the Parallels Desktop 19.2.1 update on macOS Sonoma 14.2.1 (MacBook Pro M1), however I tried to update a VM with Monterey 12.6 to 12.7.2 on my Mac mini M1 this morning and it failed to a black screen.

    I have a feeling that macOS host updates are required to fix this because Parallels just offers a wrapper for the Apple Hypervisor framework, and if that's the case then this will never be fixed; Apple have never cared about compatibility in a serious or useful way.
     
  5. ed2112

    ed2112 Bit poster

    Messages:
    1
    Same problem here. The host is 2017 iMac Pro running latest Sonoma release (14.2.1). I have a guest VM that was running Ventura that upgraded to Sonoma 14.0 with successfully. Ever since that time, any updates to Sonoma on the guest hang, then finally fail, and the guest VM ends up restarting into Sonoma 14.0. Endless loop...

    I am also running the latest version of Parallels Desktop 19.2.1 (the problem existed long before with earlier versions of Parallels, and still exists with newest version).
     

Share This Page