Cannot "unshare" folders

Discussion in 'Installation and Configuration' started by oceanben@earthlink.net, Dec 15, 2008.

  1. I have a number of drives attached to my OS-X system that I have no need to share with my Windows Virtual machine. Under the "Shared Folder" tab in the Virtual machine configuration utility I have checked the box for "Share Mac OX folders with Windows - Home Folder Only. Everything else is unchecked (see 1st attachment - Picture 11.png)).

    However, when I boot my virtual machine, all my attached drives and partitions show up under MY Computer with their own drive letters (see 2nd attachment - Parallels Picture.png). This causes conflicts with some of my company network drives which need to use those drive letters. How do I get these OS-X volumes to stop "mounting?"
     

    Attached Files:

  2. jtkohl

    jtkohl

    Messages:
    7
    I had the same problem. It's SmartMount, on a separate preference page, that's mounting your non-boot volumes.
    Seems to me it should be on the same preference pane as shared folders, since it shows up in Windoze the same way (drive letters) but the Parallels developers thought it should be separated.
     
  3. John@Parallels

    John@Parallels

    Messages:
    6,343
    Please disable Smart Mount in Configure as jtkohl suggested
     
  4. chabig

    chabig

    Messages:
    133
    I have Smart Mount disabled, and my Mac drives "still" show up in Windows. I'm not sharing anything Mac with Windows, nor Windows with Mac, yet they still show up in My Computer every time Parallels starts. Any ideas?
     
  5. John@Parallels

    John@Parallels

    Messages:
    6,343
    There is another setting for Share Mac OS disk in Shared Folders
     
  6. chabig

    chabig

    Messages:
    133
    Yes there is, and all of the checkboxes in Shared Folders are turned off. Still, the virtual machine automatically mounts my Mac drives. I can't figure this out.
     
  7. DaTa

    DaTa

    Messages:
    192
    Hi, chabig

    would you, please, find your virtual machine's bundle (file with .pvm extension) -> right-click -> show package contents -> copy config.pvs and attach it here.
    Also you can try this:
    - remove Parallels Tools from Control Panel -> Add or Remove Programs,
    - shut down the machine,
    - click Configure -> Shared folders, make sure nothing you don't want is checked,
    - disable Smart Mount,
    - save changes, start machine and install Tools again by ckicking Actions -> Install Parallels Tools.
     
  8. chabig

    chabig

    Messages:
    133
    I'll try removing the tools, shutting down, resetting the sharing prefs, restarting, and reinstalling the tools. In the meantime, here is the config file:

    http://public.me.com/chabig/config.pvs
     
  9. xochi

    xochi

    Messages:
    88
    I've had same issues: the SmartMount setting is not "sticking" in some cases, and may be getting reset when Parallels tools updates.
     

Share This Page