Can't Clone VM

Discussion in 'General Questions' started by ConorS, Jul 6, 2009.

  1. ConorS

    ConorS

    Messages:
    8
    Hi,

    I use parallels 4 and I am trying to clone my VM and it only leaves me with an image 4 GB in size. The original is 20.

    Also if I just try to copy the pvm file when the machine is stopped it fails after 4GB. Does anyone know what this might be.

    Conor
     
  2. desgael

    desgael

    Messages:
    344
    Can you provide the exact error message?
    In any case, repairing the disk permissions on a Mac using Disk Utility would not hurt to try. The following article (part of it) has the description on how to perform it: http://kb.parallels.com/en/4790
     
  3. ConorS

    ConorS

    Messages:
    8
    If I use the parallels tool to make a clone I don't get an error, the resullting clone is just too small and non-functional.

    I'll try your suggestion.
     
  4. desgael

    desgael

    Messages:
    344
    I suppose this means the same - there is an error on the Mac side which would not allow to copy a file this large. Parallels tools making a clone may just not show the error. If I recall correctly, there were similar issues with different Mac applications, referring to I/O errors, but that needs to be verified first. That is why the exact error message when you try to copy .pvm manually is absolutely necessary.
     
  5. ConorS

    ConorS

    Messages:
    8
    I tried it again and it got to about 6gb, and then failed with the same error :

    Sorry, the operation could not be completed because and unexpected error occured (Error Code -1309).
     
  6. krisK

    krisK

    Messages:
    5
    I am having a similar problem but different error code... (-36). I just tried cloning and it completed without error but the clone is too small. Actually, the cloned .pvm is the same size as when a copy fails. So it looks like they fail at the same point..
    Kris
     
  7. ConorS

    ConorS

    Messages:
    8
    Same thing that happens to me! Let me know if you can figure it out.
     
  8. Brian Trombley

    Brian Trombley

    Messages:
    7
    Identical problem on my end, but I'm not getting an error. I'm trying to close a 28GB PVM file. The cloning operation appears to work fine, but when I check the PVM on the external drive, it's only 4GB. Running that PVM, I get an error that no OS is present. FWIW, I'm copying to a external drive with 150MB free space, FAT32 format.

    This may or may not be related, but when trying to manually copy the PVM, I get a warning that I may need Administrator permissions to continue. After hitting continue, I get an error immediately with error code=0.

    I'd appreciate any help you can provide.
     
  9. desgael

    desgael

    Messages:
    344
    There is a known limitation to a single file size that can be copied to a FAT32 disk. To be more precise, it is 2 Gb for FAt 16 and 4 Gb for FAT32, so this seems like exactly the matter.
    i.e. this can be viewed here: http://www.experts-exchange.com/Operating_Systems/MSDOS/Q_20343072.html
    Try cloninig to the NTFS format disk, there should not be any errors.
     
  10. Brian Trombley

    Brian Trombley

    Messages:
    7
    Aha. Thanks, I appreciate it.
     
  11. Mark Ebbert

    Mark Ebbert

    Messages:
    4
    What about the other error?

    I don't see an answer for KrisK. I am getting the same error (-36) when I try to copy the VM and cloning acts like everything is just fine, but the clone is small and worthless (cannot connect to HD 1). I have tried cloning to my Mac HD and to an external HD. Neither of the HDs are FAT32. Both are Mac OS Extended (Journaled).

    This is pretty scary considering the clone process appeared to work just fine.
     
    Last edited: Aug 24, 2009
  12. iota

    iota

    Messages:
    20
    Have you tried to copy and paste .pvm file? then rename it?
     
  13. Mark Ebbert

    Mark Ebbert

    Messages:
    4
    Yes, that is what I was referring to when I said I couldn't copy the VM. I have tried the entire .pvm file as well as just the .hdd file within.

    I have also tried to repair and change permissions on the file(s).
     
    Last edited: Aug 25, 2009
  14. Rail Rogut

    Rail Rogut Bit Poster

    Messages:
    38
    I have the same problem with Parallels 10 and OSX 10.8.5 --- I can't clone or copy the VM. I have tried repairing the drive & permissions.. nothing works...??

    Any ideas?
     

Share This Page