Can't Compress -- No Snapshots, No Undo Disk

Discussion in 'Windows Guest OS Discussion' started by jegillick, Sep 27, 2007.

  1. jegillick

    jegillick

    Messages:
    22
    Today I realized that my Windows hdd file is 37GB and I need to clear up some space on my computer. I tried using the disc compact function, but it complained that I had either snapshots or an undo disk. I did have a bunch of snapshots so I spent the rest of the afternoon removing them (it took forever). Once the snapshot manager said "No Snapshots Available", I tried the compacter again. Again it complained with the same error. I wish it were more specific.

    * I have no snapshots
    * The undo disk is disabled (under Options > Advanced)

    The virtual machine was created through transporter (pulling windows from another PC). Could this be the cause? Here's the full error in all of it's glory:

    What is a "plain disk"?

    Thanks!
     
  2. Alicia

    Alicia Parallels Team

    Messages:
    683
    Hello,

    try to perform these steps:
    1. Shut down the virtual machine. Click Start and choose Shut Down.
    2. Close Parallels.
    3. Browse to the Applications - Parallels folder and start Parallels Image Tool.
    4. Choose the required virtual hard disk of the virtual machine and choose the "merge snapshots" option. This will take a while.
    5. Delete the snapshot folder and snapshots.xml file located in the virtual machine folder (Documents - Parallels - virtual machine folder - snapshots folder)
    6. Open Parallels and the virtual machine.
    7. Try to compress the virtual disk once again.

    Best Regards,
    Alicia
     
  3. jegillick

    jegillick

    Messages:
    22
    That didn't work.

    * I shutdown the Virtual Machine
    * Opened the Parallels Image Tool
    * Browsed to the hdd file: /Users/me/Documents/Parallels/Microsoft Windows XP/winxp.hdd
    * Got the following error:

     
  4. aclaver

    aclaver

    Messages:
    27
    You should really have looked through your own forums before you made such an obvious comment. You'll see this issue appear in a number of threads with many comments by experienced users. This is obviously a bug that need to be squashed.

    (BTW: I also have this issue and have tried numerious fixes to no success. )
     
  5. brkirch

    brkirch Kilo Poster

    Messages:
    415
    What build number of Parallels are you using? If it is anything other than build 5160, go here to download the latest version.

    Have you tried the corrupt hdd fix yet? (just to warn you though, if there are more than 2 files in your hdd file you will lose all changes since the first time you made a snapshot if you go though that procedure)
     
    Last edited: Sep 28, 2007
  6. jegillick

    jegillick

    Messages:
    22
    I was just prompted to update Parallels Desktop. After the upgrade everything seems to work OK now. Thanks.
     
  7. pendolino

    pendolino

    Messages:
    75
    i upgraded but unfortunately still facing the same problem.

    i am on build 5160
     
  8. pendolino

    pendolino

    Messages:
    75
    looks like it worked now. i think when i upgraded to 5160 i was supposed to reinstall parallels tools.
     

Share This Page