Cant connect my USB device (telescope) after PD 17.1.0 Update

Discussion in 'Windows Guest OS Discussion' started by yasara, Oct 19, 2021.

  1. MuratA1

    MuratA1 Bit Poster

    Messages:
    5
  2. Hound1

    Hound1 Bit Poster

    Messages:
    10
    I am also having USB issues with 17.1. All my PIN pad devices stopped connecting. 17.01 was working fine. How do I get back to 17.01?
    I'm running MacOS 11.6 and Windows 10.
     
  3. salvomic

    salvomic Kilo Poster

    Messages:
    172
    ok, did so.
    But that didn't solve my situation. CZUR ET18 pro does not go into either Windows 10 or macOS Monterey RC2 and maybe that's a problem with this macOS update.
     
  4. Hound1

    Hound1 Bit Poster

    Messages:
    10
    Reinstalling 17.01 fixes the problem.
     
  5. DragoB

    DragoB Bit Poster

    Messages:
    5
    Exactly the same issue for me - just downgrading now to see if it fixes this - have wasted hours trying to fix this myself!
     
  6. BenS24

    BenS24 Bit Poster

    Messages:
    1
    Same for me. Running up to date Windows 10, and with the last Parallels update (17.1) a development board with a multi-endpoint USB interface (CDC, HID, and MSD) stopped working in the VM - but still worked in the Mac. Downgraded to 17.0.1, and all is well. It looks as though something was causing the VM to drop DTR to the CDC interface - there's a 1Hz heartbeat that the development board generates toward the serial port, and an LED on the board that blinks with the serial traffic. That LED stops blinking as soon as I fire up TeraTerm and try to open the COM port (yes, the COM port appears in the Device Manager list, and it says it's working properly, but no traffic in or out.
     
  7. Yuriy5

    Yuriy5 Bit Poster

    Messages:
    1
    My Arduino Mega 2560 doesn't work at all with 17.1.0. Reverting to 17.0.1 helps.
     
  8. salvomic

    salvomic Kilo Poster

    Messages:
    172
    After the official release of Monterey I tried with the CZUR driver (scanner) on another computer where it worked before (with Big Sur): it doesn't even go there, so I think my problem is not (only) with Parallels but precisely with Monterey 12.0.1, That's why downgrading to 17.0.1 doesn't change anything here.
     
  9. Zezrum

    Zezrum

    Messages:
    1
    Thank you folks for the info here. I also had my USB device stop working with 17.1, and rolling back to 17.0.1 fixed it.
     
  10. AndrewP28

    AndrewP28

    Messages:
    1
    My USB device wasn't working after the recent upgrade, downgraded to 17.01 as
    My USB device wasn't working after a recent upgrade, downgraded to 17.0.1 after reading this and it has solved the issue. Thank you!
     
  11. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    908
    Hello, we are glad to hear your issue has been resolved. Thanks, Parallels Team.
     
  12. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    398
    @DebasmitaM@Parallels : Exactly how does going back to an earlier version 'resolve' the problem? Or were you just being sarcastic?
    17.1 clearly has problems communicating with USB devices that aren't shared by the host and they've paid for the upgrade to 17.1. They shouldn't have had to revert to an earlier version of Parallels. How irritating.
     
    BrentM3, VladislavS3 and CarlosF6 like this.
  13. GlennS5

    GlennS5 Bit Poster

    Messages:
    14
    I assume they used the wrong word since this is a workaround until solved and not a solution. I have a similar problem after upgrading to 17.1 and waiting for a new version/build where this problem is solved. Parallels is usually pretty slow to release a fix in cases like this and hopefully they will speed things up a bit and fix the USB issues introduced in 17.1.
     
  14. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    398
    I'll go one further and assume that there are several new people responding to these that don't quite have a grasp of the English language and don't understand what they read... and grinding through these at a rapid pace. As a result, some people are getting responses like this and then getting their ticket closed, when in fact nothing's been resolved. As a former employer, there's a word (and a quick solution) for this, but I'll be nice.
     
  15. GlennS5

    GlennS5 Bit Poster

    Messages:
    14
    Well you might be right :) I opened a ticket and had to tell them many times that Yubikey is not a USB keyboard since they kept taking about my "USB Keyboard issue". I also have to say that 1st line support should get better training so they can sort out cases which require a bit more than sending some links. For example I opened a ticket because my Yubikey do no longer work after upgrading to 17.1. When they send me several articles that describe USB keyboard issues it's obvious they have no idea what I'm talking about. When I told them to dig a bit deeper instead of sending me articles that is very basic they realised that more competent support is required and sent the ticket to the next level of support. The Parallels 1st line support is not good at all.
     
    Mark Fine likes this.
  16. WilliamG17

    WilliamG17

    Messages:
    1
    Having all sorts of USB problems with 17.1 as well - primarily with my USB Audio Headset that I'm passing directly to the VM via USB. Lost all audio.

    Downgraded to 17.0.1 and things seem to be working again - running MacOS 12.0.1.
     
  17. JoeK7

    JoeK7 Bit Poster

    Messages:
    4
    Thanks Guys! This place it the greatest. Was pulling my hair out on this one, and although I just downgraded (thanks for the link) I have not tried it yet, but at minimal; nice to see it was not just ME!
     
  18. JoeK7

    JoeK7 Bit Poster

    Messages:
    4
    it worked!!
     
  19. UweR7

    UweR7 Bit Poster

    Messages:
    3
    Downgrading worked for me as well. A "normal" FAT32 formatted USB stick did work, but my Android Smartphone MTP mount didn't work anymore. Due to this bug I dug out two native solutions on MacOS other than buggy old Android File Transfer (the smartest being mounting the phone via SSHFS). Besides, I was close to cancelling my Parallels subscription which happens to renew in November and reverting back to VirtualBox.
    Here's the knowledge base article mentioning that "some" users are experiencing USB issues with 17.1.0: KB128608
     
  20. ThomasH76

    ThomasH76 Bit Poster

    Messages:
    5
    When will the USB bug be fixed? The "Update me now"-Message starting Parallels is annoying.
     

Share This Page