Cant download parallels!!

Discussion in 'Parallels Desktop for Mac' started by sarsells, May 31, 2006.

  1. sarsells


    I was having problems with getting parallels up and running. I installed 3 different machines, and in the end, as I was not sure how to delete them, and was getting error messages, i decided to uninstall and start again. I dragged the parallels items from my applications folder into the trash (I am new to macs). then I went to the parallels home page, and pressed for the download. i have tried 4 times, and each time I am told that the image would not mount!
    So what do i do now?
    I need windows. I have bootcamp on here, but it would make my life SO much easier if I could have them up and running together.
  2. monoclast


    Did you download it with Safari?

    Let me guess - you are downloading the image with Safari, right? :rolleyes:

    I had the same problem. So I tried downloading with Firefox and found the image mounted just fine after downloading it with Firefox. (I have no idea why Safari would do something differently with a downloaded DMG file!)

    Try downloading it with something other than Safari and see if you are having the same problem. :)
  3. dkp


    You wait your turn - there are thousands of people trying to dl the new release candidate and the server is probably getting pretty beat up. I used wget to download it and it took quite a long time. If it didn't automatically do a re-get on timeout it would never have finished. Using a web browser is a waste of time for the time being.

  4. Jisi


    Download via wget. Us Terminal, type

  5. joem


    Resuming hung Safari downloads

    First, just dragging the app to the trash won't uninstall all of it. Run the uninstaller that comes with it if you want to uninstall first.

    Secondly, you can download using Safari. Display the download window while downloading. Watch the progress. When it hangs and there is no progress for half a minute or so, click the "x" to stop the download, then click the little arrow in the circle that the "x" turns into to resume it. You will see more progress. I had to do this about three times to get the entire thing. It worked just fine, and works with other downloads that hang as well.

Share This Page