Can't Edit Virtual Machine

Discussion in 'Parallels Desktop for Mac' started by Luke Dog, Jun 8, 2007.

  1. Luke Dog

    Luke Dog

    Messages:
    11
    Seems as though I have to stop the VM in order to edit the properties yet every time I stop the VM it closes before I can do anything.

    Any thoughts on how to fix this?
     
  2. gtjuggler

    gtjuggler

    Messages:
    22
    Cant you just Option-Enter , get out of full screen mode, and hit the stop button on the side? Last time I checked it doesn't close the VM window after suspending windows.

    It would if you apple-Q'ed from inside parallels though.
     
  3. dkp

    dkp

    Messages:
    1,367
    Before you stop the vm go to the Parallels menu and select "Open". This will keep parallels alive after you close the VM. Then you can edit the vm. I'd turn of Autostart so this doesn't happen in the future.
     
  4. Luke Dog

    Luke Dog

    Messages:
    11
    I clicked open and then hit stop and it disappears. poof.
     
  5. AlanH

    AlanH Kilo Poster

    Messages:
    316
    There's a config file for the VM with a .pvs extension in ~/Library/Parallels/<your vm name>. It's a text file and can be opened in TextEdit. There are two lines in there:

    Start auto = x
    AutoShutdown = x

    where x is 0 or 1

    If x is 1 then the VM will auto start and auto shutdown. Edit these values to 0 and save the file. It will then not start/stop automatically, and you will be able to edit it in the stopped state.
     
  6. dkp

    dkp

    Messages:
    1,367
    In the Parallels directory in under your home account there is a xxxxxx.pvs file for that VM. It is a text file. You can open it and edit it to disable autorun. Make a copy of it first.
     
  7. Luke Dog

    Luke Dog

    Messages:
    11
    you're the man.

    Worked perfectly.
     

Share This Page