Can't install Tools for Boot Camp

Discussion in 'Parallels Desktop for Mac' started by hussainahm, Dec 1, 2006.

  1. 5150Joker


    Well somehow my Windows installation got hosed as well as my Mac partition since bootcamp refuses to create a new 32 GB partition and disk utility won't allow me to make a backup of my HD. Going to steer clear of Parallels until this version reaches release.
  2. Erik2v


    Error code 1

    I had the same problem. Everytime I tried to install, it said it was already installed. It would fail upon uninstall as well.

    Here's where I got to. I uninstalled (error code 1), then installed (said already installed).

    Then, I edited my boot.ini to manually add the parallels config. See a previous post in this thread for what to add.

    Then, loaded parallels under OSX, selected Parallels from the boot menu.

    It boots to Winxp.

    I can even use the menu from within bootcamp to run windows.

    The only outstanding problem I have on my MacBook Pro is being able to use the keyboard and mouse, even external devices. WinXP sits at the login screen and I am unable to do anything.

    Any suggestions for unresponsive keyboard/mouse?
  3. mattmichielsen


    So you added "multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Parallels configuration" /noexecute=optin /fastdetect /kernel=ntkppvs_.exe /hal=halppvs_.dll" to your boot.ini?

    In mine (Macbook Core Duo), it references partition(3), and I don't have those files (ntkppvs_.exe and halppvs_.dll).

    I've tried finding those files by using wix and other various tools on the installer, but haven't been able to find those files. I'm pretty anxious to try this. Can anyone tell me how to obtain those files? I think it should work if I get them.
  4. nickdaniels


    Same here, I have tried to add the line to boot.ini but when xp boots in Parallels it can't find the new HAL and I can locate it either. This is probably due to the fact the installer never gets to creating a new hardware profile.

  5. DanWilliams

    DanWilliams Bit Poster

    Service Pack 2

    I have had all these problems too, I solved them all by creating a service pack 2 disk. I started with an Xp corporate disk.
    I downloaded a program called nlite and the network install of sp2 from MS. Then the program will read the cd integrate the service pack and leave you with a bootable image. It is bigger then normal so will need to burnt to a DVD.
    It only took about 30 mins. Which is better then the best part of a week I've spent trying to get it working.
    Once I installed with this everything worked fine.

  6. Erik2v


    At one point mine was the same way. I couldn't locate the actual dlls it was referencing. I just tried multiple times to install, uninstall, etc... I was using some command-line switches - I tried too many to remember which worked.

    If my boot.ini references partitition (3) it will boot into windows, but will fail when loading from parallels. If I switch it to (1) it runs paralles but won't from a regular bootcamp bootup.
  7. Erik2v


    Another thing I've tried is to run with the command-line: /V/a

    This will attempt to run admin., it'll fail when trying to find a dll. If you run the installer without the command-line and wait for the dialog, you can go into your temp folder and copy all the files before the setup will autodelete them when you close the dialog.

    I copied the dll in question to the other folder in the temp "_is" folder. When I ran it doesn't complain about the dll missing. It will ask you where to install. If you pick c:\ it should install on the root. That may be how I got the missing hal dll and the others. I still had to manually add the entry into boot.ini.

    Just something to try.
  8. Erik2v


    I fixed my missing mouse and keyboard. I ran setup.exe from the vmtools.iso. It installs a bunch of drivers. I did this from within bootcamp.

    Now everything seems to work just fine within the vm bootcamp launch. However the tools installation looks like it broke my non-vm bootcamp.
    Last edited: Dec 10, 2006
  9. zerologic


    Confirmed! Easy as pie.

    Don't forget to install the Parallels tools or the mouse/keyboard won't work.
  10. sabotage


    Check out the new beta. You no longer need to install the tools first via bootcamp. Be sure to uninstall first via native bootcamp.
  11. outlawrocketman


    uninstalling and installing the tools for winxp

    Don't know if this is the fix for you but it worked for me, when upgrading to the latest beta. I upgraded to 3094 my already installed win xp pro image hung with an error about the latest tools needing to be installed. I booted that image into safe mode, uninstalled the parallels tools package , (rebooted I think), booted safe mode again and installed the parallels tools. All is now well in my Win XP parallels image.
  12. markchili


    Boot Camp Boot Problems Missing hal.dll

    Hello all,

    i think, mostly i do have the same problems as all of you already had.

    I´ve installed Parallels Tool in BootcampXP, rebooted osx -> failure; formated FAT to NTFS -> other failure, added the (Coorp. edition prob) from the XP Pro SP2 Coorp CD/DVD, and do now get the missing hal.dll failure.
    I already were not able to install the Parallels Tool in XP in the right way i think.
    It also interrupted without any failures / installation completed report. I found a failure file as mentioned from other in a thread before, so i decided to copy from another disc, to try to install with /a and /v/a all with the same result, but with a failure popup.

    As well i decided to edit the boot.ini by myself into:

    [boot loader]
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Parallels configuration" /noexecute=optin /fastdetect /kernel=ntkppvs_.exe /hal=halppvs_.dll

    Now after booting MacOS i´m getting the next failure in Parallels:

    If i choose in the selection 1 Microsoft Win XP i´ll get
    "Windows could not start because of a computer disk hardware configuration problem"

    if i choose the 2 one the Parallels config i´ll get a
    "windows could not start because of the following file is missing or corrupt:
    root:sys32 hall.dll
    Please recopy or something like this.

    After 5hours of trying i´m really tired now.

    Any ideas how to fix that prob now?

    MBP (1. Gen) 2GB RAM 160GB (XP / OSX)


  13. brians


    I have a client who was running a retail version of Parallels Desktop for Mac and we tried upgrading to the latest version of 3170 RC3, but get the error:

    Parallels Desktop for Mac has detected, Parallels Tools for Bootcamp (Beta 1 Version), please uninstall before continuing.

    I've already uninstalled Parallels Tools during a previous build reinstall, but Parallels Desktop for Mac keeps saying it is still present. I've found no way to remove Parallels Tools for BootCamp automatically and forcing it out also does not work. So I tried reinstalling Parallels Tools for Bootcamp using the manual reinstaller and it also fails to install reporting:

    Error occurred during installation of Parallels Tools for Bootcamp: Error Code 1 - Contact Parallels technical support for more assistance.

    Nonetheless, does the Safe Mode uninstall resolve this problem or did you have similar issues and then went with this plan? I'm hunting in the dark and do not have my clients system to test your suggestions, so I'd appreciate any feedback before I schedule some time to go back and test the fix.

    Also, does anyone know if Parallels has a Windows Uninstaller Tool to remove previous versions of Parallels Tools for Bootcamp. My client can't be the only one having this problem???

    Thanks, Brian...
  14. finkeltron


    Works for me too

    Worked for me as well

Share This Page