Can't register at site as a new user

Discussion in 'Windows Virtual Machine' started by jpoprock, Aug 20, 2007.

  1. jpoprock

    jpoprock Bit poster

    I'm trying to register myself for the first time on the Parallels site, and for some reason, it says that my phone number is invalid?? How can that be? I think I know my phone number! I've tried everything I know of. You have to put a +1 then (XXX) XXX-XXXX no extension. So, I'm stumped. I can't proceed either.

  2. ecb

    ecb Bit poster

    I've run into the same issue - tried with four different browsers on both Macs and PC and it just won't accept my phone number even tho it's entered *exactly* as specified.

    I'm trying to submit a support request for a nasty kernel panic and can't get anywhere. Mail to simply gets me a reply that says submit the request via the same website that won't let me register. grrrrrr.
  3. Intersecting

    Intersecting Parallels Team

    Hello guys. We've just fixed the problem.

Share This Page