can't run fedora 7

Discussion in 'Linux Virtual Machine' started by macgeek21, Jul 15, 2007.

  1. macgeek21

    macgeek21 Junior Member

    i have installed fedora 7 using parallels 3.0. the install process went fine but for some reason when i try to use linux it seems like the vm is rebooting or something because the window keeps resizing it self from big to small and then i get a message saying that the server crashed and that its probably an error and it will wait before trying again. it does this but the same problem happens again. i have had problems with fedora before but that was because parallels didn't have the right drivers for linux. im thinking maybe its the same problem? i cannot find out because i am unable to boot into linux.
  2. RobW

    RobW Junior Member

    With your Fedora Core 7 machine stopped, edit the machine so that it has 256MB memory, and boots CD/DVD, Hard Drive, Floppy. Either point to the Rescue CD ISO _OR_ insert your Rescue CD.

    Boot from the rescue CD, choose the Rescue Option.

    cd /mnt/sysimage/etc/X11

    edit xorg.conf so that it reads as follows (The parser here got rid of my tabs):

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"

    Section "Monitor"
    Identifier "Monitor0"
    ModelName "LCD Panel 1280x800"
    ### Comment all HorizSync and VertSync values to use DCC:
    HorizSync 31.5 - 90.0
    VertRefresh 59.9 - 60.1
    Option "dpms"

    Section "Device"
    Identifier "Videocard0"
    Driver "vesa"

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x800"

    Make sure the xorg.conf file reflects these changes. Stop the FC7 VM, change it so that the machine boots off the hard drive, and you should be good to go.

    Please let me know if this works.

  3. srvp

    srvp Junior Member

    Fedora 7

    I am having the same problem. I run 6 just fine, but I'll try this. I did increase the memory to 512MB, so maybe reinstalling it like you said will work.
  4. demnos

    demnos Bit poster

    I'm getting this same error message.

    I tried editing the xorg.conf file above as suggested but to no avail.

    It's weird, the setup will complete just fine. I can even go through the whole initial setup phase with no problems. After the sound card test screen at the end though, I'll hit finish and then get this blinking screen / X Server error. If I stop and reboot the VM I just get the same thing again.

    Any other suggestions?

  5. Michael Rogers

    Michael Rogers Bit poster


    This worked like a charm -- thanks so much for posting it.

    Michael Rogers
  6. stlcards0

    stlcards0 Bit poster

    Thanks that worked to perfection.

    To the person who could not get it working you will have to use vi or another command line text editor and if you were still unsuccessful then you will have to double check the file that you edited.

    Again thanks.
  7. kwixson

    kwixson Bit poster

    Sorta Worked, Found Better

    This solution sorta worked, but the resulting window was too large for my 15" MacBook Pro. Ultimately it was this solution that worked for me.
  8. Daniel Hinostroza

    Daniel Hinostroza Bit poster

    It worked

    Hi Rob,
    Glad to say it worked (and using 512MB RAM instead of 256!). I did it using a MacBook Intel Duo with Parallels 3.0. Here is how I followed your instructions, yet a little more verbose:

    Before trying the rescue cd I ALT F2 on the "tried six times and the display went dead, want to try again?" in order to get a terminal window. I logged in as root and wrote:
    yum update xorg

    I let the magic happen and wrote:

    Returned to Parallels and changed the ide:0 on the virtual hard drive to ide:1. That way, the rescue cd would boot first. Once in the terminal window I wrote:

    cd /mnt/sysimage/etc/X11
    vi xorg.conf

    Then I sort of fumbled around with vi until I could write the new lines (something to do with ESC and d on the keyboard allowed me to).

    When I had written everything correctly, I ESC'd again in order to save and exit using

    Then I wrote

    and the machine was ready to change the ide:0 from the rescueCD back to ide:1 and restart Fedora 7.

    I thought the resulting desktop was a bit larger than my 13" screen size, but when I selected the Parallels "Full Screen", everything was fine.

    Hope this helps other newbies,
    Last edited: Sep 26, 2007

Share This Page