Choppy Audio/Video in Parallels macOS VM using Presonus audio interface

Discussion in 'Mac OS X Guest OS Discussion' started by warnergt, Feb 4, 2021.

  1. warnergt

    warnergt Bit Poster

    Messages:
    50
    The main symptom: after a period of time (e.g. 0 to 30 minutes) using video or sound apps on the macOS virtual machine in a Mac equipped with a Presonus STUDIO audio interface, the sound (and video, if applicable) becomes choppy and stuttered. Sound and video on the host OS (Big Sur) continue to work fine.

    Background: I use Parallels to create a virtual machine (VM) running Mac OS X Server 10.6.8 (Snow Leopard) on my Mac Pro (2019) with a Presonus audio interface.
    My goal is to use old versions of software which will no longer run on later OS X versions.
    One specific application that I use is iMovie HD 6.0.4. This is where I first encountered the problem with stuttering audio and video. However, this problem is not confined to iMovie.
    It also occurs when playing back simple videos and even simple audio. For example, I can go into the Snow Leopard System Preferences->Sound->Sound Effects and playing a simple alert sound exhibits the choppy audio.

    Hardware:
    Mac Pro (2019), 16-core, 160 GB, AMD Radeon Pro 580X 8 GB
    PreSonus STUDIO 26c audio interface

    Software:
    macOS Big Sur all versions up to 11.2. However, problem first appeared before installing Big Sur. That is, I saw the problem with Catalina macOS 10.15.x.
    PreSonus UniversalControl 3.4.0.61835
    Parallels Desktop 16 for Mac Version 16.1.2. However, problem first appeared in version released in late 2020 -- perhaps version 16.1.0.
    Mac OS X Server 10.6.8 (Snow Leopard)

    Parallels VM configuration:
    4 processors (tried 2 processors with no luck)
    8192 MB memory (tried other amounts with no luck)
    Hypervisor: Apple/Parallels -- no difference, adaptive on/off -- no difference. Note, however, that the Apple hypervisor appeared to help in earlier stages (i.e. earlier versions of Parallels) but it no longer helps.
    Graphics: 1 GB. Tried other sizes but they did not help.
    Sound->Sound Output: "Default" or "Studio 26c" exhibit the problem. (Big Sur Sound Output is set to "Studio 26c.")
    "Default" exhibits the problem. (Big Sur Sound Output is set to "External Headphones.")
    *** (Some Possible Big Clues here) **
    If I set the Parallels VM Sound Output to External Headphones and use amplified speakers, it works fine (but this is not an acceptable solution). (Big Sur Sound Output set to "Studio 26c.")

    It appears that the Parallels VM has an incompatibility with the Presonus STUDIO audio drivers and/or Apple audio drivers.
     
  2. warnergt

    warnergt Bit Poster

    Messages:
    50
    I updated to Parallels 16.1.3 from 16.1.2 yesterday. This problem still exists.
     
  3. LeeR8

    LeeR8 Bit Poster

    Messages:
    2
    I don't think your PreSonus System is the problem. I'm here because I'm also getting choppy audio on a Mojave VM running on a nearly maxxed out 2019 iMac running Big Sur.
     
  4. warnergt

    warnergt Bit Poster

    Messages:
    50
    The problem was Big Sur. It was fixed in macOS Big Sur update 11.3.
     
  5. LeeR8

    LeeR8 Bit Poster

    Messages:
    2
    Well, that's interesting. Just playing with alert sounds now. Previous to 11.3 the repeated playing of an alert would result in horrible distortion each time. Now with 11.3 the first time may still be distorted but subsequent plays of that alert are clear. Switching between sounds shows that the first 'utterance' is distorted but subsequently it's clean. Returning to a sound is also distorted on the first rendition. Short sounds like 'tink' sound clean all the time (maybe my hearing is failing me here) but longer sounds like 'submarine' are more susceptible.
    If I try to play music through iTunes then the first few bars are distorted but then it's quite clear. My settings are built-in sound in both OSes - I have no idea of what use the Parallels Access Sound option is. When I select it nothing happens and no sound emanates.
    So it's better (or is that, more good?), but not perfect.
     

Share This Page