Chrome OS Incorrect Time Issue

Discussion in 'Other Guest OS Types Discussion' started by davidlones365, Apr 8, 2012.

  1. davidlones365

    davidlones365

    Messages:
    5
    Chrome OS support is being neglected!!!

    As far as I can remember, Chrome OS running in Parallels has always displayed the incorrect time since its launch/release. It seems to default to "Marshal Islands Time" when the time is intended to sync with the host OS. When the option to sync the time with the host is disabled in Parallels, the time appears to progress at roughly (if not randomly) 1 hour per minute: 10:34... 11:34... 12:34... 1:34... 2:34... 3:34... 4:35... 5:35.......9:35... 10:36... ?????

    I use Chrome OS often as a make-shift kiosk/web-only guest user and as I've said, this has always been an issue. ...at this point, any help would be appreciated.
    If this has been addressed before, I haven't found anything helpful in my searches, neither here nor on Googles forums.


    Update:
    Today, the "AdBlock" extension notified me that quote "I should update Chrome soon or AdBlock will stop working". I've just realized that the version of Chromium OS I have installed in Parallels hasn't updated at all since Chromium OS version 14!! Wikipedia tells me that the most recent "stable" version is 17!!! I've checked for updates repeatedly and the OS assures me that it is "up to date"!?!? I've even re-downloaded the entire thing twice from Parallels' "New Virtual Machine" page and I always get version 14!!!!!!
    This... on top of the time sync issue??? What gives?????


    Update:
    Now, when time sync is disabled, the time seems to progress at exactly 1 hour and 1 minute per minute: 10:40... 11:41... 12:42... 1:43... 2:44...... and no matter what time zone I select in Chrome itself, it always switches back to "Marshal Island Time" shortly after booting. I've tried manually updating Parallels Tools from the "Virtual Machine" menu at the host, but I'm given the message: "Unable to install Parallels Tools. Parallels Tools can be installed if at least one CD/DVD drive is connected to the virtual machine. Add a CD/DVD drive to the virtual machine configuration and try again." ...but I've tried that and it seems Chrome doesn't even agknowledge that anything has been connected!!!
     
    Last edited: Apr 11, 2012
  2. tonza

    tonza Bit Poster

    Messages:
    18
    Chrome OS is being neglected? I agree!

    Yes, I too would like to see Parallels periodically update Chromium OS for Parallels Desktop. I think that, for quick dashes to the Google Store or any of the applications run from there (although, the same thing can be done for Chrome on Mac), running Chromium OS in a different (cut-down) user account on your Mac would be a very useful technique to running "Chrome-ware".

    However, there is a hack to getting your virtual machine running on the correct time zone. Just bring up the Google Terminal by typing Control-Option-T, then entering the command shell:

    crosh> shell
    chronos@localhost / $ _

    then enter superuser by using sudo (the password is the same as the username). Then, do this:

    localhost / # cd /var/lib/timezone
    localhost timezone # mv localime localtime.bak
    localhost timezone # ln -s /usr/share/zoneinfo/<yourtimezonefile> localtime

    to define what the default timezone setting of the first login shell is, and everything else should inherit this setting, despite what the System Settings indicate.

    Also, you'll want to synchronise the virtual machine's clock with the Mac OS X clock in the Advanced settings of the virtual machine itself. After you have done the change above, log out and reboot the virtual machine.

    Cheers!

    —tonza
     
    Last edited: Apr 15, 2012
  3. davidlones365

    davidlones365

    Messages:
    5
    Sorry, I have next to no experience involving linux terminal commands...
    I live in Texas under the Central time zone. What time zone file do I type for this?
     
  4. tonza

    tonza Bit Poster

    Messages:
    18
    Hi! Sorry, I tried to save myself re-typing the commands, and made the assumption that you knew how to navigate Linux.

    OK, so instead, here is the line-by-line on how to configure Chromium OS' timezone.

    1. Boot into Chromium OS.

    2. Type Control-Option-T to get to the Chromium Shell (crosh). A new window should appear to replace the browser (you can Option-Tab to switch between windows).

    3. Enter the command "shell" and press Return. A bash Shell prompt should appear:

    chronos@localhost > / $

    4. Enter the superuser (root) account:

    chronos@localhost > / $ sudo bash
    Password: enter chronos account password here; it is "chronos" by default

    5. Type the following commands to reconfigure your timezone:

    localhost user # cd /var/lib/timezone
    localhost timezone # ls -l /usr/share/zoneinfo/US
    a list of timezone files for the United States should be listed here; check that Central is listed

    6. If the Central timezone file is there, perform:
    localhost timezone # mv localtime localtime.bak
    localhost timezone # ln -s /usr/share/zoneinfo/US/Central localtime

    7. Log out.
    localhost timezone # exit
    chronos@localhost > / $ exit
    crosh> exit

    You can then select "Restart" from the "Virtual Machine" menu in Parallels to reboot the virtual machine.

    —tonza
     
  5. Fender

    Fender

    Messages:
    2
    Tonza, I could kiss you... but I won't!
    Worked perfectly!

    Thank you!
     
  6. SakibS

    SakibS Kilo Poster

    Messages:
    104
    Thanks this work well.. 1.gif
     

Share This Page