Coherence denied: Mouse issue

Discussion in 'Windows Guest OS Discussion' started by Peter Lewis, Apr 24, 2009.

  1. Peter Lewis

    Peter Lewis

    Messages:
    10
    "Unable to switch to the Coherence mode.
    The Parallels mouse sync service is not started. Reinstall Parallels Tools and try again."

    That's my bad news from Parallels 4. I'm running WinXP Pro on a brand new iMac.

    Here's what I tried without success:

    - Reinstalled Parallels Tools on multiple occasions
    - Checked Device Manager on Windows side and found no yellow mark next to mouse; tried updating driver anyway and Windows reported installed driver was the best available.
    - Checked Virtual Machine configuration, then Features, then Services and found the box in front of "automatically capture and release the mouse pointer" checked but grayed out. It is active when VM is in suspend mode.

    Coherence was working fine until I installed software for my Intellimouse Explorer 3.0. After the problem materialized I went to Control Panel add/remove to uninstall the program and rebooted. That didn't fix it.

    Any help? I'm bummed.
     
  2. Paul Bernardo

    Paul Bernardo

    Messages:
    6
    I get the same error with Parallels 4.0 when I try to switch to coherence mode. "Unable to switch to the Coherence Mode. The Parallels mouse synchronization service is not started. Reinstall Parallels Tools and try again." Reinstalling Parallels Tools however doesn't do anything--the problem persists.
     
  3. Peter Lewis

    Peter Lewis

    Messages:
    10
    I finally got this fixed, at least for now. Here's the advice PD tech support sent that worked for me:

    1. In Windows, click on 'Start Menu'.
    2. Select 'Control Panel'. (Sometimes control panel would be under settings.)
    3. In the control panel window open 'Add/Remove Programs'. (Chose classical view to see add/remove programs.)
    4. After the programs have populated chose 'Parallel tools'.
    5. Select 'Remove/Uninstall'.
    6. After removing the parallel tools restart the virtual machine.
    7. Once windows as completed booting.
    8. Cancel out any installations.
    9. Click on 'Start Menu'.
    10. Follow this path My computer > c drive > program files > parallels > parallel tools Delete this parallel tools folder to recycle bin.
    11. Turn off Windows.
    12.Quit Parallel Desktop application.
    13. Download the dmg file from this link

    http://www.parallels.com/download/desktop/

    save it in known location.

    14. Run the installer and uninstall Parallel Desktop along with Application settings (application settings option will be displayed while uninstalling Parallel Desktop.)

    15. Restart Mac.
    16. Run the dmg file which was downloaded fresh.
    17. Install Parallel Desktop.
    18. Launch Parallel Desktop.
    19. Start Windows.
    20. Select 'Virtual Machine' from Mac menu bar at the top.
    21. Select 'Install parallel tools'.
    22. After the installation of parallel tools restart windows.
     
  4. Brian Lowe

    Brian Lowe

    Messages:
    4
    I am having the same issue so I started the steps outlined above, I was able to get through step 6 and not I am getting fatal errors on the reboot. I sent the fatal error report with ID #183143.

    Now what?
     
  5. Peter Lewis

    Peter Lewis

    Messages:
    10
    Hmmm. No sure what that ID # is - a trouble ticket?
    Anyway, I'd be curious to see what response you get. In my admittedly limited reading of/participation in the forums, my sense is it's the exception when the same "solution" applies to more than one user!
     
  6. Paul Bernardo

    Paul Bernardo

    Messages:
    6
    Thanks, Peter. After reinstalling Parallels Desktop and Parallels Tools using the dmg, everything is working fine.
     
  7. Brian Lowe

    Brian Lowe

    Messages:
    4
    I wish I was that lucky

    I was able to uninstall Parallels tools then on reboot after uninstalling this happened. I have opened a trouble ticket with PTN and have not heard a word from them on this. Thanks for any help anyone can provide.

    [​IMG]
     
  8. Brian Lowe

    Brian Lowe

    Messages:
    4
    I wish I was that lucky

    I had the same issue now on reboot I get a blue screen.
     
  9. lenkel

    lenkel

    Messages:
    1
    Still Denied Coherence...Mouse Capture won't auto-release

    An update to Parallels 4 build 3844 is needed. Coherence mode, an advertised capability, will not engage. The mouse will not auto-release as in earlier versions of Parallels.

    I have tried removing the Parallels tools from Windows XP, rebooted and (after restart and cancellation of Windows new hardware install wizards) shut down then reinstalled from:

    ParallelsDesktop-parallels-en_US-4.0.3844.408728

    Still no Coherence mode whether the "Configure:Services:Automatically capture and release the mouse pointer" was set or not.

    Also, the mouse gets stuck in Windows and won't release until hot-keys are pressed which repositions the mouse again causing Parallels 4 to not be as good as its own version 3 or the competition in this regard.
     
  10. SarahF

    SarahF

    Messages:
    8
    I have exactly the same problem - I saw the comprehensive solution posted in post #3 but that looks like I have to completely reinstall windows - is that the case? I have heaps of stuff in Windows loaded up that I don't want to lose and I worry about the blue screen that others are getting. SURELY there is an easier way to solve this problem? I too got it after installing an external mouse - it was working FINE before that.
     
  11. NickH

    NickH

    Messages:
    1
    Another Solution to Mouse Synchronization

    Initial problems were unable to install Tools Properly.
    Followed above post to uninstall, delete, reinstall.
    Tools worked except for mouse.

    Looked in the mouse control panel under windows in Driver.
    I had too parallels mice drivers installed, 1 working 1 with an error.

    I uninstalled the mouse driver with the error and shutdown the VM.

    In the Parallels preferences restored the default settings.

    Started the VM and the mouse was working!
     
  12. Tom George

    Tom George

    Messages:
    5
    Upgrade from 3 to 4, installed the Parallels Tools, etc., but also had the message about the setting "Automatically capture and release the mouse pointer". Which was set.

    Went into Control Panel/Mouse/Hardware/Properties... saw that one mouse was not actually working (although both had the same driver date). I deleted the non-working driver, then restarted my Parallels Windows XP instance... and voila, it works.
     
  13. kaufman

    kaufman

    Messages:
    58
    Fix for mouse issue

    Hi. I have managed to fix this (thanks to the hints in this thread), and my method is much simpler then the ones show here.

    The problem is that the mouse driver is not automatically being updated to the one from Parallels. If you go to:

    Start->Control Panel->System->Hardware->Device Manager->Mice and Other Pointing Devices->Expand the Selection and select the mouse - Probably PS/2 mouse)->Double Click to Open Properties->Update Driver->Install from a specific location->Don't Search. I will select which Driver to Install->Turn on Show compatible Hardware

    and then Select "Parallels Mouse Synchronization Device"

    and then confirm and reboot.

    All will work as desired.

    Hope this helps.


    Michael
     
  14. DaneCC

    DaneCC

    Messages:
    14
    Great tip on Mouse Synchronization.

    Thanks
     
  15. Chris Williams

    Chris Williams Bit Poster

    Messages:
    7
    Michael, you are wonderful. This worked perfectly and helped a great deal.
     
  16. BiranitG

    BiranitG

    Messages:
    1
    Thank you SO much. It helped!
     
  17. iam23skidoo

    iam23skidoo

    Messages:
    1
    Good catch Michael! Works great.
     
  18. Eric Hamburg

    Eric Hamburg

    Messages:
    16
    Thanks Michael

    Your instructions worked.
     
  19. RubelR

    RubelR

    Messages:
    1
    ...AND it still works, Michael! I needed to begin using Coherence for a faster 3D modeling workflow, especially given PC-only 3rd-party tools that make life easier. It was beginning to be a hassle doing all the work in Parallels Windows mode. Switching to Coherence was something I had tried with version 3 to no avail. When I tried again with version 6, I got the "mouse sync" error. I had pretty much given up. Then I thought, why not check the Forum. Bingo! Switching the PS2 mouse driver did the trick! Why Parallels hasn't fixed this in code yet is beyond me, but I don't care as long as it works - thanks to you, here today some years down the road!

    Bravo - may the year be safe and profitable for you!

    Regards,
    Rube
     
  20. DominikHS

    DominikHS

    Messages:
    1
    Thanks. I had the same problem with Parallels 7.0 and Win XP as the guest system.

    Michael solution worked like a charm.

    Thanks a lot.
    Dominik

     

Share This Page