Coherence Now Bringing to Front after Update

Discussion in 'Windows Guest OS Discussion' started by Claggett, Jan 14, 2010.

  1. Claggett

    Claggett

    Messages:
    4
    I updated to Build 5.0.9308 yesterday, and immediately noticed a new annoying issue after the process. Now, in coherence mode (which I like very much) The Windows windows, constantly jump in front of everything else I have open, every few seconds. It makes it nearly impossible to get any work done in the native OS, and is extremely annoying. I've confirmed this is happening to a classmate after the update, on a nearly identical set-up (Snow Leopard and Windows 7 running on MacBook Pro.)

    Any ideas for a fix? I hate to give up coherence. Is there a way to downgrade from the recent upgrade?
     
  2. jrswinehart

    jrswinehart

    Messages:
    2
    I'm having the same issue. I first saw the problem with Build 5.0.9308. The latest build, 5.0.9310, doesn't fix it. I'm running Snow Leopard on a MacPro with Win7-x64 as the guest.
     
  3. Claggett

    Claggett

    Messages:
    4
    Well, that makes three of us with nearly identical builds, all suffering from the same problem. It really makes what was a great solution, almost unusable because of an update. Haven't seen a lot of traction or even acknowledgment of this problem - any suggestion on how to escalate it?
     
  4. >>> Message has been deleted by the user <<<
     
  5. GMM

    GMM

    Messages:
    1
    Coherence and Crystal problems

    Parallels 5.0.9344, Win 7, on an iMac

    I'm having the same problem with both Coherence and Crystal: if I'm working in another Mac application, every 30 seconds or so Parallels and the Win application(s) insist on coming forward and taking focus.

    This effectively destroys the value of these modes, which used to be great when they worked properly.

    I've also had a variant of the Windows 7 Taskbar issue mentioned in another thread on this forum: in my case with the taskbar set on Autohide, when I changed back to Window mode the taskbar disappeared completely, and could only be restored by re-starting Windows. On at least one occasion I found that it had moved from the right side of the screen to the top. My workaround for this has been to turn off Autohide - fortunately with an iMac I have plenty of screen real estate.

    Something else I've noticed in the last month or so, which I don't think used to happen: when I move into Crystal or Coherence Windows gives me a warning that a program (presumably Parallels Tools) has made it change to the Basic display settings. This is not obviously a problem, though.

    In the process of typing this, I've had to grab the mouse to bring the focus back to Firefox (Mac) at least half a dozen times. Very irritating.
     
  6. smithdm3

    smithdm3

    Messages:
    2
    This has started happening to me...

    in both Coherence and Crystal view modes. Parallels 5 / Windows 7 jumps back to be in focus every minute or so. It goes back to the last used Windows 7 application. Very bizarre and extremely irritating.
     
  7. J.R. MacReady

    J.R. MacReady Bit Poster

    Messages:
    12
    Not sure if we've got the same issue.

    My issue is similar to the one discussed here: http://forum.parallels.com/printthread.php?t=104426

    I run Windows 7 32bit on Parallels version 6.0.11828 on my Snow Leopard MBP 13". When in coherence mode, the Windows start bar attempts to "surface" every 60 secs precisely, but only when a windows app or even windows explorer is "maximized". There is a half second jitter where the bottom or top of the screen flickers and then it happens again 60 seconds later. If in regular "window mode" I set the windows task bar to display at the top of the screen, and then switch back to coherence mode the flicker occurs at the top and bottom of the app's maximized window. If I set the task bar to display at the bottom of the screen, then the flicker only occurs at the bottom of the maximized app window. So I decided to set the Windows task bar to display on the left side of the screen and then went back into coherence mode. The flickering was gone.

    Not sure what caused the problem. But the flickering (may not be the same as the "focus" issue) is no longer visible.
     
  8. KristofferN

    KristofferN

    Messages:
    1
    Serious problem with coherence mode forcing windows to the front in Parallels 6

    We have four users in a professional setting on various generations of MacBook Pros (both 13' and 15') running OS/X 10.6.5 and Parallels Desktop Build 6.0.11992 with Windows 7 Home Premium 64-bit as the guest operating system running off a boot camp partition and Office 2007 Standard as the most important application.

    We're all running in Coherence-mode. Crystal mode is disabled and the "Keep on top of other windows" option in the VM configuration is unchecked.

    We all experience the same problem as described by previous posters with applications in the guest operating system being pushed to the front and gaining autofocus while we're in the middle of doing other things in the host operation system's applications. A concrete example: Using Safari or Firefox for OS/X with Microsoft Word 2007 for Windows running in the VM. All of a sudden the window with Word running gets pushed to the front and gains autofocus. This is seriously disrupting our work.

    Two of us have upgraded from Parallels 5 and we did not experience the problem with the latest build of that version.

    I'd like to hear if anyone else out there experiences the same problem and if you have found a way to disable it. I think we've been around all the options in the VM configuration mode in vain. It would also be very, very useful for us to know if the Parallels team can reproduce the issue.
     
    Last edited: Dec 30, 2010
  9. ShortK

    ShortK

    Messages:
    4
    Having similar issue: Focus jumps every 30 sec

    I have noticed since I upgraded to latest version of Parallel 5 (running Windows 7 on my iMac 10.6) that when running quicken, there is some type of interrupt or refocus of the cursor every 30 sec or so that is extremely annoying and makes using quicken almost impossible. If I am typing in an amount in the check register and this "glitch" happens, my typing is now happening in another field within the check register...obviously a problem! From this thread, it appears there is a systemic problem. Hopefully, this can get figured out.
     
  10. ShortK

    ShortK

    Messages:
    4
    A fix for this issue

    I received the following from Parallels Support and this has fixed this problem for me. Note that in step #6 the choice for me was 'options -> services' and not 'options -> advanced'. Good luck!

    Hello Short,

    Thank you for contacting Parallels Technical Support.

    As I understand that you are experiencing issues while using the Quicken application as the cursor is refocusing every time.

    I am sorry for the inconvenience caused.

    Please follow the below steps:

    1. Download and install the latest Build for the Parallels Desktop 5.0 i.e. 9376 using the below link.

    http://download.parallels.com/deskt...lsDesktop-parallels-en_US-5.0.9376.599993.dmg

    2. Launch Parallels Desktop and start the Virtual Machine.

    3. Install the Parallels Tools by navigating to Virtual Machine-> Install Parallels Tools.

    4. Restart the Windows Virtual Machine.

    5. Now, click on Virtual Machine-> Configure.

    6. Go to Options-> Advanced.

    7. Under Time disable "Synchronization with Mac".

    8. Click on OK.

    This should resolve the issue.

    Please let us know the status of the issue.

    Awaiting your response.
     
  11. aaronlyon

    aaronlyon Bit Poster

    Messages:
    10
    That worked! Thanks!
     

Share This Page