Command + Q

Discussion in 'Parallels Desktop for Mac' started by looter, Feb 16, 2007.

  1. looter

    looter

    Messages:
    24
    Is there a way to DISABLE 'command + Q' from quitting the Parallels Desktop for Mac application (3170 RC3)?

    I can't stop accidentally typing 'command + Q' to try to quit Windows applications. This kills the QuickBooks file which I am accessing over the local network.

    I had similar issues with VirtualPC and used an inelegant Menu Master from Unsanity to remove the option from the menu on my G5 iMac. I'd prefer not to have to install this on my 15" MacBook Pro Core 2 Duo 2.33Ghz.

    Also, any fix/work-around yet for 'command+tab' to switch from Parallels to Mac applications?

    Thanks
     
  2. neosublime

    neosublime

    Messages:
    62
    I found the best way to do this is to disable the parallels dock icon:

    open terminal.app and type "sudo su -"
    then type "vi /Applications/Parallels/Parallels\ Desktop.app/Contents/Info.plist"
    Add this to the top of the info.plist file:

    <key>NSUIElement</key>
    <string>1</string>
    save>exit, and reboot.

    The next time you launce parallels, you can completely remove the icon from the dock while it's running.

    Then qhen you +Tab to your apps, and hit +Q to quit... Parallels will keep running but the windows apps will quit.

    Or you could set paralles prefs to suspend the vm if you accidently hit +Q

    :)
     
  3. David Graham

    David Graham

    Messages:
    16
    See Keyboard & Mouse Prefs

    Go to System Preferences > Keyboard & Mouse > Keyboard Shortcuts and add a custom menu item shortcut for Parallels.

    I really wish Parallels would remove all of the menu shortcuts when a VM is active, or at least allow us to more easily customize them.

    - Dave
     
  4. Lohmeyer

    Lohmeyer

    Messages:
    15
    The solution to your first problem (with Command-Q) is to enable the option in Parallels preferences->General->Perform Action when Virtual Machine is running... For "On application quite" set to "Ask me what to do". Then when you press Command-Q, a dialog will pop up and ask if you want to quit, suspend, or cancel. Problem solved.

    To get Command-Tab to switch you from a Windows VM to a Mac app, you must disbale "enable access for assistive devices" in "Universal Access" (from System Preferences under Mac OS). This is a bug with Parallels. As some programs require this feature to be enabled to work, having to disable it is at best a work around, not a solution, but for the time being, it will solve your trouble with Command-Tab.

    Rather than disableling the Comand-<key> combos in Parallels, instead, Parallels needs to make all Command-<key> combos pass through to Mac OS and not use this key for Windows (but provide the option to enable or disable the Command key as the user desires). Right now Command is acting as the "Windows" key which causes all sorts of issues like having the Windows Start menu pop up. Just as there are good reasons to prevent Command-Q from shutting things down, there are similarly good (better in my opinion) reasons to make sure Command-Tab or other Command-<key> combos gets you out of Windows and switches to or executes a Mac keyboard function.

    I think if Parallels did two simple options, almost all Command key and keyboard focus issues would be resolved:

    Option 1 - Enable Command as Mac "Command" key or "Windows" key
    One or the other, not a halfway state like it is now. And, this must work regardless of the setting of "Enable access for assistive devices".

    If set as Mac "Command" key, anytime Command is pressed, the VM should be defocused so that all keyboard _AND_ mouse funcitons work on Mac OS and are not passed to Windows. Pressing Command would also bring up the Parallels Mac OS menu at the top of the screen (in full screen mode) or cause keyboard/mouse focus to divert to Mac OS (in Windows/Coherance mode). This is exactly how Virtual PC works - simple and predicatable.

    If set as the "Windows" key, then the Command key would work as the "Windows" key on a standard PC keyboard and would not be passed to Mac OS. Pressing the Command key would bring up the Start menu like on a normal PC. The only way to get keyboard/mouse focus back to Mac OS would be to press the CTRL-OPTION keys (or what ever keys you have configured in Parallels Preferences->Keyboard->Release Input.

    Option 2 - Allow swapping Command and Option/Alt keys
    When enabled, this would swap the functions of the Command(Windows) and Option(Alt) keys so they worked as normally found on a PC keyboard.


    Of course, a fully configurable (no limitations) keyboard mapping preference item would be nice, but the above two options are a simple way to make things work with minimal confusion.
     
  5. looter

    looter

    Messages:
    24
    Lohmeyer,

    Thanks for the detailed and very informative response. I've started using both of your work-arounds and they are doing the trick. Hopefully fixes will be implemented in future versions.

    Thanks again for your and the other's responses. Very helpful.
     

Share This Page