Compressed my WinXP, now it complains about lack of diskspace!

Discussion in 'Parallels Desktop for Mac' started by luomat, Jun 18, 2006.

  1. luomat

    luomat Kilo Poster

    I ran the Compressor on my installation of WinXP, and now it left me with about 3mb worth of space, which means that a) Windows complains constantly about the low disk space and b) I can't install anything else.

    I have a "dynamic" hard drive, but whenever the installer starts it checks for available space and quits.

    What do I do?
  2. jimh


    What is the exact error message? I have seen some confusion in the way that installation memory/disk space is reported.

    Also, what is our memory allocation (both parts) set to?
  3. mcg


    I have had the same problem. Parallels seems to create some temporary files that it fails to delete. I just compacted my drive this time, though, and didn't have the problem. Actually, it did tell me I was low on disk space but when I restarted I had my free space back.

    Look in your various temporary directories (C:\Temp,C:\Windows\Temp,etc.) for temporary files that are very large.
  4. luomat

    luomat Kilo Poster

    space report

    Words to the effect of "Windows is criticallly low on disk space, would you like to run disk clean up?"

    2gb total, 512mb of that is set for WinXP

    I have noticed that it has grown from 2mb to 8mb to 10mb, but that does me little good if I need to install something 200mb (i.e. office 2003)
  5. jimh


    That is definitely a clear error message.

    I am taking a stab in the dark here, when ever Windows is about to install something it does check disk space. As per the other reply, you might want to do the clean up in case you have a bunch of left overs ; might be enough.

    Also, as per the same reply, try the clean up and do a restart and see if it helps.
  6. riccto


    My HD image will not expand too.

    I also compressed my WinXP HD image after the commercial release of Parallels Desktop for Mac. Now XP reports a lack of HD space. I tried a variety of different options with the Image Tool in the HD image, as well as copying the image to a different (external) disk. None of these worked, I probably could rebuild/reinstall the disk, but for a variety of reasons would prefer not to have to do this.

    Any assistance would be appreciated, I have had no reply from the parallels Tech support email.

    Richard T
  7. jimh


    Have you tried to convert your disk to a fixed size to see if that would get you by until the Parallel's support team can get to you (suspect that they are swamped right now)?
  8. luomat

    luomat Kilo Poster

    Exact error message

    Ok, the exact error message is:

    Low disk space

    You are running very low on disk space on Local Disk (C:).
    To free space on this drive by deleting old or unnecessary files, click here

    see it here:

    Windows reports itself to have a 7.79GB drive but only 1.32MB currently free.

    c:\windows is only about 1.1gb

    c:\program files\ is less than that.

    I didnt see any files in any of the temp directories.

    Does anyone know of a free Windows program which will do what OmniDiskSweeper does (i.e. show you graphically what is taking up space on your HD)? I tried mounting C:\ as a Windows share to my Mac but I think Windows refuses to show some folders that way (one of the many lovely things about how they "protect" users from themselves)

    I am running the disk clean up although it didn't say that it found much to clean up.

    If that doesn't work I may change back to a fixed sized disk.
  9. mikeshappell


    Look in the root for a number of large files used to compact the disk. I have a had a few times that the compaction process left these files in the root. Remove the files and you should working again.

  10. luomat

    luomat Kilo Poster

    I ran "Disk Cleanup" and also checked the box (in Windows) which said "Compress drive to save disk space" and UNchecked the box which said "Allow indexing service for index this disk for fast file searching"

    It ran for about 20 minutes and left me with 5.92GB free of 7.79GB total.

    Not a great solution (Windows runs slower when things are compressed, IIRC) but at least it gave me some breathing room. Now I've gotten anotheir message:

    "Windows - Virtual Memory Minimum too low
    Your system is low on virtual memory. Windows is increasing the size of your virtual memory paging file. During this process, memory requests for some applications emay be denied. For more information, see Help."

    By guess is that VM was turned down/off when I had such low diskspace, and now it was going to re-expand.

    At least I hope that's why!
  11. luomat

    luomat Kilo Poster

  12. riccto


    A Fix!!

    I just had a look through my disk and found the following files in

    C:\Documents and Settings\myloginname\


    All those files are >2GB and deleting them has fixed my problem!!! :)

    I think that Parallels Compressor must have "Forgotten" to erase them as it 'compressed' my disk image!

    Problem Solved, Parallels is running at full speed again.

    Richard T
  13. mathboy3


    Are you guys seeing any loss in speed by using Compressor compared to not using it?
  14. jimh


    I haven't seen any loss in speed since I converted to an expandable disk image nor after I used Compressor it.

    However, if you have the large files that the others found and your available disk space is greatly reduced, you could have thrashing going on in the disk usage for virtual memory. You might want to check for large files the others found and clean them out to see if that helps.
  15. celendis


    I use an expanding image for my primary drive, then I created a small(ish) fixed hard drive image and had windows use that drive for its paging file. It seems to work well, since it doesn't have to deal with the expanding drive for the page file.
  16. Jerry

    Jerry Bit Poster


    Celendis, would you mind explaining how you went about telling Windows to use another drive for its paging file? Thanks!
  17. cutter


    Did you interupt compressing process somehow? Did you see a message notifying you about successfull completion of Compressor run?
  18. ocaptain


    Had the same problem...

    I'm running Build 1848 for the Intel Mac and had the same thing happen: I compressed down to a 3GB physical file but XP reported an 8GB drive with zero space.

    On the root of C were two hidden files about 2GB each... deleted those without a problem.

    Parallels staff... fix it! :)

  19. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Thanks for reporting - we will try to reproduce this situation.
  20. chrisk


    happened to me too, with the DAT files, after a compression.

Share This Page