Connecting to an SQL database

Discussion in 'Windows Guest OS Discussion' started by Edgar Furse, Oct 6, 2008.

  1. Edgar Furse

    Edgar Furse

    Messages:
    6
    I did a pretty thorough search on the forums for this topic and it I cant seem to find the answer.It seems like most posts are for concerns a little more complicated than my situation.

    I am currently running SQLExpress 2005 sever on our network and I need to connect to it for our scheduling program. The PCs on the same network found the broadcast signal just fine but the parallels machines can not seem to connect.

    At this point I get to the Admin tools in XP, Data Sources (ODBC), I input the proper string and password that I use on PCs and it doesnt connect.


    I would appreciate any help at this time. Also, please let me know if there is any other information I should supply.

    Setup Specs -
    Parallels Desktop for Mac 3.x
    Build number: 5584
    Host OS: Mac OS X 10.5.x Leopard
    Guest OS/Remote OS: Windows XP Professional
    Type of computer: iMac
    Computer RAM: 2 - 4GB

    I have attached all the screen shots of the steps I have gone through.
     

    Attached Files:

  2. ReneS

    ReneS

    Messages:
    22
    Hi,

    Must be something with the syntax you are using to connect to sql server. Better try sql resources on the web, because i think it is a settings problem and not a parallels problem per se. I connect to sql server 2005 all the time (since PD 17.. or something) and never encountered a problem.

    Sorry i can't help you more, maybe someone else can....

    Rene
     
  3. John@Parallels

    John@Parallels

    Messages:
    6,343
    Try to use Bridged Ethernet for VM
     
  4. Edgar Furse

    Edgar Furse

    Messages:
    6
    Syntax

    Usually Syntax is the case, but Ive verified it several times. The odd thing is that the server doesn't show up in the drop down menu, unlike the PCs on the same network. I had hoped that by simply typing the same location it would find it.

    I will look in to and search for the Bridged Ethernet solution. Would you be able to give me details.

    Thanks for your help so far guys.
     
  5. Edgar Furse

    Edgar Furse

    Messages:
    6
    IP ping

    Just to let you know. I did a quick test to see if I could ping the IP address of the machine Im trying to reach and I was successful.

    Here is the screen shot.... just in case
     

    Attached Files:

  6. John@Parallels

    John@Parallels

    Messages:
    6,343
    Did you try to use Bridged Networking?
     
  7. Edgar Furse

    Edgar Furse

    Messages:
    6
    Bridged Networking

    What I dont understand is what two connections am I bridging. I apologize for my novice position, but I thought you needed 2 connections to bridge.

    I attached a screenshot of the Network Config screen of the VM XP machine.
     

    Attached Files:

  8. John@Parallels

    John@Parallels

    Messages:
    6,343
    No it is not bridged but firewalled, please disable firewall, and use Bridged Networking
     
  9. Edgar Furse

    Edgar Furse

    Messages:
    6
    I dont understand, that machine doesnt have a firewall on the XP side, we disabled it on the install.

    Again, I am a novice so please be more specific about what you would like me to do.

    I set up the HOST option under the configuration of the VM. Here are the directions I followed.

    1. Launch Parallels Desktop for Mac.
    2. Click the Network Adapter icon in the main configuration window to open its settings.
    3. Make sure that the Enabled and Connect cable at startup options are selected in the Device Status area.
    4. In the Emulation area select the Host-only networking option.
    5. Click OK to close Configuration Editor.
    6. Open Mac OS X System Preferences - Sharing - Internet.
    7. Select your network connection interface in the Share your connection from drop-down list.
    8. Enable the Ethernet Adaptor (en2) (number after en depends on your Mac configuration) in the To computers using list.
    9. Click the Start button. Then confirm Internet Sharing service activation.
    10. Click the Firewall section in the same window, and check the type of service you want to access from your virtual machine. If your Firewall is active you should select the Personal Web Sharing option to be able to browse the Internet web sites at least. Alternatively, you can click the Stop button to disable the Firewall.
    11. Restart your Mac.
    12. Start your virtual machine, and then check its network connections.


    This did not work.

    Is there anything I should be adding to the connection string in order for this to work. (please refer to the previous pictures)

    Is there I way I could contact you via IM to expedite this process. I appreciate all of your help so far.
     
  10. John@Parallels

    John@Parallels

    Messages:
    6,343
    Could you please remove internet sharing and just try Bridged Networking
     
  11. AngelaG2

    AngelaG2

    Messages:
    2
    I have the same problem and tried to use bridged networking, but it is grayed out; thus I cannot choose it. How do I get it to allow use?
     
  12. AngelaG2

    AngelaG2

    Messages:
    2
    No it wasn't. I apologize. I was indeed using bridged networking. It sees the sql server now, but won't let me connect from the parallels machine, but I can from all others. I have no clue why not. Guess I will keep trying. Sorry to have added to this thread.
     

Share This Page