Connecting to VPN while using broadband card, no go in VM

Discussion in 'Installation and Configuration' started by wardjustin@gmail.com, Jun 17, 2008.

  1. So, I've got the broadband card working on the VM side using Host-only Networking and sharing the internet connection.

    Once I connect to the VPN on the Mac side, I can not reach the internet or browse my local network on the VM side. I'm assuming that this won't be possible until the next release.

    Any work around?
     
  2. John@Parallels

    John@Parallels

    Messages:
    6,343
    1. Go to the properties for your VPN connection

    2.
    Click on the Networking tab

    3.
    Double click on TCP/IP

    4.
    Click on the Advanced button

    5.
    Uncheck "Use default gateway on remote computer"
     
  3. Is this the same as Allowing Local LAN access in the Cisco VPN client?
     
  4. John@Parallels

    John@Parallels

    Messages:
    6,343
    Use split tunneling feature
     
  5. I am on a MacBook Pro OSX 10.5.2. Using a ATT GlobeTrotter Connect Version 1.3.0. I have Parallels set up as Host-only Networking with Internet Sharing turned on for the Globetrotter to EN2 in Mac Networking Preferences. I can access the internet from the VM through the Globetrotter connection. When i connect to the VPN on the Mac side i can connect to my private network and internet from the Mac side. I can not do either on the VM side even with split tunneling(allow local lan access) enabled in my VPN client. I don't need to access the private network on the VM side just the internet while connected the VPN on the Mac side. I can live with VPN on both side. Any help is greatly appreciated.
     
  6. John@Parallels

    John@Parallels

    Messages:
    6,343
    Ok, I got it, the problem is that in this case, you need to use shared networking,
    Were you directed exactly to use host only networking? you can switch internet connection to share with Parallels NAT adapter
     
  7. Well, the only thing i could find that allowed the broadband card to be used on the VM side was the Network-only with internet sharing. Supposedly in the next version of Paralles the broadband connection will work with shared networking like Airport and Ethernet does. When the broadband card was install, a second Networking profile was created, i had to add en2 to this profile before i could share it. I do not have the option to add Parallels NAT adapter to this profile.
     
  8. John@Parallels

    John@Parallels

    Messages:
    6,343
    ok, this is the situation, when modem shutdowns our interfaces.
    Well, I think we have workaround here too, add second nic Host-Only, and edit routing table, I cannot check it as I do not have VPN server,
     
  9. I'm not exactly sure what you mean by "add second nic Host-only". Is this a Parallels config or Mac?
     
  10. John@Parallels

    John@Parallels

    Messages:
    6,343
    In Configuration for Vm, add second Network Card, and edit routing table
    http://www.chicagotech.net/routingissuesonvpn.htm
    see section
    Can't access the internal server when remote client establishes VPN
    just part when suggestion is to edit routing table, if you add static entries they will always present, so in any case you will have Internet connection
     
  11. Am i editing the routing table on the Mac side or Windows side? And what do i do with the second nic that i added?
     
  12. John@Parallels

    John@Parallels

    Messages:
    6,343
    On Windows side
     
  13. rbh

    rbh

    Messages:
    53
    This may not help you, but when I travel I use a Vodafone 3G ExpressCard or USB "pebble" for my mobile broadband connectivity.

    All I do before starting the VM to allow it to use the modem as an Internet access device is switch from bridged to shared networking.

    Also - I have purposely created a network location for the 3G that disables Ethernet and Airport (and bluetooth and firewire data networking), allowing only the E800 (card) or E220 (pebble) Huawei modems (and the Parallels NAT "devices").

    Works like a treat - the great thing is I never have to tamper with the VM (Vista) as it always gets to see a RealTek gigabit Ethernet device as its network connection to the outside world.

    This works too for me when I have to connect to a corporate wifi via 802.1x and PEAP/WPA or WPA2.

    R
     
  14. jgk

    jgk

    Messages:
    2
    I have the same problem posted earlier with the Verizon wireless USB broadband device. MAC pro/windows xp VM internet connection works gre at on the office ethernet connection. However, away from the office (most of the time - Real Estate) Mac side no problem with Verizon device but the VM (Windows xp) no go. I have tried all the sugested work arounds and settings. My question is would a switch from Verizon USB wireless device to something else fix the problem? I need the PC for real estate but love the MAC. I really need the wireless connection to work and would happily switch to another provider or a card if I knew it would work. Not as Tech savvy as most of you...
     
  15. rbh

    rbh

    Messages:
    53
    What have you set the network adapter to in the network preference in the VM configuration (these are the Parallels preferences you can adjust before starting the VM)?

    Try setting the adapter to "default adapter" rather than a specific device (like the AirPort or GE port).

    YMMV :)
     
  16. jgk

    jgk

    Messages:
    2
    Thanks RBH..the only way I get a prompt in network preferences for "default adapter" is with bridged ethernet.. I just tried that and still no go. Think I have tried every possible combination of network preferences mentioned in the threads. Maybe I have to update Parallels. I am on build 3170.
     
  17. John@Parallels

    John@Parallels

    Messages:
    6,343
    Try this one
    http://www.parallels.com/en/download/file/en/GA/Parallels-Desktop-3224-Mac-en.dmg

    as for others with Wireless modem, please unplug modem, restart Mac, sitch VM to Host-Only and share internet connection with Host-Only adapter
     
  18. JDLandry@cox.net

    JDLandry@cox.net Bit Poster

    Messages:
    12
    Getting PC Express Card to work on VM Side.

    Here is how I got my Verizon Wireless PC Express Card to work on the VM side:
    1. Go to System Preferences
    2. Under "Sharing", select Internet Sharing and make sure that Internet Sharing is turned on for the PC Express Card for "Parallels Host-Guest".
    3. To utilize the Express Card, I found that I could NOT utilize the Verizon Wireless' VZ Access Manager. I had to launch the connection through the Network System Preference...
    - Under System Preferences - Network, select the PC Express Card and Connect there. Then launch Parallels, and you will have internet access on both the VM and the OSX sides just like with Ethernet.

    I hope this helps.
     

Share This Page