Darwin x86

Discussion in 'Parallels Desktop for Mac' started by aderium, Dec 14, 2006.

  1. aderium

    aderium Bit Poster

    Has anybody attempted to install Darwin x86 ?
    If anybody has been succesfull please share installation guide
  2. willmc


    I'm interested in this as well. I've tried identifying the VM's OS type as both "Other" and "FreeBSD", neither with any success. I've downloaded the Darwin x86 8.0.1 ISO from Apple and pointed the VM's CD drive to that image, and while the boot loader seems to start the mach kernel, after a few seconds the display resolution adjusts to 1024x768 (I think) and just hangs on an empty black screen with no indication of CD drive activity.

    Any ideas? Anyone ever get this working?
  3. dkp


    Parallels provides a list of OS's that are supported. If Darwin x86 is not on that list you should not expect it to install and run. I don't recall seeing it on the list.
  4. catmistake


    its a virtual machine...

    I get the exact same symptoms when I try to install Darwin x86... it appears as though its about to work just fine, you get to the boot options screen... then when you boot, black screen.

    Well... NetBSD isn't on that "supported" list... and it runs like the wind! Also, Plan 9 isn't there (why would it be?) and, as far as I can tell, it works pretty good too. I thought it might have to do with funky mach kernel stuff, but OpenStep works, too, and it uses the mach kernel.

    I'm not saying Parallels should support every OS that runs on x86... but hey... if OpenStep and FreeBSD work, Darwin x86 ought to work too (I'm not interested in running OS X virtualized, btw... but I am very interested in test driving Darwin x86 before I commit to dedicating a real machine to it).

    Come to think of it... Parallels should be ported to run on Darwin x86 (not much work involved there... if it already runs on OS X). How cool would it be to be able to seamlessly migrate an entire office from Windows to Darwin via running Parallels on top of Darwin with a Windows vm? Let me give you a hint... very very cool.

    I'm getting different behavior with some different settings.
    At the boot menu,
    if you use -F (to ignore the boot file) the screen changes to the OS X splash screen (screen with an Apple)!

    if you use -f (for safe boot, don't load drivers), a mad amount of stuff goes across the screen, looks like files being loaded.

    and I got a white screen of death (instead of the black one) when I tried something more complex: boot: platform=X86PC rd=disk1s0 -f "Graphics Mode"="640x480x16"

    Also, here's a thought...

    Since its possible to install Darwin x86 with other emulator software, do that, then convert the vm to Parallels. I haven't tried this, but I will once I give up on a straight install.
    Last edited: Jun 10, 2007
  5. unused_user_name


    Try using type 'other linux' or 'msdos'. Those types seem to have the best support. (they are also the slowest).

    Also try giving the VM < 512MB of RAM.
  6. catmistake


    well... tried as you suggested and also mixed with the other settings I list above, but so far, I'm seeing no difference.

    Curious... what leads you to believe this?
  7. dippyskoodlez

    dippyskoodlez Bit Poster


    You do know darwin has no UI right? ;)

    Its really just the "essential" files thats necessary to "start" a computer.

    You may want to look into a distrobution that used this as a base, though.

    Not very beginner friendly.
  8. catmistake


    Well... for starters, there's the cli... that's a UI, isn't it? And... once its up, you can use Darwin ports (er.. MacPorts now), or pkgsrc, or GNU-Darwin, or fink to slap on gnome, or wmaker, or kde or whathaveyou, if you want a gui

    its more than that... its a legitimate bsd operating system, but one with limited driver support.

    OpenDarwin is the only one I'm aware of... and I can't find their install disk... and they quit last summer.

    Its no less 'beginner' friendly than NetBSD, or Gentoo, or Solaris. If you want to know Darwin OS, the only place to start is with Darwin proper.

    C'mon man... interest in it is weak enough as it is without discouragement.
    Last edited: Jun 10, 2007
  9. catmistake


    I think I found a reason why Darwin may never work in a Parallels vm...

    Does Parallels support EFI firmware and the SSE2 instruction set? If not, that could be the show stopper. If so, then the show must go on...

Share This Page