Deleted Parallels NAT adapter ... how to create another?

Discussion in 'Installation and Configuration' started by SatchelL, Jul 20, 2009.

  1. SatchelL

    SatchelL

    Messages:
    3
    I was having trouble with some wireless configuration on my Mac and some tech support guy deleted my Parallels NAT adapters. Now I can't access the network from within Parallels.

    "Bridged" is the only option available, and it's not working for me.

    The docs state that the NAT adapter is created when Parallels Desktop is installed, but I can't find any mention of how to create it separately.

    Any suggestions would be very appreciated.
     
  2. desgael

    desgael

    Messages:
    344
    In your case, the only way is to reinstall Parallels Desktop application, this would automatically recreate Parallels adapters. Your virtual machine would not be affected by this process.
    You would need the latest .dmg package. For Parallels 4.0 you can get it from our site: http://www.parallels.com/download/desktop/
     
  3. SatchelL

    SatchelL

    Messages:
    3
    Making progress ...

    OK, that worked. Thanks!

    I reinstalled Parallels Desktop and got the network adapters back (Parallels NAT and Parallels Host-Guest).

    Now I can't get Windows to connect the internet through my wireless connection.

    It has been nine months or so since I set up networking through Parallels, so I don't recall how it was configured, or if there are additional steps required with Parallels.

    Can you point me in the right direction to connect?
     
  4. galochka

    galochka

    Messages:
    187
    Hello SatchelL,

    Open Confugire -> Network adapter -> try to switch from Shared Networking to Bridged Ethernet
    Also Parallels Desktop Menu-> Parallels Desktop-> Preferences-> Network-> restore defaults
     
  5. SatchelL

    SatchelL

    Messages:
    3
    It's working now.

    I'm using Parallels Desktop 3.0. (I didn't see an option to restore defaults under the preferences.)

    I changed to Bridged from Shared in the VM config, but after trying all kinds of permutations under the Devices menu, I decided to create a new Network Adapter. I made it Bridged, specified the Airport/Wireless adapter (en1), and deselected "Connect cable at startup". Then once the VM started, I went to the Devices menu, and under Network Adapter 2, I select "Connect". Now it works. I can go back and change the config to connect at startup, and save a step.

    Now I need to find the knucklehead who deleted my network adapters in the first place ... argh.

    Thanks for the help, everyone.
     

Share This Page