Direct Bluetooth not working on Apple M2

Discussion in 'Windows Guest OS Discussion' started by Vmatz, Mar 12, 2023.

  1. Vmatz

    Vmatz Bit Poster

    Despite correctly configured VMs on my MacBook M2 cannot find Bluetooth devices.
    Of course, I activated "Direct access". In line with
    Of course, all access permission are set to allow. On line with
    I tried with different bluetooth headsets.
    I tried with Win 11 ARM as well as Ubuntu 22.10 ARM64.
    I had Parallels Support remote access my MacBook to confirm and double check. They also don't seem not to be able to find an issue.

    To me it seems to be a bug. Anyone else having this issue on Apple silicon?
  2. Charlon

    Charlon Bit Poster

    I have the same problem, I have a macbook pro m2 max.
    I tried pairing with my xbox controller and also plugged in.
    I tried with a JBL bluetooth headsets.
  3. Vmatz

    Vmatz Bit Poster

    I opened a support ticket.
    Would be good to hear from others to give it more weight.
    Charlon likes this.
  4. Charlon

    Charlon Bit Poster

    Please support, fix this problem... <3
  5. Tharun@P

    Tharun@P Moderator

    Hello @Vmatz , We would like to inform you that Intel-based applications and drivers for Intel chips or hardware for Intel chips are not supported on M1/M2 chips since Apple developed theirs based on the ARM architecture. You can try the steps from this link: to troubleshoot your issue. If the issue persists, then please contact the respective application support or hardware support and check with them if their application or hardware will work on the ARM OS with the M1/M2 chip. Parallels cannot simulate an Intel application or hardware to work on the M1/M2 chip. It has to be done by the respective application or hardware provider. Thanks.
  6. Vmatz

    Vmatz Bit Poster

    Thank you @Tharun@Parallels, I don't see the above relevant.
    - The kb article describes software and drivers. This is well known. How the above relates to hardware, I cannot follow. I am not aware of external hardware built for intel or built for ARM. On the hardware level using standardised interfaces such as USB, Bluetooth, etc. the CPU architecture is not relevant, afaik. Can you please elaborate?
    - The hardware I am using can directly connect to the Mac under MacOS. Hence, on a hardware layer thee is no issue.
    - In the VM - WINDOWS or Ubuntu makes no difference - the OS cannot even find/see Bluetooth hardware, let alone pair. This is before drivers and applications become relevant.

    Happy to hear your qualified feedback!!
  7. FritzTwo


    I have the same problem.
    I use MacBook Pro M2.
    Please find a solution. Thank you.
  8. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Thank you all for your feedback. We've submitted the issue to our developers. I advise you to subscribe to to get the notifications about new Parallels Desktop fixes.

Share This Page