DirectX 11 Support (list of app titles)

Discussion in 'Parallels Desktop for Mac Feature Suggestions' started by Dmitry@Parallels, Apr 20, 2017.

  1. KennethE1

    KennethE1 Bit poster

    After upgrading to Parallels Desktop 15 and Catalina, my light design software Dialux Evo 8.2 is no longer starting up. I appreciate if you could look into it, since I use it daily at work...
  2. alev

    alev Parallels Team

    Hi KennethE1, we will take a look.
    KennethE1 likes this.
  3. KennethE1

    KennethE1 Bit poster

    Much appreciated and thanks for the quick response!
    I found a link on dialux forum that has similar problem, but he is running native windows and a dedicated graphic card.

    My specs:
    MacBook Pro (Retina, 13-inch, Late 2013)
    2,8 GHz Tokjerners Intel Core i7
    16 GB 1600 MHz DDR3
    Intel Iris 1536 MB
  4. TylerC4

    TylerC4 Bit poster

    Has anybody been able to get AutoCAD and it's verticals to utilize DirectX 11 in Parallels 15? I tried running AutoCAD and AutoCAD Civil3D with Parallels 15, but I couldn't turn on hardware acceleration in AutoCAD.
    I'm using a late 2016 MacBook Pro 15" running the latest version of Catalina
    Radeon Pro 455
    16 GB LPDDR3
  5. ChrisE5

    ChrisE5 Bit poster

    Hi @alev and other Parallels developers,

    Could I please get a response on the DX11 to Metal crash stack trace that I posted earlier in this thread? I was a trial user, but received no response during my 14 day trial period. I'm not sure how you can list this feature as complete when many users are still reporting issues.

    If you would support me, I would happily become a paid user.

  6. CraigM5

    CraigM5 Junior Member

    *** SOME SUCCESS ***
    After having another try at upgrading to Mojave since Catalina was just released I experienced some frustrating troubleshooting, but ultimately had some success. Upon upgrading this time I was surprised to find that I wasn't experiencing the same disconnection with an "authentication to instance" error. I was surprised but happy and continued to then make other necessary adjustments to other things like updating mail database etc. I ran an update and things still seemed fine, but then I was prompted for another update, after which I was back to experiencing the same problem albeit not every time, usually I can load up a Toon in Path of Exile on the second attempt. But there is still something else going on because loading new areas is slower and can lead to disconnection by taking too long. I rolled back in an attempt to identify the patch level where things seemed to be fine, but in the end I couldn't be sure. So I've ended up at 10.14.6 at this stage.

    HOWEVER, I have noticed that if using the Apple OS Hypervisor instead of the Parallels Hypervisor I no longer experience the disconnection issues. Interestingly I've not noticed any significant or even minor negative performance mismatch between using the Apple Hypervisor. Indeed at this stage, I'm not experiencing the disconnection issue AT ALL, and game performance is as good as ever. Upon enabling the resource monitor provided by Parallels I've noticed that although there's no concerning difference in CPU usage, there's a considerable difference in RAM usage on the part of the Parallels Hypervisor.

    When running with the Parallels Hypervisor the Parallels Monitor indicates approximately 45% to 55% CPU usage during most normal gameplay, this is in keeping with the Apple Hypervisor. However RAM usage is reported as fractionally over 9GB (in the windows client) and an additional 12GB in the Host machine.

    This is compared to the Apple Hypervisor session which will report approximately 6GB in the client VM and no discernable additional RAM on the Host. With or without the windows paging file enabled there's no difference. In fact I'm concerned that the Parallels Hypervisor session appears to be using more RAM than the client machine can have when I've disabled the paging file.

    I will probably move up to Catalina when I've found a suitable replacement for a couple of other applications that are not 10.15.x compatible. But at this stage my resolution seems to be use the Apple Hypervisor for the present. I'll keep checking with each Parallels update, as well as 10.14.x update. I'm just not wasting anymore time troubleshooting at this stage.

    Attached Files:

  7. LewisF2

    LewisF2 Bit poster

    Thanks for your work so far!

    Been playing the new Halo : Master Chief Collection. When I play in bootcamp, on 1080p, "performance" graphics settings I'm getting a silky smooth 60FPS. When I play in parallels, I'm lucky to get 20 FPS and its more choppy than a set of kitchen knives. Obviously part of me is thinking this is an optimisation issue, but I'm not sure for who. It requires DX 11 (which is now a thing for us, YAY!) and the devs have specifically came out to say they've made it to play on as many different and legacy machines as possible, so as far as it being demanding, it's no where near other AAA titles coming out this year. It works in bootcamp well so hardware shouldn't be the issue. Any chance you guys could look into this and see if there's anything you can do?

    For reference:
    15" MBP 2018: 2.9 GHz i9, 32GB RAM, 560X 4GB, OSX Catalina, Parallels 15 Pro -> Win 10

    Thanks again :)
  8. Dmitry@Parallels

    Dmitry@Parallels Parallels Team

    Hi @LewisF2, to ensure that your Windows virtual machine shows the best performance, please follow the steps below:
    1. Shutdown Windows virtual machine.
    2. Open virtual machine's configuration > click "Change..." button > select "Games only" profile > click OK.
    Note: This profile changes macOS and Windows sharing settings. If you want to enable Shared Applications and Shared Profile, visit Options tab > "Sharing" and "Applications" settings respectively.

    Also please check in-game settings and try to lower resolution and graphics quality. Hope that it helps!
  9. yil1

    yil1 Bit poster

    [QUOTE =" Dmitry @ Parallels,岗位:821316,成员:170619"]由于Mac的Parallels Desktop 15支持DirectX 11,因此该列表现在涉及性能问题,可以改进。

    请注意,某些应用程序仅可在macOS Catalina上运行,而Apple在其中实现了更多功能。
    在macOS Catalina和ATI Radeon显卡上也可获得最佳性能。

    • Autodesk Revit 2020(可在Parallels Desktop 15中使用)
    • Autodesk 3Ds Max 2020(可在Parallels Desktop 15中使用)
    • Autodesk硬件加速(可在Parallels Desktop 15中使用)
    • Lumion(在Parallels Desktop 15中工作)
    • ArcGIS Pro 2.3(可在Parallels Desktop 15中使用)
    • Master系列(可在Parallels Desktop 15中使用)
    • 洛克希德·马丁Prepar3D

    • FIFA 19(在Parallels Desktop 15中运行,需要macOS Catalina)
    • 图灵测试(可在Parallels Desktop 15中使用)
    • Madden NFL 19(可在Parallels Desktop 15中使用)
    • 《战地风云1》(可在Parallels Desktop 15中使用,但存在时滞)
    • 使命召唤:黑色行动3、4(尚未测试)
    • 玩家的未知战场(可在Parallels Desktop 15中使用,但存在滞后)
    • 神界:原罪2(在Parallels Desktop 15中工作)
    • 星海-最后的希望(尚未测试)
    • 黑暗之魂3(尚未测试)
    • 雷神之锤(尚未测试)
    • 汤姆克兰西《彩虹六号:围攻》(需要修复)
    • Halo Wars Definitive Edition(在Parallels Desktop 15中可用,但存在滞后)
    • 高尔夫俱乐部2019(尚未测试)
    • Elite Dangerous(可在Parallels Desktop 15中使用,但有滞后)
    • Kurtpel(尚未测试)
    • Black Desert Online(尚未测试)
    • The Witcher 3(在Parallels Desktop 15中可用,但有滞后)
    • 国家崛起:扩展版(尚未测试)
    • 孤岛惊魂5(可在Parallels Desktop 15中使用,但存在滞后和一些纹理问题)
    • 帝国时代:权威版(可在Parallels Desktop 15中使用)
    • 孤岛危机3(可在Parallels Desktop 14中使用)
    • Apex Legends(可在Parallels Desktop 15中使用,但有滞后)
    • 辐射4(可在Parallels Desktop 15中使用,但有滞后)
    • Elite Dangerous(可在Parallels Desktop 15中使用,但有滞后)
    • 铁路帝国(在Parallels Desktop 15中工作)
    • Anno 2205(在Parallels Desktop 15中工作)
    • 下雨的危险2(在Parallels Desktop 15中运行)
    • 太空工程师(在Parallels Desktop 15中工作)
    • Anno 1800(在Parallels Desktop 15中工作)
    • Frostpunk(可在Parallels Desktop 15中使用)
  10. MattD8

    MattD8 Bit poster

    Cannot get rFactor2 to work on Steam... DX11 compatible but will not lead past Launcher screen.
  11. Maria@Parallels

    Maria@Parallels Problem solver

    Could you collect the tech report right after the issue reproduced please? And post the tech report ID here?
    Also is it possible to make a short video recording of the issue and post or send it to us via the private message?
    Looking forward to your reply.
  12. ae6dx

    ae6dx Hunter

    How well does it run?
  13. JavierC9

    JavierC9 Bit poster

    Hello I want to play call of duty warzone, but I can't enter in the game, all the time is
    directx has suffered an unrecoverable error. Any one knows when is available direct 12??
    I think is the problem, or If someone knows another solution please tell me....
    Damian6 likes this.
  14. Damian6

    Damian6 Bit poster

    I am also unable to launch WarZone and it would be great if you could let us know if it is even a possibility to run with Parallels. With COD's popularity it probably makes more sense for one engineer at Parallels to figure this out instead of hundreds of users wasting hours banging their heads against a wall. If it's not possible, great, I'll move on.

    They have a couple of commands you can run in BattleNet to switch to Direct X 11 using the
    GameOptions->GameSettings->Additional command line arguments

    Neither of these seem to work and still get the direct X unrecoverable error. In all fairness, this error is fairly prevalent with PCs too, but at least there are usually know work arounds for those. On the PC there are reported issues with RTSS (Riva Tuner Statistics) and overlays. Maybe that's related to Parallels issues?

    Also I find it a little weird that if I run dxdiag on Windows it tells me in the system info I am running in DirectX 12, but in Display it looks like its DirectX 11.

    Thanks in advance.
  15. AlexS33

    AlexS33 Bit poster

    Crossout, please! Doesn't work properly on PD15 or PD16, with a broken screen full of artifacts...
  16. CricT

    CricT Bit poster

    With the addition of the Metal 2 API in "High Sierra" it should be possible to get the full DirectX 12 feature set.
    But note that for those games, being able to use more than 2GB VRAM is also important. I'd like to see that increase to 4GB at minimum, but if the only limitation is my physical RAM
    This will give the windows VMs a real boost in graphics compatibility and performance.
    Last edited by a moderator: Dec 18, 2020
  17. KaruK

    KaruK Bit poster

    Is GTA 5 still working?
  18. PaulD23

    PaulD23 Bit poster

    Hey Guys,

    dont know if this is D11 or D12. But can we maybe get support for Diablo II Ressurected. I get the Error, Failed to initialize graphics device. Please ensure your PC meets the minimum system requirements and your drivers are up to date.

    Im on MacBook Air with M1.
    Maria@Parallels likes this.
  19. Maria@Parallels

    Maria@Parallels Problem solver

    Hi, could you collect the tech report once the issue reoccurs and post it here please?
    Looking forward to your reply.
  20. PaulD23

    PaulD23 Bit poster

    Hey thanks for the reply. The ID is 380023250

Share This Page